Results 1 to 15 of 15
  1.    #1  
    I'm having a problem with mms messaging with my unlocked gsm pre2 on t-mobile's service.

    I can send/receive pictures through mms, and while the pictures I send are received on other phones as full size images, the pictures that I receive are only tiny thumbnails.

    There is a post about this on the pre and pre plus forum (I posted there too), but it's really old, and my phone is a pre2 so I thought I'd post here too.

    I talked to tmobile. I appear to have the correct settings. I don't believe that this is a tmobile issue. My mom has a different phone on tmobile's network, and she gets full sized mms pictures.

    It also takes a really long time for mms messages to send. More than 5 minutes, on average.

    So.. does anyone else have a pre2 on tmobile, and are you able to receive full size mms messages? If yes, can you please check your settings and let me know if they are different from mine?

    My current settings:
    APN: epc.tmobile.com
    MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
    Proxy: 216.155.165.50:8080

    Max limit is set to 300, this is what tmobile guy said it should be. I tried changing it to 1000 at one point, made no difference at all.

    Before I had these settings, there were other settings that were somehow already there -- I was still able to send and receive mms messages with the other settings (the received mms pictures were still just tiny thumbnail images), though the phone told me that the settings were not valid whenever I tried to do anything with them.
    APN: wap.voicestream.com
    MMSC: http://216.155.174.84/servlets/mms
    Proxy was blank
  2. #2  
    you are only on 2g, so they probably reduce file size.
  3.    #3  
    Thanks for your response!

    I guess that it is possible it has to do with the 2G thing, but I think unlikely -- For one thing, the Tmobile guy I talked to couldn't find anything about them having a network setting that would change the size of an MMS picture. My last phone (sony g900) was only 2G as well, and it could receive full size mms images.

    Also, I could be confused about this, but I didn't think mms used a data connection at all. Data and MMS are separate settings, aren't they? Does MMS use 3 or 4G if it's sent on a phone that has a 3 or 4G connection?
  4.    #4  
    I still can't find any answers to this.. Is there anyone else who has the pre2 on tmobile? I would like to know if there are other people with this issue, or if I'm the only one...
  5. rumz's Avatar
    Posts
    205 Posts
    Global Posts
    220 Global Posts
    #5  
    I'm having the same issue with the Pre3 on T-Mobile.

    Reading elsewhere on the web, I'm led to understand that there's a User Agent reported to the carrier by the handset in association with MMS, and that if the user agent reported is not recognized as a supported handset in T-Mobile's system, they automatically downsize the image quality, which is why we're getting these thumbnail-size images (which appear pixelated / blurry when viewed full screen).

    (This is something I've gleaned from some Android forums-- apparently their messaging app has a user agent field or some such, and changing this info from a recognized ID results, on T-Mobile, in blurry / reduced resolution incoming MMS images).
  6.    #6  
    Thanks for that information, that makes a lot of sense. I wonder why none of the Tmobile people I talked to knew about this.
  7. rumz's Avatar
    Posts
    205 Posts
    Global Posts
    220 Global Posts
    #7  
    I'm guessing there are just not enough unsupported handsets on T-Mobile for them to really care. I found a hack for the iPhone to do the same thing-- they tell the iPhone to report itself to T-Mobile's MMS system as a "SonyEricssonW800i/R1L".

    T-Mobile Support Community: MMS factory unlocked iPhone 4s ???

    With Android devices it ends up being a temporary but widespread issue with pictures coming over low res (because they are T-Mobile devices and the system apparently just hasn't been updated with the new phone's User agent ID ahead of the device launch)-- then as soon as they update the database with the new Android handset user agent, things work properly again.

    Sounds to me like it's just not a big enough issue / not common enough for homebrew people to even look for a way to do this UA spoofing for MMS.
  8. #8  
    Hmm. I was just responding the other day to a topic just like this one, however, I can't seem to locate it again, so I'll just respond on this one, instead, and maybe I'll find the other one later:

    I just found a setting in Phone->App Menu->Network Services->Manual Settings (On)->Edit Network Settings->MMS APN->Max Size. It defaults to 300. I've just moved the setting up to 600, and thought I'd see what happens. Now, I need someone to send me a MMS. Anyone game?


    * edit: never mind. Every time I hit "Change Settings" it comes back a couple of seconds later, and gives me "Invalid Settings". Anyone able to locate settings that will work?

    So, it would appear that we -are- capped on the quality of incoming MMS.
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  9.    #9  
    Two things:

    1) Changing this setting didn't actually change anything for me. I still only received tiny MMS images.

    2) There are two different APN settings I can use, and both work, though one of them always says Invalid Settings. The one that is filled in automatically is the one that says invalid settings if I try to change anything. If I hit ok anyway, it works. Very odd.


    Quote Originally Posted by eblade View Post
    Hmm. I was just responding the other day to a topic just like this one, however, I can't seem to locate it again, so I'll just respond on this one, instead, and maybe I'll find the other one later:

    I just found a setting in Phone->App Menu->Network Services->Manual Settings (On)->Edit Network Settings->MMS APN->Max Size. It defaults to 300. I've just moved the setting up to 600, and thought I'd see what happens. Now, I need someone to send me a MMS. Anyone game?


    * edit: never mind. Every time I hit "Change Settings" it comes back a couple of seconds later, and gives me "Invalid Settings". Anyone able to locate settings that will work?

    So, it would appear that we -are- capped on the quality of incoming MMS.
  10. #10  
    I have the same problem, it seems ua spoofing is the way to go. Does anyone know how to write a patch?
  11.    #11  
    Quote Originally Posted by carguy303 View Post
    I have the same problem, it seems ua spoofing is the way to go. Does anyone know how to write a patch?
    I wish I did, but no. People created a UA spoofing patch for the internet browser.. I wonder if that would have any effect on MMS? Or is that completely unrelated?
  12. #12  
    Totally unrelated. I'd be reasonably certain that the sevice is screwing us. It's probably screwing everyone, T-Mo's service absolutely sucks.
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:
  13. #13  
    No I think you're on to something with the UA spoofing, I had a similar problem with an HTC HD2 that I had running android and I had to spoof the phone to the nexus one. And I actually like T-Mobile service. It works great in the chicagoland area.
  14. #14  
    now mms just isn't working at all. Whats wrong with this?
  15.    #15  
    Quote Originally Posted by carguy303 View Post
    now mms just isn't working at all. Whats wrong with this?
    Did you do something before mms stopped working? Or did it just spontaneously stop working for you?

    Also, do you have data turned on? Even though mms doesn't use or require a data plan, my phone refuses to send or receive mms messages unless data is turned on.

Tags for this Thread

Posting Permissions