Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 64
Like Tree8Likes
  1. tcurtin's Avatar
    Posts
    150 Posts
    Global Posts
    151 Global Posts
    #41  
    I'm about to do the Sprint Pre- to FrankenPre2 myself, and one thing (so far) confuses me about the directions. There's specific mention that you can't use cygwin on windows to run the metadoctor scripts, but windows is still in the descriptions as though it is supported. Can someone let me in on how to run the scripts without cygwin? (Not having the phone yet, I haven't tried - hopefully it isn't as simple as just double-clicking, 'cause that'll make me feel silly.)

    Anyone? I don't have a linux machine handy, so I'm really hoping that's not the only option...
  2. #42  
    I used Linux. I had to install it from Win7.
  3. tcurtin's Avatar
    Posts
    150 Posts
    Global Posts
    151 Global Posts
    #43  
    Quote Originally Posted by daffy4u View Post
    I used Linux. I had to install it from Win7.
    Wait - I'm not sure I understand. You installed the MetaDoctor from Win7, or installed linux from win7?

    Sounds like I may have to dig up a machine to convert...
  4. #44  
    Quote Originally Posted by tcurtin View Post
    Wait - I'm not sure I understand. You installed the MetaDoctor from Win7, or installed linux from win7?

    Sounds like I may have to dig up a machine to convert...
    I installed Linux from Win7 then used Linux to create and run the custom Meta-Doctor.
  5. hankbuddy's Avatar
    Posts
    48 Posts
    Global Posts
    52 Global Posts
    #45  
    Quote Originally Posted by tcurtin View Post
    I'm about to do the Sprint Pre- to FrankenPre2 myself, and one thing (so far) confuses me about the directions. There's specific mention that you can't use cygwin on windows to run the metadoctor scripts, but windows is still in the descriptions as though it is supported. Can someone let me in on how to run the scripts without cygwin? (Not having the phone yet, I haven't tried - hopefully it isn't as simple as just double-clicking, 'cause that'll make me feel silly.)

    Anyone? I don't have a linux machine handy, so I'm really hoping that's not the only option...
    Go to the webOS Internals wiki page. There are instructions there, including how to set up a safe dual boot environment with ubuntu linux on your windows machine. Application:MetaDoctor - WebOS Internals You then do all the work on updating your phone in linux. It is not as daunting as it sounds. Most of the commands you will have to use can just be cut and pasted from the wiki page, and the environment inside ubuntu isn't all that foreign or difficult to figure out for most people familiar with windows or mac os.
  6. tcurtin's Avatar
    Posts
    150 Posts
    Global Posts
    151 Global Posts
    #46  
    Just wanted to let everyone know that my conversion worked fantastically. Holy crap, this is such an improvement over the Pre-! (Voice dialing, all by itself, is pretty much worth the price of admission. Not to mention the Just Type improvements, more solid build quality, speed...)

    Now, if only the launcher was patchable the way 1.4.5 was. I really miss having so many icons on one page and being able to click the page name to jump to another.
    daffy4u likes this.
  7. ThePhat1's Avatar
    Posts
    46 Posts
    Global Posts
    48 Global Posts
    #47  
    Finally got around to doing my conversion this morning -- used a Verizon Pre 2. Everything went well except I couldn't get one of of those blasted sliding tabs back into place properly so that it lays flush on the Pre 2's keyboard. Aside from that minor annoyance, overall the upgrade went smooth as butter. Only thing that would make me happier than my FrankenPre 2 would be a Pre 3, but I digress...
  8. scobb's Avatar
    Posts
    56 Posts
    Global Posts
    95 Global Posts
    #48  
    Another working Verizon to Sprint Franken Pre2 here. I used the script meta-sprint-franken-verizon-pre2-2.1.0. Defice info says I have 2.1.0. However, it says there is an OTA update to 2.1 available for me. It is not clear from the documentation why this should be. Is it OK to take the OTA update? Will it undo the Franken bits?

    Also, I successfully transferred my Sprint PRL using the /media/internal/my_1.4.5_prl_backup.tar.gz trick. However, Device info says my carrier is Verizon. I have sprint on the default menu and the PRL says 60861 - and the phone calls and accepts calls just fine. Is it just an odd side affect to have device info say Verizon?

    Thanks to all involved in this process.
  9. #49  
    Another Sprint FranenPre2 here...

    The wiki does talk about the OTA update, if you look at the portion regarding Voice Dialing, it states that when you Franken Pre your Pre2 the voice dial will not work, you will get an OTA update notice, after installing the update the voice dial works.

    WebOS 2 Upgrade - WebOS Internals

    I bought a Verizon Pre2 on E-bay and just made the swap on Saturday. The longest part of the whole deal was installaing Ubuntu. Ubuntu did not want to install on my main computer using wubi, it would boot and give me a bunch of errors. I ended up digging out an older PC and just installed Ubuntu on it. Then created the MetaDr and Dr'd the Pre2. Then went back to my main PC to install Sprint Navigation, and restore backups, etc...
  10. scobb's Avatar
    Posts
    56 Posts
    Global Posts
    95 Global Posts
    #50  
    Thanks - yes indeed. I didn't care about VoiceDialing, so I kinda glossed over that. Again - read the documentation many times :-)

    I too found the most time consuming part to be Ubunto and getting it installed and updated.

    To people on Windows, I would suggest getting a solid Ubuntu install on your system long before buying the pre2.
  11. #51  
    Okay so got my unlocked Pre 2 and making sure I got this in the righ order to frankenpre this bad boy with my Pre-: (I am probably just overthinking this like soccerbudd, but the software part I want to make sure is done right and not lose anything)

    1) backup the device and turn off backups, use APP:SaveRestore, move contacts off just in case as told on Wiki. (going to go without clearing profile and hope that works). The Definitive Guide to Backing up and Restoring your webOS Device | The #1 HP webOS, TouchPad, Pre, and Veer Community | PreCentral.net
    2) update Sprint PRL on pre- and then do the tar backup and save off of phone to PC. Sprint PRL Update - WebOS Internals
    3) Get MetaDoctor on my Ubuntu PC installed and ready to go. Application:MetaDoctor - WebOS Internals
    4) swap the hardward (this looks like the easy part) Sprint Pre 2 - WebOS Internals
    5) Run device-specific MetaDoctor script = Sprint Franken Unlocked Pre 2
    6) Run the modified webOS Doctor which the metadoctor script will startup for you. Updating to 2.0.1 cause I read that going straight to 2.1 had voice dial problems? So 2.0.1 then let it OTA to 2.1.
    7) Install/correct Sprint Nav
    8) Install preware and restore applications data from SaveRestore app.
    9) make sure to donate to WEBOS INTERNALS!

    What if anything besides PRL update which has to be done manually and the other Sprint bloat apps won't work with this frankenpre? Sounds like OTA updates are okay since everyones voice dial works after 2.0.1 to 2.1 update. Or will we have to metadoctor updates on this device from here on out?

    I think the confusing part on Wiki is having instructions for putting WebOS ver. 2.x on a pre- in with the changing comm boards and updating frankenpre's to 2.x. Or again I am just over thinking all of this. :-|

    Thanks

    JMAC
  12. giggles's Avatar
    Posts
    677 Posts
    Global Posts
    690 Global Posts
    #52  
    Quote Originally Posted by scobb View Post
    Thanks - yes indeed. I didn't care about VoiceDialing, so I kinda glossed over that. Again - read the documentation many times :-)

    I too found the most time consuming part to be Ubunto and getting it installed and updated.

    To people on Windows, I would suggest getting a solid Ubuntu install on your system long before buying the pre2.
    Good thing I already have windows 7 ult and ubuntu 11.04 dual booted huh? Hahaha so all of this should only take a few mins?
  13. #53  
    I had some issues with installing ubuntu, but I was able to overcome them.

    1) After installing ubuntu, I had a big holdup with booting up Ubuntu, as I would just get a blank/black screen during boot up.

    I think it Ubuntu freaked out with my video card and/or my dual monitors.

    Fortunately, instructions on this link fixed it, Ubuntu 11.04 blank screen on boot. SOLVED.

    Try these steps if you are experiencing a blank screen during boot or install of Ubuntu 11.04 Natty Narwhal.

    1. LiveCD boots into a blank screen.

    When you see the boot menu when you boot LiveCD, hit F6 and select the “nomodeset” option.

    2. Boots into a blank screen after install.

    Reboot and keep your finger on the “SHIFT” key till you get the grub menu. Highlight the first entry and replace “quiet splash” with “nomodeset” . Hit CTRL + X to continue booting. Once logged in install the latest Graphics drivers. System -> Administration -> Additional Drivers

    DONE. Hope it works for you, it did for me.

    2) Second issue, which is probably a n00b mistake by me, is that during the ubuntu Windows Installer, I set the installation size too small (2GB). Don't make this mistake, make sure it's at least 10 Gigs. I set mine to 17GB to be safe.


    All in all, my Sprint Pre 2 works great and i love it! I admit, i was originally turned off by the fact it looks sooo similar to the orginal pre, and the Pre 3 announcement really stole the Pre 2's thunder. Well since, there's almost no chance of a pre 3 or veer coming to spring, Pre 2 suddenly became of interest. I'm glad I made the switch, it's awesome. If you've been using the pre minus for the last 2 years or whatever, upgrading to this device is just a wonderful feeling
    Last edited by BAUERMUNDO; 09/12/2011 at 02:37 PM.
  14. #54  
    Quote Originally Posted by jmccrary View Post
    Okay so got my unlocked Pre 2 and making sure I got this in the righ order to frankenpre this bad boy with my Pre-: (I am probably just overthinking this like soccerbudd, but the software part I want to make sure is done right and not lose anything)

    1) backup the device and turn off backups, use APP:SaveRestore, move contacts off just in case as told on Wiki. (going to go without clearing profile and hope that works). The Definitive Guide to Backing up and Restoring your webOS Device | The #1 HP webOS, TouchPad, Pre, and Veer Community | PreCentral.net
    2) update Sprint PRL on pre- and then do the tar backup and save off of phone to PC. Sprint PRL Update - WebOS Internals
    3) Get MetaDoctor on my Ubuntu PC installed and ready to go. Application:MetaDoctor - WebOS Internals
    4) swap the hardward (this looks like the easy part) Sprint Pre 2 - WebOS Internals
    5) Run device-specific MetaDoctor script = Sprint Franken Unlocked Pre 2
    6) Run the modified webOS Doctor which the metadoctor script will startup for you. Updating to 2.0.1 cause I read that going straight to 2.1 had voice dial problems? So 2.0.1 then let it OTA to 2.1.
    7) Install/correct Sprint Nav
    8) Install preware and restore applications data from SaveRestore app.
    9) make sure to donate to WEBOS INTERNALS!

    What if anything besides PRL update which has to be done manually and the other Sprint bloat apps won't work with this frankenpre? Sounds like OTA updates are okay since everyones voice dial works after 2.0.1 to 2.1 update. Or will we have to metadoctor updates on this device from here on out?

    I think the confusing part on Wiki is having instructions for putting WebOS ver. 2.x on a pre- in with the changing comm boards and updating frankenpre's to 2.x. Or again I am just over thinking all of this. :-|

    Thanks

    JMAC
    Hey everyone, I've got my Pre 2 and I'm at step #2 above:

    "2) update Sprint PRL on pre- and then do the tar backup and save off of phone to PC. [url=http://www.webos-internals.org/wiki/Sprint_PRL_Update]Sprint PRL Update - WebOS Internals"

    However, I'm unable to complete it. I've downloaded novacom and installed the drivers and I've downloaded novaterm. I searched webosinternals and made sure I had the 64bit version of novaterm because I have a Windows 7 64bit machine etc.

    The instructions to "update the PRL" did not pan out: there was no "Preferences & Accounts" in the phone app, so I went to the "Phone Services" icon and found "Update PRL" at the bottom. I'm hoping that's the same as in the instructions below (but I HATE when instructions are not the same as what I find! Anyway...) Here is the exact step to check the PRL:

    *******************************************
    Procedure
    Step 1

    While your Pre is still running webOS 1.4.5, update PRL:

    1) Phone --> App-Menu --> Preferences & Accounts --> Update PRL


    NOTE:
    As of April 21st 2011, some people are getting PRL# 01115, and others are getting PRL# 60678.
    It is unknown why at this time.
    The 01115 has some data roaming changes in it that boost data rates for some customers in certain areas.
    Unofficial changelogs can be found here.


    After this, check to make sure that you have "prefroamlist" on your phone:

    1) Plug your Pre into your computer. DO NOT put it in USB Mode.
    2) Run novaterm (will open a Linux shell to your phone).
    3) cd /var/lib/software/ModemFiles
    4) ls

    You should see a file named "prefroamlist". This is your PRL file.
    ***********************************

    I've put the confusing part in BOLD. When the black screen opens (I think that's the command line, yes?) it has the "localhost" in the box, but when I click "Connect," it always fails. I've also tried typing "3) cd /var/lib/software/ModemFiles" several times but it also always fails (I've also tried closing the gap between "cd" and "/var...", but no luck. Did I mention I really get frustrated when this stuff is vague?!...)

    So, how do I get this to work to find the "prefroamlist" file and thus make sure I have updated the PRL file?

    Thanks! (And I haven't even tried to install the Zulu file yet....or Ubuntu or whatever it's called...)

    Edit: Alright, while I'm waiting for a response to the PRL problem, I tried to find and install Ubuntu. Good luck. Another round of ambiguity. The "Application: Metadoctor" page on webosinternals says to download the "Desktop Edition," but that's nowhere to be found on the Ubuntu home page. Is it merely the default download? Also, there's an option for 32-bit and 64-bit--normally, I'd match my machine, of course, but it says 32-bit is recommended. So which is correct?

    Edit #2: O.K., sorry about the whining, folks--I've calmed down a bit...time for bed, see you tomorrow for more fun!
    Last edited by Pre in MN; 09/23/2011 at 11:46 PM.
  15. giggles's Avatar
    Posts
    677 Posts
    Global Posts
    690 Global Posts
    #55  
    ^you made this alot harder than it already is and its best to follow the web os internals guide. anyways Heres how how update prl, for a pre 2 or pre.

    http://forums.precentral.net/palm-pr...print-prl.html

    21081 and 60681 are the newest ones.
    Last edited by giggles; 09/25/2011 at 08:22 AM.
  16. #56  
    Thanks, giggles, I do "overthink" this sort of thing because I'm trying to avoid frustration and problems (and loss of time) later on; from experience, I've learned that the details matter for this sort of thing, so thanks for indulging me and being patient while I navigate these rather scary procedures.

    Anyway, right now, my Pre minus says its PRL is "60681." Is that newer than 21081 or 60680? It would seem to be the next one after 60680, but I've learned not to assume anything.

    Also, I'm assuming (!) that update Sprint PRL thread (which I must admit was confusing given all the responses) is only relevant to what we do AFTER we swap and activate our Pre 2--correct? Thanks!

    (Sorry, but you can rest assured that I'm not done asking questions--should prove to be a long weekend...)
  17. #57  
    Quote Originally Posted by Pre in MN View Post
    Thanks, giggles, I do "overthink" this sort of thing because I'm trying to avoid frustration and problems (and loss of time) later on; from experience, I've learned that the details matter for this sort of thing, so thanks for indulging me and being patient while I navigate these rather scary procedures.

    Anyway, right now, my Pre minus says its PRL is "60681." Is that newer than 21081 or 60680? It would seem to be the next one after 60680, but I've learned not to assume anything.

    Also, I'm assuming (!) that update Sprint PRL thread (which I must admit was confusing given all the responses) is only relevant to what we do AFTER we swap and activate our Pre 2--correct? Thanks!

    (Sorry, but you can rest assured that I'm not done asking questions--should prove to be a long weekend...)
    @ Pre in MN

    Yes, PRL 60681 (as far as I know) is the most recent version. I updated PRL few days ago (while doing the frankenpre conversion) and that was the PRL updated in the phone.
  18. #58  
    O.K., I'm done and I have a Sprint Pre 2 running 2.0.1! Yay! Whew!

    Spent the whole day doing this, starting around 2 pm and it's now almost 1 am. Dang. Forget the idea that it's easy--at least for people who have only heard about Linux (but don't know how to pronounce it) and have never heard Ubuntu (but have never seen it run on a PC, much less did the whole "Terminal" thang with meta-doctor etc.)...

    Sheesh, guys, so much ambiguity and missing steps and going back and forth to threads and picking and choosing the best aspects/steps/advice of the swap videos and breaking the dang volume rocker (but had two, of course) and....

    Luckily, I had a Touchpad to load up stuff to get double screens going!

    So I'm updating to 2.1 right now and I'm going to do the Sprint PRL, Nav, and Flash stuff.

    But I'm still confused about the PRL: my new Sprint Franken Pre 2 says it has 60681, just like the Pre minus had before I destroyed it. But giggles' "Sprint PRL" thread says 21081 is the latest. And that "Files of oostah" site doesn't list 21081 for Sprint. So, confused. Anyone know I should do?

    Anyway, thanks to everyone involved in this adventure! renck, giggles, and everyone! Love this site and love webosinternals and all the developers (but just wish y'all would watch rookies like me sitting down to follow your instructions so you could see where we get confused etc. and then tweak your tutorials...jus' sayin'.... )

    Edit: Well....I was able to install Sprin Navigation, but I can't install...Preware! I get the "No Packages Found" error in WebOsQuickInstall 3.14, 4.2.3, and 4.3.1. What's up with that? Why doesn't good 'ol Preware show up for installation?! I reinstalled novacom, and opened and closed WOSQI several times and no Preware. Go figure.
    Anyone have a clue about this?! Thanks!

    Edit: I should note that, when trying 3.14, is actually does show up, but after I download it and then hit "install," I get an error. On both of the later versions, Preware doesn't even show up.
    Last edited by Pre in MN; 09/25/2011 at 01:48 PM.
  19. Ziplock's Avatar
    Posts
    243 Posts
    Global Posts
    249 Global Posts
    #59  
    If your on 1.4.5 , there is a patch that will put all ur contacts in a file and just import that file into google contacts.
  20. giggles's Avatar
    Posts
    677 Posts
    Global Posts
    690 Global Posts
    #60  
    Yha my bad 60681 is the newest one next to 21081. I Think keep it at your pre- because thats what sprint has for your area.

    Try this for exporting on the pre-

    1.) Dial ##66623#
    2.) Tap Cellebrite Export
    3.) When it is done, connect the phone to the computer
    4.) Select USB drive then Open the Palm Pre drive
    5.) Make sure that "Show hidden files and folders" is selected in your pc (folder options)
    6.) Open the TEMP folder
    7.) A file called "PIMmigration" will be inside the TEMP folder, copy this file to the desktop.
    It will show one contact, BUT! now open your gmail, go to your contacts & pick more actions & import the vcard from where you saved it. ALL the contacts will move to Google/Gmail.
    viola! done!
    worked for me. But my palm profile backed up everything but its nice to have a backup on gmail.

    also I saw you point in the webosqi thread, Good job. I dont think this can be a pre2 issue more on a qi issue. Considering its the one gathering the packages. They should be able to help you out.
Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions