Results 1 to 13 of 13
  1. alanh's Avatar
    Posts
    53 Posts
    Global Posts
    54 Global Posts
       #1  
    I'm trying to make a Sprint FrankenPre 2 from a Pre- and unlocked GSM Pre 2. I'm using a MacBookPro running 10.6.7.

    I'm at step 4 on WebOS 2 Upgrade - WebOS Internals and have the Pre2 in recovery mode. The Doctor starts, and I'm at the point where it's asking me to plug in the Pre: http://dl.dropbox.com/u/3186140/Screenshots/wgf5.png

    However, it never detects the device:

    http://dl.dropbox.com/u/3186140/Screenshots/1ycf.png

    I have novacom installed (just installed the SDK). Growl shows "Palm" connecting and disconnecting when I plug/unplug the USB cable.

    I've also tried this on another Macbook and get exactly the same result.
  2. alanh's Avatar
    Posts
    53 Posts
    Global Posts
    54 Global Posts
       #2  
    Progress:

    I had to kill novacomd and restart it as root. The current installation seems to put novacomd in a different location /opt/nova/bin.

    I did the following:

    cd /opt/nova/bin
    ./stop-novacomd
    sudo ./start-novacomd

    Then I also did an sudo to run the sprint frankenpre .JAR that was created by the Meta-doctor. It's running now and is 64% through....
  3. alanh's Avatar
    Posts
    53 Posts
    Global Posts
    54 Global Posts
       #3  
    Meta-doctored, rebooted.... restores are taking forever, but other than that it's looking good! Now to do "step 6" from the instructions...
  4. #4  
    Cool!
    Quote Originally Posted by rwhitby View Post
    We always prefer that people donate in response to tangible items they can use today, rather than for intangible promises about the future that may or may not be possible to achieve.
  5. alanh's Avatar
    Posts
    53 Posts
    Global Posts
    54 Global Posts
       #5  
    One other thing: The white wire from the comm board to the frame became detached during the transplant, but I was able to put it back on the mount. It was the white wire which I think goes to the power button. Future FrankenPre'ers beware of that!
  6. #6  
    Quote Originally Posted by alanh View Post
    One other thing: The white wire from the comm board to the frame became detached during the transplant, but I was able to put it back on the mount. It was the white wire which I think goes to the power button. Future FrankenPre'ers beware of that!
    If I'm not mistaken the both the black and white wires connected to the comm board are the gps wires. You might wanna check to see if your GPS if still working.
  7. #7  
    I also just did the conversion to the pre 2. And so far its great
  8. alanh's Avatar
    Posts
    53 Posts
    Global Posts
    54 Global Posts
       #8  
    Quote Originally Posted by phillyeagles36 View Post
    If I'm not mistaken the both the black and white wires connected to the comm board are the gps wires. You might wanna check to see if your GPS if still working.
    The GPS is working as far as I can tell, so it looks like I'm good. Restoring things it taking about forever though. It downloaded most of the App Catalog items overnight, but 3-4 of them failed. Retrying seems to have worked on those. The phone also rebooted spontaneously 3-4 times which I think is correlated with the failed installs. It also took a long time to sync the Contacts back over, but my memos got restored fine.

    Right now, I'm restoring the file system. It might just be me, but copying via USB seems to be running slowly. I'm only getting about 700KBps or so.

    I installed Preware and SaveRestore is my next step after the FS copy is done.
  9. alanh's Avatar
    Posts
    53 Posts
    Global Posts
    54 Global Posts
       #9  
    One other question: Right before I did this, I ran the PRL update on my old Pre-. I also, just in case, followed the directions for saving the /var/lib/software/* into a .tar.gz. Is it necessary for me to actually install the PRL again at this point or is that something that was saved onto the comm board during the PRL update?
  10. #10  
    Congrats! And I don't think the white wire goes to the power button. I'm pretty sure that both of those wires (the black and the white) are antenna wires. One is for GPS, and I think the other is wifi/bluetooth. I don't remember for certain what antennas they are, but I'm pretty sure both are antennas.
    Twitter: dullgeek
  11. #11  
    i also did a sprint pre 2 conversion on my imac 10.6.7 but im getting randon reeboots on my sprint pre ? any tips
  12. #12  
    I have a Pre and I purchased an unlocked Pre 2 when HP went bonkers and started their WebOS product fire-sales. I may eventually make a FrankenPre conversion but for now, I would just like to know it can be done and maybe try 2.1 on my Pre as a test run.

    I have installed Ubantu but I am hopelessly stuck on running the device-specific scripts and have no idea on how to do a "git pull" and a "make clobber". I also have no idea of how to edit a jar file to conform with the error message I get when I try to apply the meta-doctor to my phone.

    Is there a place to unlock these mysteries and have more fun with my Pre!?
  13. #13  
    Here's a tip that I just (inadvertently) found:

    I was also having the 4% error - the Meta-doctor would get up to 4% and then disconnect. What I discovered was that if I went to the bottom of the Ubuntu screen where the USB connections are listed, right click and you will find the Pre "bootie". Enable it.

    Then, when it says that the connection is lost, go back to the USB connections, and this time it will read "Pre (something or other)" as a USB choice. Enable that, and it should finish.

    **************
    NOW my problem is that I the opening screen constantly cycling and not letting me choose my language!

Tags for this Thread

Posting Permissions