Results 1 to 6 of 6
Like Tree1Likes
  • 1 Post By rwhitby
  1. cfbauer's Avatar
    Posts
    179 Posts
    Global Posts
    206 Global Posts
       #1  
    I'm having an issue with my 3 day old FrankenPre 2 I haven't seen mentioned at all.

    It cuts out when I plug in external speakers, both my car stereo tape adapter and my external speakers connected through the headphone jack.

    If I start any audio playing application, the music plays fine though the internal speaker. Once speakers are plugged in, however, the audio quickly fades out after about a second. Very odd. In addition, the volume rocker buttons that worked fine before plugging in speakers stop working. Pushing them up or down does nothing.

    A phone reset seems to bring the Pre2 back to normal.

    Music plays just fine through its internal speaker and with headphones plugged in.

    I've been using a work around for music during my commute: I plug the speakers into the device, then restart the phone. Without unplugging them, I fire up a music player and everything works.

    I've done lots of testing and have been unable to narrow things down from there, or find any other way to fix the issue. I believe this is unrelated to the known audio bug since I can make and receive phone calls just fine.

    Any suggestions are appreciated. Thanks.
    Last edited by cfbauer; 06/03/2011 at 01:32 AM. Reason: clarification
  2. #2  
    Is the voice dial app launching as well?
  3. cfbauer's Avatar
    Posts
    179 Posts
    Global Posts
    206 Global Posts
       #3  
    Quote Originally Posted by crucian4 View Post
    Is the voice dial app launching as well?
    It is not launching.

    I may see where you're going with that. Smart thinking. On my old Pre minus running 2.1, the voice dial app launched every time I plugged it into speakers.

    On my FrankenPre2 it isn't loading at all, tapping on it either before or after plugging in speakers gives no response.

    I'm researching if there is a task / process manager app available. I might be able to kill a voice dial process that keeps me from using the speakers.
  4. cfbauer's Avatar
    Posts
    179 Posts
    Global Posts
    206 Global Posts
       #4  
    Drat. I downloaded JsTop, but don't see any process open for the Voice Dial App.
  5. cfbauer's Avatar
    Posts
    179 Posts
    Global Posts
    206 Global Posts
       #5  
    Nice! On the webos-internals wiki page about upgrading to WebOs 2.1:

    WebOS 2 Upgrade - WebOS Internals

    For the Sprint-Franken-Pre2 (Pre2-GSM-Unlocked confirmed + sprint-pre(-)comm) and perhaps the Verizon-Franken-Pre2, the voice dialing application may not work after the metadoctor procedure above. The application may or may not even launch after tapped. You may experience problems with sound intermittently not working, esp. when playing media, or using the phone. This will be corrected automatically with a webOS OTA Update to 2.1.0. When the phone prompts for the update, install it.
    An update to WebOs 2.1 fixed it!

    Thanks crucian4, and thanks as usual to the incredible WebOs Internals team. I owe those guys my first (and possibly second) born child.
  6. #6  
    Quote Originally Posted by cfbauer View Post
    thanks as usual to the incredible WebOs Internals team. I owe those guys my first (and possibly second) born child.
    Thanks, but I've already got two myself

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
    pcworld likes this.

Posting Permissions