Page 1 of 2 12 LastLast
Results 1 to 20 of 35
Like Tree5Likes
  1.    #1  
    Here is how to install Sprint Navigation v2.8 on your Sprint Pre2s.


    I am using a Windows 7 64bit Machine.
    With the 2.1 SDK installed.


    Prerequisites:
    • Have Palm Pre SDK installed.
    • Pre is on Dev mode
    • Download com.telenav.sprintnavigation_1.0.1-86_armv7.ipk



    Steps:
    1. Plug your Pre to your computer and select USB mode
    2. Copy your new IPK to your Pre's USB Drive
    3. Take your Pre out of USB mode. (Disconnect)
    4. Plug your Pre to your computer again and select Just Charge
    5. Open your command prompt (Click START, type cmd, press enter.)
    6. Navigate to SDK bin directory
      Type:

      For 64 bit
      Code:
      cd \program files (x86)\palm\sdk\bin
      For 32 bit
      Code:
      cd \program files\palm\sdk\bin
    7. Gain root
      Type:
      Code:
      novacom -t open tty://
    8. Install Sprint Navigation v2.8
      Type:
      Code:
      ipkg install /media/internal/com.telenav.sprintnavigation_1.0.1-86_armv7.ipk -force-depends
    9. Reboot your Pre
    10. Enjoy!




    Thanks to deesugar and webOS Internals for your help!
  2.    #2  
    has anyone tryed it ?
  3. #3  
    Hex yeah! Works beautifully!
  4.    #4  
    good, im glad.. took me a while to find out how to do this. i just wanted to make this easier for anyone else looking to get this done.
  5. scobb's Avatar
    Posts
    56 Posts
    Global Posts
    95 Global Posts
    #5  
    Thanks for the info.

    I was getting read-only file system errors (see output at bottom).

    As per another thread, if you see those errors, before the install run the command:

    mount -o remount, rw /



    Original errors running the command:


    root@ZzzzPalmPre:/# ipkg install /media/internal/com.telenav.sprintnavigation_1.0.1-86_armv7.ipk -force-depends

    ipkg install /media/internal/com.telenav.sprintnavigation_1.0.1-86_armv7.ipk -force-depends

    Begin installation of com.telenav.sprintnavigation
    Installing com.telenav.sprintnavigation (1.0.1-86) to root...
    ipkg: //usr/lib/ipkg/info/com.telenav.sprintnavigation.control: Read-only file system
    ipkg: //usr/lib/ipkg/info/com.telenav.sprintnavigation.md5sums: Read-only file system
    ipkg: /usr/lib/BrowserPlugins/TnAdapter.so: Read-only file system
    ipkg: /usr/lib/Telenav/TnService: Read-only file system
    ipkg: /usr/lib/Telenav/font.fnt: Read-only file system
    ipkg: /usr/lib/Telenav/telenav.cfg: Read-only file system
    ipkg: /usr/lib/Telenav/telenavresource_global.bar: Read-only file system
    ipkg: /usr/lib/Telenav/telenavresource_img.bar: Read-only file system
    ipkg: /usr/palm/applications/com.telenav.app.sprintnavigation/appinfo.json: Read-only file system
  6. cwhead321's Avatar
    Posts
    77 Posts
    Global Posts
    80 Global Posts
    #6  
    done! Thanks so much!
  7. #7  
    I did it the very lazy way and after rebooting it's working for me.

    I used WOSQI.

    I'm also using Windows 7.

    I highlighted and search for the file to download and downloaded it to my desktop.

    I used WebOs Quick Install to send the file to the phone.

    I opened up the Linux Command line in WOSQI, and it brought up a DOS window.

    I highlighted and copied "mount -o remount, rw /" without quotes from scobb and use the right click to paste it into the DOS command window.

    Then I highlighted and copied

    ipkg install /media/internal/com.telenav.sprintnavigation_1.0.1-86_armv7.ipk -force-depends

    then right clicked and pasted into the command line. Hit enter. It ran a few things.

    Disconnected and rebooted the phone and now it's there and seems to be working.

    Thanks everyone.
    Jonnie likes this.
  8. settelma's Avatar
    Posts
    69 Posts
    Global Posts
    73 Global Posts
    #8  
    I have the Nav working, but has anyone installed the Sprint TV or the Sprint App succesfully?
  9. #9  
    Quote Originally Posted by settelma View Post
    I have the Nav working, but has anyone installed the Sprint TV or the Sprint App succesfully?
    The Sprint TV installs, but just doesnt show up any video. I dont quite get why it wouldnt work vs 2.1. Surely a fix is possible?
  10. tdogg0413's Avatar
    Posts
    74 Posts
    Global Posts
    85 Global Posts
    #10  
    it's been a while since I've had to do anything, but I cannot get the command line to give me root, keeps saying system cannot find the path specified. opening a prompt, I get: C:Users\Todd: do I just use the cd command? I'm not a programmer, but follow directions (explicit) pretty well. any help? I've already got the Nav ipk on the Frankenpre.

    Thanks!

    Update: After uninstalling/reinstalling 2X, finally let me in. Not sure what the issues were, but thanks for the method, worked like a charm!
    Last edited by tdogg0413; 01/17/2012 at 05:22 PM. Reason: I'm an idiot.
  11. #11  
    how come its not working for me? it says error returned 22 on the LINUX COMMAND for WOQI
  12. #12  
    can someone please help me? i try to download the file but it says my computer does not recognize the file when i try to open
  13. #13  
    Quote Originally Posted by rigo0523 View Post
    can someone please help me? i try to download the file but it says my computer does not recognize the file when i try to open
    What file are you trying to open? the ipkg just needs to be moved and installed via WOSQI or Internalz, are you refering to the webOS Dr.? If thats what your trying to open then winrar or 7 zip worked for me.
    ARE YOU NOT ENTERTAINED!!!
  14. #14  
    Quote Originally Posted by rigo0523 View Post
    can someone please help me? i try to download the file but it says my computer does not recognize the file when i try to open
    Its been a while since I did it but I think you don't need to open it, just drag it to your usb drive on your pre and then execute with command line in quick install.
  15. #15  
    I did all of that as well but it says error when I copy and paste the ipk that says force depends.
  16. #16  
    Quote Originally Posted by rigo0523 View Post
    I did all of that as well but it says error when I copy and paste the ipk that says force depends.
    Do you have SDK installed?
    ARE YOU NOT ENTERTAINED!!!
  17. #17  
    Quote Originally Posted by rigo0523 View Post
    I did all of that as well but it says error when I copy and paste the ipk that says force depends.
    OK lot of different methods here is what worked for me for both sprint and amazonMp3: use an older version of quick install, and type your commands instead of paste with the directions as follows:

    1. You have already have the file(s). (To install amazon you need two)

    2. Put your phone in Dev Mode, open up quick install, and send file to /media/internal

    3. Open up the linux command and type the following command:

    ipkg install /media/internal/com.telenav.sprintnavigation_1.0.1-86_armv7.ipk -force-depends

    4. Hit enter key

    5. Restart your phone.

    Come back and let us know.
    Last edited by laingman; 01/19/2012 at 01:37 AM.
  18. #18  
    Quote Originally Posted by laingman View Post
    OK lot of different methods here is what worked for me for both sprint and amazonMp3: use an older version of quick install, and type your commands instead of paste with the directions as follows:

    1. You have already have the file(s). (To install amazon you need two)

    2. Put your phone in Dev Mode, open up quick install, and send file to /media/internal

    3. Open up the linux command and type the following command:

    ipkg install /media/internal/com.telenav.sprintnavigation_1.0.1-86_armv7.ipk -force-depends

    4. Hit enter key

    5. Restart your phone.

    Come back and let us know.

    well I'm not home now, I'm at work but when I get home in the afternoon I will try it. Wait, so what is the media/internal? I just made sure from WOQI I sent the file to the phone. And then I copied the force depends file and I pasted it in the linux command line of WOQI. Did I do it right? So suggest typing it instead of pasting?
  19. #19  
    Quote Originally Posted by rigo0523 View Post
    well I'm not home now, I'm at work but when I get home in the afternoon I will try it. Wait, so what is the media/internal? I just made sure from WOQI I sent the file to the phone. And then I copied the force depends file and I pasted it in the linux command line of WOQI. Did I do it right? So suggest typing it instead of pasting?
    Basically media\internal is where you are dropping your files when you are in USB mode. This is the space granted for files aside from the OS itself.

    In order to get Sprint Nav to install on my Frankenpre2 I had to use an earlier version of WOQI (think it was 3.14 not the new 4.3.1). Try that, it should work.

    As far as Sprint TV...with webOS 2.2.4 I have it installed but have yet for it to show my any videos. I get the menu options for the channels and the shows etc, but it just sits at the Sprint logo screen.


    Nokia (red phone) --> Denso TouchPoint TP2200 --> Samsung SPH-N400 --> (Palm VII) --> Sanyo 5150 --> Palm Treo 650 --> Palm Pre --> Sprint FrankenPre 2 --> (HP TouchPad)/(HP Pre 3 - Wifi) --> Galaxy Nexus (with TS mod and hopes of Open webOS!)
  20. #20  
    Quote Originally Posted by rigo0523 View Post
    well I'm not home now, I'm at work but when I get home in the afternoon I will try it. Wait, so what is the media/internal? I just made sure from WOQI I sent the file to the phone. And then I copied the force depends file and I pasted it in the linux command line of WOQI. Did I do it right? So suggest typing it instead of pasting?
    I had to use an earlier version of quick install, and for some reason pasting didn't work in the command line so type it carefully.
Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions