Results 1 to 9 of 9
  1.    #1  
    Bad enough this exists on a CrapBerry, but I'm very disappointed to find the same single-mindedness on the Pre2 when it comes to automatically capitalizing whatever follows a period. If I type "etc." or "co." or any word that I abbreviate and end with a period in the middle of the sentence, the next letter is a capital! On my Treo, at least, it would show me that it was going to capitalize the next letter, and I could hit the shift key to disable it, but the only thing I seem to be allowed to do on the Pre - that I've found, at least - is to double-type the next letter, then futz around getting the cursor in front of the second letter and delete the cap! (how I miss the nav buttons! Sorry, as cool as touchscreens are, the human finger is too damn fat to act as a stylus!!!! HP, please stop trying to be just as 'cool' as an iPhone and make a phone with enough physical controls that it actually works better.)

    Please don't tell me to just hit the backspace until you've tried it; that seems to be everyone's advice whenever something like this comes up, and it doesn't work, folks. Any period seems to default webOS to starting a new sentence, which it 'helpfully' capitalizes, whether I want it to or not. Please tell me my ire and frustration are misplaced, that I've missed something, that my searches online are phrased wrong to get the answer I'm looking for.

    And while we're at it, is there any way to type a tab character?
  2. #2  
    Just tried and backspace does work. You have to hit it immediately after you type that first capital letter and it lower casicizes it and then you can keep going. Still just one key press like the Treo. o_0

    P.S. No tab that I know of.
  3. #3  
    Quote Originally Posted by Ptrope View Post
    Bad enough this exists on a CrapBerry, but I'm very disappointed to find the same single-mindedness on the Pre2 when it comes to automatically capitalizing whatever follows a period. If I type "etc." or "co." or any word that I abbreviate and end with a period in the middle of the sentence, the next letter is a capital! On my Treo, at least, it would show me that it was going to capitalize the next letter, and I could hit the shift key to disable it, but the only thing I seem to be allowed to do on the Pre - that I've found, at least - is to double-type the next letter, then futz around getting the cursor in front of the second letter and delete the cap! (how I miss the nav buttons! Sorry, as cool as touchscreens are, the human finger is too damn fat to act as a stylus!!!! HP, please stop trying to be just as 'cool' as an iPhone and make a phone with enough physical controls that it actually works better.)

    Please don't tell me to just hit the backspace until you've tried it; that seems to be everyone's advice whenever something like this comes up, and it doesn't work, folks. Any period seems to default webOS to starting a new sentence, which it 'helpfully' capitalizes, whether I want it to or not. Please tell me my ire and frustration are misplaced, that I've missed something, that my searches online are phrased wrong to get the answer I'm looking for.

    And while we're at it, is there any way to type a tab character?
    backspace absolutely does work.

    follow these steps:

    1. type your first sentence
    2. type a period
    3. type a space
    4. type the first letter of sentence #2 (it will be capitalized)
    5. hit backspace once (the capital letter will become lowercased)

    this process also works with undoing auto-corrected words.
  4. #4  
    Backspace only works if autocorrect is on or some crap like that. You have to fiddle with settings in Text Assist.
  5. #5  
    Quote Originally Posted by innocentbystander View Post
    Backspace only works if autocorrect is on or some crap like that. You have to fiddle with settings in Text Assist.
    well, if text assist is off, it wouldn't be capitalizing your words would it? so then we wouldn't need this trick at all.


    ps i dont have a pre right now so i cant check this out.
  6. #6  
    I just checked it out and Mhunterjr's solution works. It's the first option in the "Text Assist" app. I hate how if you reply to anything in these forums, it NEVER capitalizes the first word. Half the time I go back and fix it, the other half... I don't care. If you're still running on 1.4.5, then backspace is the only option aside from doing the double letter and repositioning the cursor to erase the capital, which sounds like a great game .....or not. I think the system sound for spelling mistakes should be configurable....new thread time
  7.    #7  
    Quote Originally Posted by Mhunterjr View Post
    well, if text assist is off, it wouldn't be capitalizing your words would it? so then we wouldn't need this trick at all.


    ps i dont have a pre right now so i cant check this out.
    Well, it appears this does work, but only if Text Assist is on; I turned off TA for a reason, and it still capitalizes after a period, but the difference appears to be that it will NOT allow you to correct that. Who dreamed this up? The only way to be able to manually correct something that it shouldn't be doing in the first place is to live with it automatically messing with everything else? Oy!

    There are so many things I love about the Pre, but it makes it all the more frustrating to find all the places they went backwards in terms of functionality and ergonomics; they didn't need to match the features of the iPhone just because it was Apple - they needed to build on the things they already did better, that they'd gotten right over years of experience. Would a D-ring have been such a bad thing? Even a virtual one! Buttons for scrolling instead of having to swipe all the time. And the simple expedient of being able to just hit the damn Shift key to get the character you really want (either a lower-case letter, or a tab), when you want it ...

    Thanks for the responses!
  8. #8  
    This is driving me nutz all the sudden!

    For the longest time I couldn't get the backspace key to revert the autocapped character back to lowercase on any webOS2 device, just deleted it instead. This is even after god knows how many partial erases and doctors. Now all the sudden it is working fine on my Pre2, I can hit the backspace to revert the capped character now all the sudden goes lower case? I did delete my palm profile backup and partial erase couple days ago and wondering if that has something to do with it. I did have auto correct on so maybe my palm profile backup had some fubar data hosing my pref cookies?

    Anywho, if you have Auto-Capitalization on, you also need to have Auto-Correction on too if you want the option to revert the capped character.

    Wierd..
    Last edited by addiarmadar; 04/16/2011 at 11:22 AM.
    Try diplomacy first. You can always conquer them later...

    www.webos-internals.org, read it, use it, love it, and donate to it.....
  9. #9  
    Really? I just repeat the letter and erase the uppercase one

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg

Posting Permissions