Quick question. I have a working sprint pre 2 running 2.0.1 and I want to doctor it as I've had a patch attempt go bad. I have read in the other sprint pre 2 forum about being able to use the normal Unlocked GSM Pre 2 doctor after using the Sprint Pre 2 MetaDoctor because the modem has been updated. Can anyone clarify this for me please? Thanks.