Page 1 of 2 12 LastLast
Results 1 to 20 of 33
  1.    #1  
    Strange behaviour of my Pre2: the caller id is not matched with the number saved in Contacts (the number saved in Contacts contains a country code prefix, e.g.: +44 7776 xxxxxx, while the caller id of the incoming call starts with: 07776 xxxxxx). I did not see this on my old Pre (webOS 1.4.5). Not sure if this is a bug in webOS 2.0.1 or I need to set something in Preferences ? (do not want to remove the country code prefix from my contacts as I travel abroad a lot).
  2. #2  
    Quote Originally Posted by kbywal View Post
    Strange behaviour of my Pre2: the caller id is not matched with the number saved in Contacts (the number saved in Contacts contains a country code prefix, e.g.: +44 7776 xxxxxx, while the caller id of the incoming call starts with: 07776 xxxxxx).
    Yea, I am seeing this too, very annoying.
    So far, I just added a second number to the people calling me locally. But this needs to be addressed by Palm.
  3. #3  
    Do you have the UK set as your country under International Dialing in Phone Preferences? I don't have this issue in Afghanistan with my Pre 2.
  4. #4  
    Quote Originally Posted by dc/dc View Post
    Do you have the UK set as your country under International Dialing in Phone Preferences? I don't have this issue in Afghanistan with my Pre 2.
    Do you indeed have International Dialing pref on a GSM model Pre 2? I thought that option is only available on CDMA Pres, however, thinking it over, the pref might be available on USA GSM Pres too. Anyway, it's not available on my UK Pre 2 GSM model.
  5. #5  
    Quote Originally Posted by dc/dc View Post
    Do you have the UK set as your country under International Dialing in Phone Preferences? I don't have this issue in Afghanistan with my Pre 2.
    Interesting. Indeed I did not configure international dialling.

    However, after configuring it, it does not resolve the problem.
  6. #6  
    Quote Originally Posted by Dick99999 View Post
    Do you indeed have International Dialing pref on a GSM model Pre 2? I thought that option is only available on CDMA Pres, however, thinking it over, the pref might be available on USA GSM Pres too. Anyway, it's not available on my UK Pre 2 GSM model.
    I have an unlocked EU GSM model, international dialing is under the phone prefs.
  7. #7  
    That's about the only thing I could think of that would affect it. That caused problems in my previous experiences with BlackBerry and iPhone.
  8. #8  
    Quote Originally Posted by urig View Post
    I have an unlocked EU GSM, international dialing is under the phone prefs.
    Interesting. This is what's under phone prefs om my GSM Pre, model P102UEU, webOS 2.0.1. Bought and activated in the UK
    Last edited by Dick99999; 12/26/2010 at 04:04 PM. Reason: corrected model number into P102UEU
  9.    #9  
    International dialing is ON, but it makes no difference (EU GSM Pre2 being used in the UK).
  10. #10  
    Apart from where that option is, my contact numbers are listed as local Netherlands numbers (0xx 555 1234). Caller ID works, and those caller numbers are displayed as +31 xx 555 1234. Have not tried international calls FROM abroad yet.
    Since I am also a user of iDialPlan SMSi, I don't need to adjust my numbers into international format when being abroad....
  11. #11  
    Quote Originally Posted by urig View Post
    I have an unlocked EU GSM model, international dialing is under the phone prefs.
    The prefernce International Dialing only seems to appear when formats in regional settings is set to USA. My setting was/is Uk. Then the particular preference disappears. It might be that recognition of the caller ID is influenced by that setting.
  12. #12  
    I posted this on Palm's official support forums as well. I suggest anyone who suffers from this number matching weigh their opinion in there as well.
    Caller ID mis-matching madness - Palm Support Community
  13. ykottler's Avatar
    Posts
    3 Posts
    Global Posts
    10 Global Posts
    #13  
    i have the same problem

    i have an unlocked Pre 2 from the US, running on the Orange GSM network in Israel.

    in some cases it would recognize the contact for a voice call but not for an SMS.

    i hope they resolve this soon.
    Last edited by ykottler; 12/28/2010 at 04:56 AM.
  14. #14  
    One thing I discovered: the International dialing setting, when turned on, only adds 001 to the numbers if dialed from an external application.

    For example, I tapped a local number emailed me, and the phone application added 001. This is odd.

    Does this mean that palm, in their wisdom, saw fit limit the pre only to official launch countries (e.g. US, UK) and if I happen to live in Israel, I will have no number matching on +972 numbers??
  15. ykottler's Avatar
    Posts
    3 Posts
    Global Posts
    10 Global Posts
    #15  
    i find it incredible that they droped the ball so bad that they cant fix this.

    this seriusly hammpers the usability of my phone
  16. #16  
    The international dialing option has always (v 1.x) been available for North American phones only. Now GSM in N.A. is also supported by HP Palm, that option seem to appear for EU phones also, but only if Regional settings/Formats is set to USA. It has always only supported 'adding a 1' for dialing.

    I had also expected more progress on this for the Rest of the World, and my iDialPlan would largely be out of business. It seems not the case.....
    But you never know, perhaps the final version of webOS2 for the Pre 1 will allow adding a country code in regional settings....

    This really addresses 2 related issues.
    1) caller ID issues, the title of this thread: how does the phone know which country to match if there is no setting to complement 10/11 digit numbers. And perhaps it would not have to know if matching is done with reversed numbers.
    2) calling home from abroad, largely solved by adding a +1 for N.A. and the core of my App for the RoW.
    Last edited by Dick99999; 01/04/2011 at 03:43 AM. Reason: Cleaned it up now I'm behind my PC
  17. #17  
    Quote Originally Posted by kbywal View Post
    Strange behaviour of my Pre2: the caller id is not matched with the number saved in Contacts (the number saved in Contacts contains a country code prefix, e.g.: +44 7776 xxxxxx, while the caller id of the incoming call starts with: 07776 xxxxxx). I did not see this on my old Pre (webOS 1.4.5). Not sure if this is a bug in webOS 2.0.1 or I need to set something in Preferences ? (do not want to remove the country code prefix from my contacts as I travel abroad a lot).
    Do you have that phone number in the contact information for more than one person?
  18.    #18  
    Quote Originally Posted by Cantaffordit View Post
    Do you have that phone number in the contact information for more than one person?
    No, the number is assigned just to one entry in my contacts. This happens for all numbers, not just for one number.
  19. #19  
    having the same problem on my unlocked Pre 2 (EU)
  20. #20  
    Thank you folks for sharing your problems and knowledge - I had the same problem and this thread helped me to resolve it.

    I have an unlocked Pre 2 from the UK, and had the same problem. However, the Pre plus I had before did not have this problem, so quite quickly I found the configuration that resolved the problem:

    1) In 'Regional Settings' (System launcher page) I put "United States of America"

    2) In the Phone Preferences (from the Phone application Menu > Preferences and Accounts), "International Dialing" is turned on, and the DIALING PREFIX is "Israel".

    Hope this helps
Page 1 of 2 12 LastLast

Posting Permissions