Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33
  1. #21  
    Quote Originally Posted by zevix69 View Post
    Thank you folks for sharing your problems and knowledge - I had the same problem and this thread helped me to resolve it...........
    In your case, did callerID not work for all of your numbers? Or did it just not work for some numbers even if these are listed in contacts (my case)?
  2. #22  
    Could a patch be written to solve this problem? It isn't only stuffing up caller-id for phone calls, I cannot use the messaging app correctly!
    I send a text, and the response comes back as another contact unless I add their number with the international calling code number to their contact...

    I hate this problem, its the only thing between me and a perfectly working Pre 2 in Australia.
    Palm m105 >> Zire 72SE >> AT&T Pre Plus >> Pre 2 (cracked)>>HP Veer/Pre 2>>Touchpad>>Pre 3...and I'm only 17 years old! (My own savings)
  3. #23  
    i think on the old phones, they only matched the last 5 digits or something like that, the did say they re wrote the phone app? Probably in one of the config files there will be a way to not match all the digits?
  4. #24  
    Try this, leave the settings in the phone app as they are and just change the country you are in from the regional settings
  5. #25  
    Quote Originally Posted by zevix69 View Post
    Thank you folks for sharing your problems and knowledge - I had the same problem and this thread helped me to resolve it.

    I have an unlocked Pre 2 from the UK, and had the same problem. However, the Pre plus I had before did not have this problem, so quite quickly I found the configuration that resolved the problem:

    1) In 'Regional Settings' (System launcher page) I put "United States of America"

    2) In the Phone Preferences (from the Phone application Menu > Preferences and Accounts), "International Dialing" is turned on, and the DIALING PREFIX is "Israel".

    Hope this helps
    Zevix, unfortunately this does not work for everyone. I have a Palm Pre 2 NA and I am using it in Rio de Janeiro, Brazil. I already tried your solution above (just changing the dialing prefix to Brazil) but it did not work out. Actually, I tried several different settings, I changed it to UK and United States of America, I turned on (and off) International Dialing for both options but... Not solved yet.

    I am really mad because this problem did not exist with my old Palm Pre and it is really ANNOYING!

    I do not understand why this phone does not use only the last 7 digits to match the caller id as EVERY DAMN PHONE IN THE WORLD DOES. It only matches correctly when the number is exactly like the number stored in Contacts. So I would have to add 021 (Rio de Janeiro area code) manually to ALL MY HUNDREDS of contact numbers in order to have caller id matching to work here. Unbelievable...

    As another minor nuisance, all phone numbers in Rio de Janeiro and So Paulo have 8 digits nowadays (and have for many years now) and the Palm Pre 2 is unable to understand that a line can have an 8 digit number, it always assumes the first 3 digits are the local area code. So all numbers on my contacts are weirdly separated by ()...
    Example: 8816-2504 shows as (881) 62504... This is done automatically and I can't delete these () even if I do it manually.

    I am really disappointed with the Palm Pre 2 so far. I already have to cope with the not being able to buy anything from the App Store since my original Palm Pre, but not being able to know who is calling me is too much.
  6. #26  
    Just to note, that I received the OTA update 2.1.0 yesterday but the problem still persists...
  7. #27  
    Hi, had this same problem earlier today, solved (like zevix69 above), by simply going to "Regional Settings" and setting "Formats" to - in my case - "Other". Requires a reboot. I did not change anything under "Phone preferences".

    My problem would be that most of my phone numbers are +47 xxxxxxxx, and when "local" callers called it would not recognize them. Phone numbers listed as xxxxxxxx would be recognized as before. After the change above, it now works as expected and I do not have two numbers registered for each person.

    Also, from my previous experiences (on 2.0.1 though), you only get the "International dialing" option available if "Regional settings" and "Format" is set to United States. Don't know what other people see. When I reset or doctor my phone, it's always there (as I install to English (US)), but when I set "Regional settings Formats" to Norway, it disappears.
  8. #28  
    Hi, Im using the Pre 2 also in Rio de Janeiro and have the same problem. Did you solved it?
  9. C64c's Avatar
    Posts
    9 Posts
    Global Posts
    10 Global Posts
    #29  
    I am using a HP Veer in the UK and I have the same problem. I'm thinking of just adding +44 to all my numbers as there doesn't appear to be a solution!
  10. #30  
    Check your Regional Settings as per psv75's post #27 above.
  11. #31  
    I am in hell with the same problem. After more then 10 years with Palm, it is time to move to Android. Bye !
  12. #32  
    I had the same problem on my att pre3 too, but it is solved now.

    The caller id not matched problem is caused by regional settings phone numbers format.
    My original format setting is "Hong Kong", phone numbers show as "xxxx xxxx".
    Now I switch to "other" format, phone numbers show as "xxxxxxxx".
    The caller id bug is created by "empty space" inside phone numbers. Erase the space from your contacts, change them to "xxxxxxxxx" format, then caller id will match its numbers.

    In a weird situation is you need to edit some phone numbers one by one even though they show in "xxxxxxxx" format. The method is to "tap" on the phone numbers and press "done" button without doing any editing, then the problem will be solved.

    Hope this helps.
    Love webOS.
  13. #33  
    Quote Originally Posted by visimon View Post
    Hi, Im using the Pre 2 also in Rio de Janeiro and have the same problem. Did you solved it?
    The only way I found to make the pre2 work was by entering all phone numbers in this format: +5521xxxxxxxx or +5511xxxxxxxx for Rio de Janeiro and SP as examples (YES, you have to enter the + sign!)
    Regional Settings for country are: Other
    If you enter phone numbers in this format, the pre2 will recognize the phone calls, will work with the SMS app perfectly and you will be able to call someone using this format.
    Of course, you will have to change the contacts by hand. You can either change the old phone to this format or add a second number in this format repeating the old phone number (both will work).
    In my case, in order to limit the amount of work needed to be done, I just edited phones from the people I talk most and I am gradually changing phones from people that call me for some months. I also enter all new contact's phones in the extended format.
    It is a hassle but it is now working.

    Good luck

    PS: For everyone else, changing the regional settings DO NOT fix this problem for everyone. At least, for brazilian users, that have 8 digit phones, the problem persists. I tested this extensively some months ago. But I do recommend setting the phone to the "Other" country phone format in regional settings because brazilian phones will be shown in a more understandable format.
    Last edited by mrwar; 10/16/2011 at 09:45 AM.
Page 2 of 2 FirstFirst 12

Posting Permissions