Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By Kara2020
  1.    #1  
    Hi everyone!

    I use Palm Pixi Plus CDMA and I have one trouble. I installed Russian keyboard layout and tried to send sms in Russian. But addressee can't see Russian text: "??????"

    How I can solve this trouble?

    PS. I'm sorry for bad English.
  2. #2  
    Must be that the SMS in not Unicode encoded (UTF-8) but relies on a specific encoding for each alphabet, such as Latin (most of the world), Chinese simplified (mainland China) and so on.

    I don't know whether it's the phone of the network that handles those messages in Latin... oh, wait a minute! You haven't told us yet what the target phone is (smartphone or flip-phone, your network, their network, brand of their phone, etc)

    Because my other phone is an LG flip-phone from mid-2007 and it does not support the Cyrilic alphabet, i checked it right now...
  3.    #3  
    Two examples:

    From: network Intertelecom CDMA, Palm Pixi Plus, text: "Привет"
    To: MTS UA GSM, Sony Ericsson W200i, text "_ _ _ _ _ _" (this phone supports Cyrillic symbols)

    From: network Intertelecom CDMA, Palm Pixi Plus, text: "Привет"
    To: network Intertelecom CDMA, Palm Pixi Plus, text: "_______"
    Remy X likes this.
  4.    #4  
    I sent SMS to myself and got the same problem:
  5. #5  
    Thank you

    This really completes the picture. I'm sure now, that it's a Pixi/webOS problem, primarily because Palm (the manufacturer) did not test its phones in the foreign markets where they didn't intend to sell yet.

    While i cannot offer you a fix right this minute, this looks like something that could be fixed by a person familiar with the code in that part of the operating system. Someone has already released a patch to add Unicode support to the Bluetooth interface to fix broken functionality. And if nobody offers a simple solution in the next 3 days, i will do it myself, even though i have the SMS functionality disabled now due to the amount of advertising coming in.
  6.    #6  
    I would be very grateful ))
  7. #7  
    Ok, i've done some searching and from what i can tell, webOS does use UTF-8 for all text (notes, email, IM), however the networks doesn't always support it for SMS transmission and most likely want the encoding to be set to Cyrilic (there's more than one encoding for it)

    See this thread regarding Unicode glyphs: Text Morpher formerly: txt flipper ɹǝddılɟ ʇxʇ

    What i'll have to do is find out what encoding your network might be using and possibly have to work with the Russian webOS forum to resolve this and test the patches


    Edit: According to Wikipedia (http://en.wikipedia.org/wiki/Short_M...e#Message_size), the Cyrillic, Japanese, Korean, Arabic alphabets are all transmitted in the UTF-16 encoding. And here is a thread on another forum that discusses UTF-8 to UTF-16 conversion for SMS use, so what we'll most likely need is to convert the text before sending. http://www.eggheadcafe.com/community...8-to-ucs2.aspx

    However, i still wonder why the Russian webOS forum cannot provide a ready solution for you, if they already send messages in Russian. I mean, why am i the only one helping you? Somebody else should as well...
    Last edited by Remy X; 12/08/2012 at 06:56 PM.

Posting Permissions