webOS Nation Forums >  webOS Devices >  Palm Pixi and Pixi Plus > Help! My pixi plus graphics are messed up
Help! My pixi plus graphics are messed up
Thread Tools Display Modes
Old 03/10/2012, 03:34 AM   #1 (permalink)
Posts: 1
Hi, I just got a pixi plus from amazon today. It worked fine and was in very good condition. I installed preware and then installed uberkernel, everything seemed fine, until later it developed a graphics issue where the bottom half of the screen is mirroring the top portion of the screen.

It works normally other than that, the touchscreen works fine, but now it is unusable. I have done a hard reset, and I have even flashed it back with webos doctor. I am just wondering what else I can do ........ I guess I can just send it back and get another one but I would like to fix it if possible. Anyone else ever have a graphics issue like this?
jchapman007 is offline   Reply With Quote
Old 01/11/2013, 12:17 PM   #2 (permalink)
malfunkshon's Avatar
Posts: 1
I know this is an old thread, but I have the same problem on my Palm Pixi Plus and haven't yet found a solution.

Anyone have some ideas?

The problem seems to be progressing.. it used to be the bottom 8mm of the screen, but now it's the bottom 16mm.

LCD connector? Graphics chip?
malfunkshon is offline   Reply With Quote
Old 01/11/2013, 02:27 PM   #3 (permalink)
Posts: 110
If it was mine I'd probably try taking it apart and look for the LVDS connector for the screen, and try reseating it. Maybe clean the circuit board with a Q-tip and some alcohol if it looked dirty. Beyond that I doubt there is much that can be done.
trwrt is offline   Reply With Quote


graphics problem, pixi

Thread Tools
Display Modes


Content Relevant URLs by vBSEO 3.6.0