Page 70 of 72 FirstFirst ... 20606566676869707172 LastLast
Results 1,381 to 1,400 of 1436
Like Tree49Likes
  1. #1381  
    ok i opened up cygwin typed cd "then the directory" and it took me to the directory. after that i typed "make install" and it ran through all that code i posted earlier and it disconnected and connected back " like when its being doctored" but the cpu chip sign never shows up i may just try to install ubuntu on vmware and run it again. how will i install the sdk in ubuntu though, is it the same way? and thanks for the replies, ill download ubuntu now
  2. #1382  
    I meant before that, but you should be fine on Ubuntu. The SDK download page has instructions on installing under linux. Best of luck!
    webOS Ports' UI Architect & luna-sysmgr guru.
  3. #1383  
    THANK YOU SHIFTYAXEL!!!!!!!!!!!!!! i ran the whole process from ubuntu in vmware and it WORKEDD!!!!!!!!!!!!!!!! UR a life saver!!!!!! now im running 2.1 on my pixi plus and it seems even faster than it was on 1.4.5 also my wifi wasnt working and now on this 2.1 OS it works!!!! again thanks bro.
    Last edited by fuadgo18dummy; 02/16/2012 at 11:21 PM.
  4. #1384  
    I have a PixiPlus I got for a music player (maybe a phone some day if my PrePlus or Pre2 both die)...

    Transformed it to work on Verizon, let me explain what I did and why I did it and if it helps anyone great!

    I used a meta-doctor Verizon script and cooked a new Verizon 1.4.5.1 doctor...
    I will not post it but explain what it does and why I did it (if you want it PM me and I can send it your way)...
    Anyway wanted the full HP experience HP Bootlogo, all Verizon Apps, and of course it to present itself as webOS 2.1.0 (why to get the backups working and the restore process working if it needs to be erased)...
    This script slow cooked my PixiPlus and makes it think it is something else (impostah like nothing else)...

    Now that my device was set, I used nuttybunnys great process...
    Now by default this was a umts backup/restore my device is cdma...

    So to fix this I used the devicetool.jar file to invoke DevMode...
    Once in I copied (using USB mode) the following files from the Verizon 1.4.5.1 Pixi Doctor:
    amazonservice_1.0-5_armv6.ipk
    com.nim.vznavigator_1.0.0-15.4_armv6.ipk
    com.nim.app.vznavigator_1.0.0-15.4_armv6.ipk
    com.palm.app.amazonstore_1.0-71_armv6.ipk
    com.palm.app.mobilehotspot_1.0-1.0.12_armv6.ipk
    palmcustomizationinfo-verizon_1.0-276_all.ipk
    pixiecdmafw-verizon_1.0.0-1524_armv6.ipk

    Once in I copied (using USB mode) the following files from the AT&T 2.1.2 Veer Doctor:
    contacts.plugin.pmvoicecommand_1.0-2_all.ipk (not really needed just wanted to test VoiceDial, does not work but was fun to try)

    Once in I copied (using USB mode) the following files from the Verizon 2.1.0 Pre2 Doctor:
    skyped_1.0-28.3_armv7.ipk
    com.skype.app.skypesearchdirectory_1.0-13_armv7.ipk

    Once in I copied (using USB mode) the following files:
    A updated palm-build-info (a impostah)...
    com.palm.app.findapps_2.0.22300_all.ipk and an icon file.
    Transformed existing Maps (from webOS 2.1.2) to GoogleMaps…
    MotionApps Classic Bits for webOS 2.x… (look for getclassic.zip in the how to classic webos 2.x thread)...

    Once that is all copied over I ejected USB mode and jumped into novaterm
    Removed the following IPKG (using ipkg remove):
    audiod-config-eu - 1.0-13 - Audio Policy Manager EU Configuration
    com.palm.service.contacts.sim - 1.0-22 - Sim Service
    com.palm.app.stk - 1.0-64 - SIM Toolkit
    com.palm.sfrvvm - 1.0.1-16 - Luna Service for SFR VVM
    com.palm.app.wlmcustomlogin - 1.0-6.3 - SFR WLM Custom Login UI
    imsfrtransport - 1.0.1-19.2 - Mojo SFR MSN IM Transport
    palmcustomizationinfo-wr - 1.0-2597 - wr Customization Info
    sfrwisprd - 1.0.0-9 - SFR Wi-Fi Hotspot Controller
    pixieumtsfw-row - 1.0.1-13211 - Modem Firmware package

    Left the following WR Carrier Apps
    sweatshop-wr-pixie - 1.0-60 - Version 1.0-60 of package sweatshop-wr-pixie
    crotest-images - 1.0-2 - Images used by luna app com.palm.app.crotest

    Add the following (using ipkg install):
    -nodeps amazonservice_1.0-5_armv6.ipk
    -nodeps com.nim.vznavigator_1.0.0-15.4_armv6.ipk
    com.nim.app.vznavigator_1.0.0-15.4_armv6.ipk
    com.palm.app.amazonstore_1.0-71_armv6.ipk
    com.palm.app.mobilehotspot_1.0-1.0.12_armv6.ipk
    palmcustomizationinfo-verizon_1.0-276_all.ipk
    pixiecdmafw-verizon_1.0.0-1524_armv6.ipk
    contacts.plugin.pmvoicecommand_1.0-2_all.ipk

    Modified the arch.conf file (look for a post in Skype Mobile on PixiPlus...)
    Add the following (using ipkg install):
    skyped_1.0-28.3_armv7.ipk
    com.skype.app.skypesearchdirectory_1.0-13_armv7.ipk

    Now I am not on the Verizon Network (remember this is a music player for me), so can't tell you if it really works, but one day I might and will want to try...

    Now extracted the Classic and GoogleMap bits and cleaned up the WR Carrier Apps empty directories (seems when you ipkg remove it removes the files but leaves the directory structure).

    Used sqlite3 on the device to fix luna Preferences like having AmazonMP3 as the default MP3 App and Verizon defaults (don't nag when the network is not available, SMS delay, OTA info)...

    Moved the findapps (app catalog and icon) to where apps-ipkg wants it, modified the manifest, .list and .md5sums so they are correct (it does not check but want it to be right).
    Removed the old app catalog file and it's icon.
    Tweaked the First Use app so it would not bother me about activations (great patch)

    Now once that was done...

    Went to device info and did a full erase...

    Once that was done let the device reboot...

    Now took a full backup of the device (meta-doctor is great) so that my work can be restored without redoing all these steps (which I did three times to make this post).

    Used the devicetool.jar to re-invoke DevMode...
    Once in I copied (using USB mode) the following files:
    prefsDB.sl
    Once that was copied over I ejected USB mode and jumped into novaterm
    and moved this file to where WiFi Profiles go... (I guess I am lazy, do not wish to re-type my WPA password)

    Used WebOSQuickInstall to install Impostah, used it to wipe my Palm Profile Account (from Dr. Skipped First Use), then activated my device, then remove the palm profile and let the device reboot...

    It then came up and asked me my language and country, jumped at me with my Phone was Activated and wanted me put in my palm profile information...

    It restored my Palm Profile (which is now webOS 2.1.0) and Luna restart and my Apps were coming down...
    Now Maps failed but let it install which it installs enyo to my device (could have done that before but hey let HP do it)...

    Reboot

    Use DevMode to clean up Maps Rebooter and remove the empty maps directory again why does ipkg remove leave such a mess...

    Now I have a webOS 2.1.0 PixiPlus reporting webOS 2.1.0 to the Palm Profile, now I can NOT get any 2.1.0 apps (the App Catalog is smart enough to know I am still just a PixiPlus after all) but the backup utility works and with my many times the palm profile restores my device just fine...

    Why I did this I do not know, I was taking a break from Kernel development with webOS 2.2.4 on my PrePlus and felt like going exploring for a new challenge...

    But when I was done, I went working out on the treadmill and listening to my new mp3 player and enjoying my fruitful endeavor...

    Oh and don't play angry birds while on the treadmill, cause it hurts... not just the pigs...
    Last edited by John Steffes; 02/21/2012 at 09:09 PM.
  5. #1385  
    I'm sorry, but I usually learn through videos because through just writing it doesent work for me, so can someone help me or post a video on youtube (I know there is one but its only writing in the description)PLEASE
  6. #1386  
    Hopefully I can get a little help here, sorry, but I've gotten everything installed & all that. Phone is in recovery mode, but when i start the make file install, after it shows "The fun begins. DESTROYING ALL YOUR PIXI PARTITIONS." it just sits there, been 20 mins and it's still sitting there, when I reboot the phone, everything's still the same on 1.4.5.1.
  7. #1387  
    anyone? no?
  8. #1388  
    Quote Originally Posted by theyluvmella87 View Post
    Hopefully I can get a little help here, sorry, but I've gotten everything installed & all that. Phone is in recovery mode, but when i start the make file install, after it shows "The fun begins. DESTROYING ALL YOUR PIXI PARTITIONS." it just sits there, been 20 mins and it's still sitting there, when I reboot the phone, everything's still the same on 1.4.5.1.
    Quote Originally Posted by theyluvmella87 View Post
    anyone? no?
    To help people need to see what you did please include the output of the script...
    Most of the issues with the make file is that it can not delete a volume when it is in use...
    Last edited by John Steffes; 03/07/2012 at 08:02 PM.
  9. #1389  
    Quote Originally Posted by theyluvmella87 View Post
    Hopefully I can get a little help here, sorry, but I've gotten everything installed & all that. Phone is in recovery mode, but when i start the make file install, after it shows "The fun begins. DESTROYING ALL YOUR PIXI PARTITIONS." it just sits there, been 20 mins and it's still sitting there, when I reboot the phone, everything's still the same on 1.4.5.1.
    Your probably using Cygwin. Google wubi. Its an Ubuntu installer. And all you have to get is the novacom drivers and not the whole sdk for Ubuntu.
    My Pixi *Plus* can handle the "new features" of WebOS 2

    Your 2.1 Pixi is only 15 minutes away: http://nuttybunny.wordpress.com/2011...pixi-plus-gsm/
  10. #1390  
    Hi Iam trying to do this with win7 64bit
    When I run cygwin I can get to the Pixi folder which has a downloads dir with webosdoctorp121ewwatt in it.
    The Pixi root dir has the e4014e63a755ac02a63478047ad21d7e winrar file, the fixi winrar and the Makefile-modem file which I renamed to Makefile. When I try to run make install all I can get is: -bash: make: command not found?
    I have installed HP webOS SDK, novacomd and novacom (a black window pops up and closes before I can read anything) Dr webOS runs fine. Do I need to use unzip on the rar files (it dosent work). Does anyone have any ideas?

    PS when I try to run webOS emulator to test my SDK install a black box pops up and closes before I can read it?
    Last edited by dmerlin; 03/14/2012 at 06:40 PM.
  11. #1391  
    I found a program called make and have tried to install it but after the install I cant find a icon for it anywhere on this computer? I must e missing something easy but I canf get this to work? I allways get the same: -bash: make: command not found
  12. #1392  
    Quote Originally Posted by ShiftyAxel View Post
    Oh, I see the problem, you don't have make installed. I think you can rerun the cygwin installer to add extra packages such as make. Either that or you should be able to find it on the cygwin site or via google.
    Hi this is the error I get but I have installed make? Do i need to install it someplace other then the defalt? I cant seem to get it right? Can any one help me?
  13. #1393  
    If one wishes to build a doctor instead of using the Make file process, which provides a restore of a backup file, the doctor is a clean install (no user files) follow this link:

    http://forums.webosnation.com/palm-p...-pixiplus.html
  14. #1394  
    Thank You! Ill give it a try.
  15. brody8898's Avatar
    Posts
    12 Posts
    Global Posts
    38 Global Posts
    #1395  
    Anyone know of an easier way to get 2.1 on AT&T branded GSM Pixi Plus?
  16. #1396  
    Quote Originally Posted by brody8898 View Post
    Anyone know of an easier way to get 2.1 on AT&T branded GSM Pixi Plus?
    I do not have an AT&T device, but I created one anyway, it is a variation of the WR (ROW) script.

    Try the AT&T script first and see if it works.

    I also posted a script for Sprint.

    http://forums.webosnation.com/palm-p...-pixiplus.html
    Last edited by John Steffes; 03/29/2012 at 07:43 AM.
  17. #1397  
    hey guys... I'M BACKK. :-) um. Did anyone get the error `invalid compressed data to inflate'

    I got that error in ubuntu and wjndows
  18. #1398  
    Quote Originally Posted by zacky59 View Post
    hey guys... I'M BACKK. :-) um. Did anyone get the error `invalid compressed data to inflate'

    I got that error in ubuntu and wjndows
    Zacky59,

    The Doctor method I provided works much better then the previous method:

    http://forums.webosnation.com/palm-p...-pixiplus.html

    FYI Even though the thread is labeled for Verizon, I have scripts for all carriers (Verizon, WR [ROW], Sprint, and AT&T)...

    But if you are still using NuttyBunny's script, there are lots of issues with the existing files included in the rootfs (the long hex file name) that is why I created the Doctor build (it is the closest thing to a real doctor according to the MD5SUMS file).

    Also if you use the Super Script it makes the build much more polished (Veer ports)...

    If you want us to help you troubleshoot your existing error, please copy the command line (a log of what you did)?
  19. #1399  
    Quote Originally Posted by John Steffes View Post
    Zacky59,

    The Doctor method I provided works much better then the previous method:

    http://forums.webosnation.com/palm-p...-pixiplus.html

    FYI Even though the thread is labeled for Verizon, I have scripts for all carriers (Verizon, WR [ROW], Sprint, and AT&T)...

    But if you are still using NuttyBunny's script, there are lots of issues with the existing files included in the rootfs (the long hex file name) that is why I created the Doctor build (it is the closest thing to a real doctor according to the MD5SUMS file).

    Also if you use the Super Script it makes the build much more polished (Veer ports)...

    If you want us to help you troubleshoot your existing error, please copy the command line (a log of what you did)?
    okay, i PM'ed you for help.
  20. #1400  
    Quote Originally Posted by NuttyBunny View Post
    Ok people, as some of you know, I managed to get copies of 2 versions of webOS 2.x for Pixi, one is 2.1 (Barleywine), and the other is 2.0 (Blowfish).

    The intention is to make an effort to place these versions on a new Pixi (mr.xtop has already downgraded his Pixi to 1.4.5 so we don't have his info anymore).

    With the help of some you guys, I've managed to get a GSM AT&T Pixi, and I've just managed to unlock it. It's running 1.4.5 right now, and I'm in the process of looking for the way to upgrade it.

    The backup was done with Meta Doctor, but the webOS Internals groups is not associated with this effort, so, please, don't bug them or make claims against them, we don't want to damage relationships here, ok?

    Thanks for your attention. Now, let the fun begin.

    UPDATE:
    As many of you know, this is now working.
    The instructions are here: This is it. webOS 2.1 on *your* Pixi Plus GSM | The NuttyBunny
    The files can be found with google.
    Read the last pages of the thread if you have doubts.

    What works:
    GSM Pixi
    - Everything in a 2.1 installation except Flash, Voice Dial and Overclocked Kernels
    - SMS works after updating the modem firmware

    CDMA Pixi (both Verizon and Sprint)
    - Recommendation: Install 1.4.5, activate it, then proceed with 2.1.
    - Apparently works after installing, entering developer mode (##DEVMODE#), then doing a full erase to let the Pixi reactivate itself.

    Most 2.1 patches should work with no further modification

    What doesn't work:
    - Paid App Access. It won't work to download 2.1 apps, don't bother. Read the thread to find an alternate way to have a 1.4.5 version on your profile, which will let you download ONLY 1.4.x apps (paid if you want). **You need to edit the /etc/palm-build-info on your Pixi, this way: Line 1 from the 2.1 version, subsequent lines from 1.4.5 version, login to your profile again, you may use Impostah to do this**
    - Most PDK apps won't work because we're on a different processor, also 1.4.5 Pre games won't work as well. Of course, Pixi PDK apps should work. Also, NDrive works.
    - No Flash, No Voice Dial
    - There are no and there will be NO custom kernels for this. STOP ASKING.
    - And well, it's pretty slow, but you can install govnah, set it to 600Mhz userspace with no compcache and almost enjoy it

    Warnings:
    Please, DON'T do the "quick tests" or you Pixi may die a horrible death, read zacky59's posts.

    Thanks to everyone for your help, and if you'd like to donate, PM me for the info.
    I download all the correct files.I'm using terminal in Ubuntu.I get this error @ubuntu:~/Desktop/pixi$ make install
    THIS WILL WIPE EVERYTHING EXCEPT THE NVRAM PARTITION FROM YOURDEVICE AND TRY TO INSTALL 2.1 ON IT. IT MAY OR MAY NOT WORK.IF IT DOESN'T WORK YOU'RE INVITED TO USEmake uninstallAND THEN RESTORE USING WEBOS DOCTOR.
    make[1]: Entering directory `/home/tron/Desktop/pixi'
    tar: Unexpected EOF in archive
    tar: rmtlseek not stopped at a record boundary
    tar: Error is not recoverable: exiting now
    make[1]: *** [build/unpacked-doctor/webos/.unpacked] Error 2
    make[1]: Leaving directory `/home/tron/Desktop/pixi'
    make: *** [install] Error 2
    What is that I'm doing wrong?...

Tags for this Thread

Posting Permissions