Page 45 of 64 FirstFirst ... 35404142434445464748495055 ... LastLast
Results 881 to 900 of 1263
Like Tree3Likes
  1. #881  
    Quote Originally Posted by bryanbowles90 View Post
    Hey errbin, how 'bout Youtube on that setup. I'm working now but will test it in an hour.
    I can get HD YouTube videos to play, but only after I've downloaded them (no prob. with Jason's patch). The "highest def" of them all require disabled Compcache, Anticipatory, & Westwood.

    65% or lower threshold is also required. max tickle window and max floor window seem best set at 1 & 4 sec. (1,3 -&- 2,4 also work well, but the audio will get out of sync much, much quicker with these settings).

    With these settings I've been using, on the "highest def" vids... maybe once or twice per video, the video will just barely lag behind the audio (think this has to do with transferring data to swap), and I will need to swipe to the left in order to rewind 10 seconds. After that, playback is flawless to the end. This only happens on the absolute fastest pace onscreen movement. With the 1,4 tickle/floor windows, the video more often than not actually seems to catch up on its own if it's lagging... so the swipe back isn't totally necessary. But if a notification or message pops up... there can be enough video lag to warrant that back swipe.

    Test these settings out and see for yourself. If you find a video that won't playback flawlessly, let me know the name and I'll see if I can find some slightly better settings, but I highly doubt it. Try a Luna Restart after you start these settings to make sure they you get a nice, clean start

    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 806.4 MHz
    sampling rate: 0.2 Sec
    up threshold: 60 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 1 Sec
    max floor window: 4 Sec
    compcache enabled: false
    Scheduler: Anticipatory
    Congestion: Westwood

    This is my final answer!!

    My final question is -- "Is it possible to set the Anticipatory scheduler and Westwood TCP algorithm to stick at a fresh boot??"


    Would a rebuilt kernel, Meta-Doctor be able to solve this problem? I don't want to change them after each and every boot. I really feel like I could cut the boot time down by 50% to 75% if I could do this.
  2.    #882  
    Quote Originally Posted by grndslm View Post
    My final question is -- "Is it possible to set the Anticipatory scheduler and Westwood TCP algorithm to stick at a fresh boot??"
    Yes.

    You can make them the default from start of boot by recompiling the kernel.

    You can make them the default from init script time by creating an upstart script to set them.

    Govnah does not yet have support for making those settings "stick". Code contributions to do this are welcome. Contact me if you're a C developer who wants to help.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  3. #883  
    Thanks errbin!
  4. errbin's Avatar
    Posts
    256 Posts
    Global Posts
    451 Global Posts
    #884  
    alright grndslm testing with the compcache off
    but I have the up threshold: 50 %


    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 806.4 MHz
    sampling rate: 0.2 Sec
    up threshold: 50 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 1 Sec
    max floor window: 4 Sec
    compcache enabled: false
    Scheduler: Anticipatory
    Congestion: Westwood
  5. #885  
    Wow I feel dumb. Sorry grndslm I thought you were errbin. I am really diggin the last setup you posted though. I have been running it for a day and Youtube videos run perfect!
  6. #886  
    Yeah Ive been testing some of the more recent developments from you guys and compcache off definitely makes for a smoother experience on my phone. So, I think thats a given. The following works quite well as pointed out by grndslm earlier:

    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 806.4 MHz
    sampling rate: 0.2 Sec
    up threshold: 60 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 1 Sec
    max floor window: 4 Sec
    compcache enabled: false
    Scheduler: Anticipatory
    Congestion: Westwood

    Im running that and seems so far it has a slight edge above any other settings Ive tried.
  7. #887  
    actually, if you install the unset cfq io scheduler patch, you will then be able to set anticipatory from boot

    for some reason, palm decided to force to cfq regardless of setting.

    recompiling the kernel without this patch will still result in cfq...
  8. #888  
    I've benchmarked throughput for all the different avail tcp congest and cubic was amongst the highest. I don't remember which was the absolute fastest but they were within 5%. So I just stuck with cubic.
  9. #889  
    per palm, most of the boot "time" is actually consumed by lunasysmgr.

    one thing i've heard that makes for faster boots is to have fewer apps installed. Try it
  10. #890  
    Quote Originally Posted by codecrumb View Post
    actually, if you install the unset cfq io scheduler patch, you will then be able to set anticipatory from boot

    for some reason, palm decided to force to cfq regardless of setting.

    recompiling the kernel without this patch will still result in cfq...
    I'm thinking about just running an init script... but I don't exactly know the commands to set anticipatory & westwood. Seen 'em a long time ago, but can't find 'em anymore.

    Quote Originally Posted by codecrumb View Post
    I've benchmarked throughput for all the different avail tcp congest and cubic was amongst the highest. I don't remember which was the absolute fastest but they were within 5%. So I just stuck with cubic.
    Cubic is definitely good, but it still can't handle "HD" video like westwood. I dunno the exact resolution of these vids, but I definitely can't see any pixels. Who knew that the smallest, cheapest smartphone, made more than a year ago... had a Retina display??

    Quote Originally Posted by codecrumb View Post
    per palm, most of the boot "time" is actually consumed by lunasysmgr.

    one thing i've heard that makes for faster boots is to have fewer apps installed. Try it
    Exactly. It takes 4 minutes for a boot with cfq. When I do a luna restart w/anticiwood, it takes about 1 min, 30 sec.

    Really... figuring out how to set anticipatory/westwood at boot is the only thing I have left to do.
  11. errbin's Avatar
    Posts
    256 Posts
    Global Posts
    451 Global Posts
    #891  
    Quote Originally Posted by errbin View Post
    alright grndslm testing with the compcache off
    but I have the up threshold: 50 %


    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 806.4 MHz
    sampling rate: 0.2 Sec
    up threshold: 50 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 1 Sec
    max floor window: 4 Sec
    compcache enabled: false
    Scheduler: Anticipatory
    Congestion: Westwood

    after removing smooth scrolling patch this setting is great
    very quick and smooth my Pixi is very responsive
    it opens all my apps quicker

    I didn't really watch youtube on my phone so the effects it
    has on it doesn't really matter to me

    I mainly do a lot of web browsing and texting

    I'll continue testing for battery life
  12. #892  
    I think you'll find you'll get better battery life with a slightly higher threshold, that way your phones underclocked for the entire time you're not using it, even if you have a repeating notification.

    (Just my experiences, not a statement of fact.)
  13. #893  
    my problem with setting it above 60% is when I receive a phone call after being @ idle for a while, I can't get the phone app to respond fast enough to answer the call :/
  14. #894  
    Quote Originally Posted by bradenfontaine View Post
    my problem with setting it above 60% is when I receive a phone call after being @ idle for a while, I can't get the phone app to respond fast enough to answer the call :/
    Even with 8mb Compcache? Or even compcache turned off?

    I've always had my threshold at 65%, it seems like a phone call would be enough to kick the CPU into gear without issue, so it may be another setting conflicting with it.
  15. #895  
    Quote Originally Posted by Sketh View Post
    Even with 8mb Compcache? Or even compcache turned off?

    I've always had my threshold at 65%, it seems like a phone call would be enough to kick the CPU into gear without issue, so it may be another setting conflicting with it.
    its almost like the phone call kicks it in, but there is so much "back log" its having to catch up with it gets overloaded and cant respond fast enough until everything catches up. the load usage is tell-tale.
    verizon pre 2 - 2.0, stock
    verizon pre plus - 1.4.5 various patches OC'd 1Ghz.
    verizon pixi plus - various patches, OC'd 800 mhz.
    verizon pixi plus - chillin in my sock drawer
  16. #896  
    What are your tickle settings?


    ... I'm re-reading what I just wrote, and it's humorous. But really, what are they?
  17. #897  
    From Service:
    Governor: ondemandtcl
    Scheduler: anticipatory
    Congestion: westwood
    min freq: 320 MHz
    max freq: 806.4 MHz
    sampling rate: 0.2 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: false
    compcache memlimit: 16 MB


    this seems to be the best setting i can find. even through EVERYONES input. been using these settings for days. every now and again i get bad lag, then i just check govnah and see it needs a reset, but honestly, using preset rest, i never have much trouble.
    verizon pre 2 - 2.0, stock
    verizon pre plus - 1.4.5 various patches OC'd 1Ghz.
    verizon pixi plus - various patches, OC'd 800 mhz.
    verizon pixi plus - chillin in my sock drawer
  18. #898  
    Quote Originally Posted by bradenfontaine View Post
    From Service:
    Governor: ondemandtcl
    Scheduler: anticipatory
    Congestion: westwood
    min freq: 320 MHz
    max freq: 806.4 MHz
    sampling rate: 0.2 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: false
    compcache memlimit: 16 MB


    this seems to be the best setting i can find. even through EVERYONES input. been using these settings for days. every now and again i get bad lag, then i just check govnah and see it needs a reset, but honestly, using preset rest, i never have much trouble.


    Well those pretty much mirror my settings minus the min frequency and compcache. The only thing I'd suggest would be lowering the compcache to 8MB, but 16 worked well for me too.

    I also have very minimal background processing going, and I normally close all of my cards before I put my phone to sleep. I'm just a neat freak that way, but I think that has a lot to do with my phones speediness.
  19. #899  
    Quote Originally Posted by Sketh View Post
    Well those pretty much mirror my settings minus the min frequency and compcache. The only thing I'd suggest would be lowering the compcache to 8MB, but 16 worked well for me too.

    I also have very minimal background processing going, and I normally close all of my cards before I put my phone to sleep. I'm just a neat freak that way, but I think that has a lot to do with my phones speediness.
    check it. the compcache is set to false. and i close everything but govnah, i like to see what its doing when im not messin with it.
    verizon pre 2 - 2.0, stock
    verizon pre plus - 1.4.5 various patches OC'd 1Ghz.
    verizon pixi plus - various patches, OC'd 800 mhz.
    verizon pixi plus - chillin in my sock drawer
  20. #900  


    when my load average gets this high (idle after 1 hour) it wont process much until it goes down. so answering phone calls, opening the camera, u can FORGET IT!

    i wanna know if the cpu is as high as it says it is when its "idle" why the hell is the load average so high?!
    verizon pre 2 - 2.0, stock
    verizon pre plus - 1.4.5 various patches OC'd 1Ghz.
    verizon pixi plus - various patches, OC'd 800 mhz.
    verizon pixi plus - chillin in my sock drawer

Posting Permissions