Page 24 of 64 FirstFirst ... 14192021222324252627282934 ... LastLast
Results 461 to 480 of 1263
Like Tree3Likes
  1.    #461  
    Quote Originally Posted by twilightomni View Post
    Hello there. Using Uberkernel 1.4.5.124, I've gathered the three requested Govnah logs.

    1. Palm Default 600Mhz from boot, normal, no lag.
    2. Booted to 768Mhz profile, no lag.
    3. Changed from 768Mhz profile back to Palm Default/600Mhz, with resulting UI skips/lag.

    Hope this is helpful.
    Does it occur on 1.4.5-128 ?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2. #462  
    plugged in to usb. Sunspider took 27 seconds.




    proc_version: Linux version 2.6.24-palm-chuck (v1.4.5-128@org.webosinternals.kernels.uber-kernel-pixi) (gcc version 4.2.1 (CodeSourcery Sourcery G++ Lite 2007q3-51)) #2 PREEMPT Tue Nov 2 13:47:53 UTC 2010
    Current:

    From Service:
    Governor: ondemandtcl
    Scheduler: cfq
    Congestion: cubic
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB


    Files:

    cpufreq_file
    description "Govnah Settings"

    start on stopped finish

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    echo -n 'ondemandtcl' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo -n '320000' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo -n '787200' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo -n '100000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/sampling_rate
    echo -n '65' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/up_threshold
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/ignore_nice_load
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/powersave_bias
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_tickle_window
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_floor_window

    end script

    compcache_file
    description "Govnah CompCache Configuration"

    start on stopped finish
    stop on runlevel [!2]

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    swapoff -a
    insmod /lib/modules/`uname -r`/extra/xvmalloc.ko
    insmod /lib/modules/`uname -r`/extra/ramzswap.ko memlimit_kb=16384 backing_swap=/dev/mapper/store-swap
    sleep 3
    swapon /dev/ramzswap0 -p 1

    end script


    Profiles:

    (4) Perfect
    Governor: ondemand
    min freq: 122.88 MHz
    max freq: 600 MHz
    sampling rate: 0.1 Sec
    up threshold: 60 %
    ignore nice load: false
    powersave bias: 0
    compcache enabled: true
    compcache memlimit: 24 MB
    (5) Fixed Speed 600 v6
    Governor: performance
    min freq: 600 MHz
    max freq: 600 MHz
    (6) Palm Default v6
    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 600 MHz
    sampling rate: 0.2 Sec
    up threshold: 80 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    (35) OC1
    Governor: ondemandtcl
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB
    (36) Performance 787
    Governor: performance
    min freq: 787.2 MHz
    max freq: 787.2 MHz
    compcache enabled: true
    compcache memlimit: 16 MB
  3. boyer61's Avatar
    Posts
    261 Posts
    Global Posts
    418 Global Posts
    #463  
    I used those exact same setting, and got 20.89 on sunspider
  4. #464  
    unplugged sunspider 21 seconds.




    proc_version: Linux version 2.6.24-palm-chuck (v1.4.5-128@org.webosinternals.kernels.uber-kernel-pixi) (gcc version 4.2.1 (CodeSourcery Sourcery G++ Lite 2007q3-51)) #2 PREEMPT Tue Nov 2 13:47:53 UTC 2010
    Current:

    From Service:
    Governor: ondemandtcl
    Scheduler: cfq
    Congestion: cubic
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB


    Files:

    cpufreq_file
    description "Govnah Settings"

    start on stopped finish

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    echo -n 'ondemandtcl' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo -n '320000' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo -n '787200' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo -n '100000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/sampling_rate
    echo -n '65' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/up_threshold
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/ignore_nice_load
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/powersave_bias
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_tickle_window
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_floor_window

    end script

    compcache_file
    description "Govnah CompCache Configuration"

    start on stopped finish
    stop on runlevel [!2]

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    swapoff -a
    insmod /lib/modules/`uname -r`/extra/xvmalloc.ko
    insmod /lib/modules/`uname -r`/extra/ramzswap.ko memlimit_kb=16384 backing_swap=/dev/mapper/store-swap
    sleep 3
    swapon /dev/ramzswap0 -p 1

    end script


    Profiles:

    (4) Perfect
    Governor: ondemand
    min freq: 122.88 MHz
    max freq: 600 MHz
    sampling rate: 0.1 Sec
    up threshold: 60 %
    ignore nice load: false
    powersave bias: 0
    compcache enabled: true
    compcache memlimit: 24 MB
    (5) Fixed Speed 600 v6
    Governor: performance
    min freq: 600 MHz
    max freq: 600 MHz
    (6) Palm Default v6
    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 600 MHz
    sampling rate: 0.2 Sec
    up threshold: 80 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    (35) OC1
    Governor: ondemandtcl
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB
    (36) Performance 787
    Governor: performance
    min freq: 787.2 MHz
    max freq: 787.2 MHz
    compcache enabled: true
    compcache memlimit: 16 MB
  5. #465  
    Here are the logs again, for 1.4.5-128.

    Again, from boot, 600 and 768MHz profiles perform equally well, with equal UI responsiveness and no noticeable difference in lag.

    However, if boot @768 is changed back to the Palm Default profile, UI again becomes much noticeably laggier than stock.

    It's worth noting a few other oddball things.
    1. Overclocking doesn't seem to noticeably change the performance or smoothness of any of the apps on the phone when done from boot. More of a benchmark thing I guess. It just seems like all I'm doing is trying to prove it works just as good as stock.

    2. For some reason changing a profile doesn't have immediate effect [ex., from Palm Default to 128/768; it just stays at 600]. I usually have to switch more than once, or switch to Fixed 768 and then switch to 128/768 before it takes effect. This has happened ever since I installed the first Uberkernel testing on this phone. [Please note, I made sure to watch the CPU speed fall to 128MHz, so I can confirm that I did successfully switch profiles.]

    3. I did not try the new 786 profile, as when I tried to set it to Fixed 786, for some reason the CPU would not ramp up that far; instead it stopped at 748. I did not spend more than a few seconds investigating this.
    Attached Files Attached Files
  6. #466  
    Twighlight Omni wrote:
    "It's worth noting a few other oddball things.
    1. Overclocking doesn't seem to noticeably change the performance or smoothness of any of the apps on the phone when done from boot. More of a benchmark thing I guess. It just seems like all I'm doing is trying to prove it works just as good as stock."

    I agree 100%. I dont want to be negative because I GREATLY appreciate all the work by everybody especially RWhitby and Codecrumb.
    But our devices are not any faster with these techniques. (not even a little)
    If the devs have a minute can they tell me if my findings are true or not? Just the devs please because writing that "my device is fast" does not help ....If you say that you have not done a side by side comparison to stock. We are now increasing the frquency by over 31%!
    Thanks so much
    *Patchers STILL make this phone Perfect!
    Palm Devices Currently Owned: Pre, Pre Plus, Pre 2, Pre 3, Pixi, Veer, Touchpads, and too many touchstones!
  7. #467  
    I disagree ... our devices are seeing a speed increase, mine is for sure when it comes to running many programs at once...especially when programs start getting swapped into compcache, the processor handles the compression process much faster and my "switching between" programs like with 5-10+ open is much more smooth. Opening many programs at once is also much faster, vs the sluggishness I experienced at 600mhz.

    For the record, I am running the latest warthog kernel w/ the stock kernel vm parameters which are loaded up after phone is fully booted via a sysctl command on a .conf file. I do find the warthog vm specific parameters still to cause UI lagging...whereas the stock / uberkernel does not.
    I also run my phone w/ vm.swappiness setting of 30
  8.    #468  
    Quote Originally Posted by GenTarkin View Post
    I disagree ... our devices are seeing a speed increase, mine is for sure when it comes to running many programs at once...especially when programs start getting swapped into compcache, the processor handles the compression process much faster and my "switching between" programs like with 5-10+ open is much more smooth. Opening many programs at once is also much faster, vs the sluggishness I experienced at 600mhz.

    For the record, I am running the latest warthog kernel w/ the stock kernel vm parameters which are loaded up after phone is fully booted via a sysctl command on a .conf file. I do find the warthog vm specific parameters still to cause UI lagging...whereas the stock / uberkernel does not.
    I also run my phone w/ vm.swappiness setting of 30
    Do you see the same performance using latest pixi uberkernel with unchanged parameters as you do with warthog with your stock vm parameters, or is there still a difference there?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  9. #469  
    from what I recall, yes I saw about the same performance. I remember your parameters .. you changed I believe one thing and left the features at 7, I think this vs the 24188 (or whatever) is on warthogs is kinda messin it up.
    The other 2 seem to not affect it as bad.
  10. #470  
    Is there anything I can do to help identify the cause of post-downclocking slowdown? Does anyone else experience that specific symptom?

    Is there any other information that would be useful?
  11. #471  
    rwhitby would be your man
  12. #472  
    I am curious, could it be the "race to idle" feature you guys are implementing w/ non stock kernel thats causing these random slowdowns people are experiencing?
  13. #473  
    experiencing sluggishness since last night




    proc_version: Linux version 2.6.24-palm-chuck (v1.4.5-127@org.webosinternals.kernels.warthog-kernel-pixi) (gcc version 4.2.1 (CodeSourcery Sourcery G++ Lite 2007q3-51)) #2 PREEMPT Mon Nov 1 14:09:36 UTC 2010
    Current:

    From Service:
    Governor: ondemandtcl
    Scheduler: cfq
    Congestion: cubic
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB


    Files:

    cpufreq_file
    description "Govnah Settings"

    start on stopped finish

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    echo -n 'ondemandtcl' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo -n '320000' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo -n '787200' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo -n '100000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/sampling_rate
    echo -n '65' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/up_threshold
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/ignore_nice_load
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/powersave_bias
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_tickle_window
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_floor_window

    end script

    compcache_file
    description "Govnah CompCache Configuration"

    start on stopped finish
    stop on runlevel [!2]

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    swapoff -a
    insmod /lib/modules/`uname -r`/extra/xvmalloc.ko
    insmod /lib/modules/`uname -r`/extra/ramzswap.ko memlimit_kb=16384 backing_swap=/dev/mapper/store-swap
    sleep 3
    swapon /dev/ramzswap0 -p 1

    end script


    Profiles:

    (2) Palm Default v6
    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 600 MHz
    sampling rate: 0.2 Sec
    up threshold: 80 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    (18) Overclocked 787 stable
    Governor: ondemandtcl
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB
  14. #474  
    feels like this thread is dying, any support?
  15.    #475  
    Quote Originally Posted by InSaNeO14 View Post
    feels like this thread is dying, any support?
    I'm waiting for you guys to look at each other's Generate Email output and work out why some people are seeing lag and others are not ...

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  16. jonsmith89's Avatar
    Posts
    6 Posts
    Global Posts
    52 Global Posts
    #476  
    I've been running the "TCL" profile for the past week and have noticed an increase in performance in the handling of multiple cards open and smoother launcher transitions. It's pretty much a tweak of insane014's 787 profile except I changed the sampling rate to 2 seconds and compcache to 24mb. This seemed to work better on my AT&T Pixi Plus. I'm very pleased with the improvements made by overclocking and I appreciate everything everyone has done to help us Pixi users be even more amazed with our devices. Loving my Pixi so much makes me wonder how I'm going to handle whatever HP and Palm give us next year.

    PS. I've noticed that everyone is using cfq and cubic for the scheduler and congestion when a while back I thought they were saying anticipatory/deadline and westwood were the best settings for the Pixi. In my testings I've found the latter to work better for me. Did I miss something, somewhere?

    proc_version: Linux version 2.6.24-palm-chuck (v1.4.5-128@org.webosinternals.kernels.uber-kernel-pixi) (gcc version 4.2.1 (CodeSourcery Sourcery G++ Lite 2007q3-51)) #2 PREEMPT Tue Nov 2 13:47:53 UTC 2010
    Current:

    From Service:
    Governor: ondemandtcl
    Scheduler: cfq
    Congestion: cubic
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.2 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 24 MB


    Files:

    cpufreq_file
    description "Govnah Settings"

    start on stopped finish

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    echo -n 'ondemandtcl' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo -n '320000' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo -n '787200' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo -n '200000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/sampling_rate
    echo -n '65' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/up_threshold
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/ignore_nice_load
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/powersave_bias
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_tickle_window
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_floor_window

    end script

    compcache_file
    description "Govnah CompCache Configuration"

    start on stopped finish
    stop on runlevel [!2]

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    swapoff -a
    insmod /lib/modules/`uname -r`/extra/xvmalloc.ko
    insmod /lib/modules/`uname -r`/extra/ramzswap.ko memlimit_kb=24576 backing_swap=/dev/mapper/store-swap
    sleep 3
    swapon /dev/ramzswap0 -p 1

    end script


    Profiles:

    (1) Fixed Speed 600 v6
    Governor: performance
    min freq: 600 MHz
    max freq: 600 MHz
    (2) Palm Default v6
    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 600 MHz
    sampling rate: 0.2 Sec
    up threshold: 80 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    (5) 787
    Governor: performance
    min freq: 320 MHz
    max freq: 787.2 MHz
    compcache enabled: true
    compcache memlimit: 16 MB
    (9) Tcl
    Governor: ondemandtcl
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.2 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 24 MB
  17. boyer61's Avatar
    Posts
    261 Posts
    Global Posts
    418 Global Posts
    #477  
    I experienced some insane lag with Profile 22. It was bad lol.

    Switched to profile 23, what im at now and it's back to normal, it was probably that "race to idle" thing.

    proc_version: Linux version 2.6.24-palm-chuck (v1.4.5-127@org.webosinternals.kernels.warthog-kernel-pixi) (gcc version 4.2.1 (CodeSourcery Sourcery G++ Lite 2007q3-51)) #2 PREEMPT Mon Nov 1 14:09:36 UTC 2010
    Current:
    From Service:
    Governor: ondemandtcl
    Scheduler: anticipatory
    Congestion: cubic
    min freq: 787.2 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB



    Files:
    cpufreq_file
    description "Govnah Settings"

    start on stopped finish

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    echo -n 'ondemandtcl' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    echo -n '787200' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    echo -n '787200' > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
    echo -n '100000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/sampling_rate
    echo -n '65' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/up_threshold
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/ignore_nice_load
    echo -n '0' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/powersave_bias
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_tickle_window
    echo -n '3000' > /sys/devices/system/cpu/cpu0/cpufreq/ondemandtcl/max_floor_window

    end script

    compcache_file
    description "Govnah CompCache Configuration"

    start on stopped finish
    stop on runlevel [!2]

    script

    [ "`/usr/bin/lunaprop -m com.palm.properties.prevBootPanicked`" = "false" ] || exit 0
    [ "`/usr/bin/lunaprop -m com.palm.properties.prevShutdownClean`" = "true" ] || exit 0
    [ "`/usr/bin/lunaprop -m -n com.palm.system last_umount_clean`" = "true" ] || exit 0

    swapoff -a
    insmod /lib/modules/`uname -r`/extra/xvmalloc.ko
    insmod /lib/modules/`uname -r`/extra/ramzswap.ko memlimit_kb=16384 backing_swap=/dev/mapper/store-swap
    sleep 3
    swapon /dev/ramzswap0 -p 1

    end script



    Profiles:
    (2) Palm Default v6
    Governor: ondemandtcl
    min freq: 122.88 MHz
    max freq: 600 MHz
    sampling rate: 0.2 Sec
    up threshold: 80 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    (18) 787
    Governor: performance
    min freq: 787.2 MHz
    max freq: 787.2 MHz
    compcache enabled: true
    compcache memlimit: 16 MB
    (22) Profile 22
    Governor: ondemandtcl
    min freq: 320 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB
    (23) Profile 23
    Governor: ondemandtcl
    min freq: 787.2 MHz
    max freq: 787.2 MHz
    sampling rate: 0.1 Sec
    up threshold: 65 %
    ignore nice load: false
    powersave bias: 0
    max tickle window: 3 Sec
    max floor window: 3 Sec
    compcache enabled: true
    compcache memlimit: 16 MB



    -- Sent from my Palm Pixi
  18.    #478  
    Quote Originally Posted by boyer61 View Post
    I experienced some insane lag with Profile 22. It was bad lol.

    Switched to profile 23, what im at now and it's back to normal, it was probably that "race to idle" thing.
    Do you still get the lag with the low-end of ondemandtcl set to 122.88 MHz ?

    Did the profile 22 lag persist after making it sticky, then clean reboot with usb cable disconnected?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  19. boyer61's Avatar
    Posts
    261 Posts
    Global Posts
    418 Global Posts
    #479  
    Quote Originally Posted by rwhitby View Post
    Do you still get the lag with the low-end of ondemandtcl set to 122.88 MHz ?

    Did the profile 22 lag persist after making it sticky, then clean reboot with usb cable disconnected?

    -- Rod
    I'll set that profile and run it for a couple of days to see how it runs.
  20. #480  
    gotcha rod, lemme see what I can come up with

Posting Permissions