Results 1 to 2 of 2
  1. Olidie's Avatar
    Posts
    385 Posts
    Global Posts
    387 Global Posts
       #1  
    Ok, I may have don't something stupid. I downloaded the a patch from the dangerous section (CPU scaling). I restarted my Pre and now it's stock on "palm" screen. What next? Help please
  2. #2  
    I smelled problems with these patches showing for Pixi users as soon as I saw them. The Pre has a different processor than that of the Pixi. The Pixi also runs at 600MHz out of the box. Therefore, only cpu scaling or smartreflex would have any effects assuming that our processor supports them.

    From the wiki, you can test the CPU scaling in a non-permanent fashion, if you have a terminal access to your Pre. (I installed the terminal app+plug in on the Pre) The settings will go away after a reboot, which sounds like a great thing. Assuming you are on a Windows workstation I can only think of attempting a WebOS repair (at the cost of loosing all of your stored data). If you are able to fix your Pixi and would like to manually attempt this changes (which are lost upon a power down) read below.

    CPU Scaling:
    The first command sets the scaling ("on demand") function, the second sets the processor speed. The listed is for 500Mhz, use "echo 600000" for 600Mhz or some other custom number.

    root@castle:/sys/devices/system/cpu/cpu0/cpufreq# echo ondemand > ./scaling_governor
    root@castle:/sys/devices/system/cpu/cpu0/cpufreq# echo 500000 > ./scaling_max_freq

    -----

    SmartReflex Voltage adjustment:
    Both of the commands need to be run to activate the smart reflex.

    root@castle:/sys/power# echo -n 1 > ./sr_vdd1_autocomp
    root@castle:/sys/power# echo -n 1 > ./sr_vdd2_autocomp

    You can overclock in concert with smartreflex with:
    root@castle:echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed

Posting Permissions