Results 1 to 14 of 14
  1.    #1  
    Just bought the Pixi touchstone compatible backcover, and placed it on my touchstone for my pre. It recognized it once, but after i took it off, it wont recognize it again. I tried to restart the device, still no luck.

    Anyone else have this problem? Could it be software related? Im gonna return the back cover tomorrow at sprint and try a different one to see if this cover is faulty or doesnt hit the contacts on the phone just right. I just hope its not the phone.
  2. a2k
    a2k is offline
    a2k's Avatar
    Posts
    103 Posts
    Global Posts
    111 Global Posts
    #2  
    I had the same problem. I remove it and placed back on again, this time pressing firmly on the back making sure the cover's contact touched the phone's contact. All is well now.

    good luck.
  3.    #3  
    well, replaced the back cover, it works more often now, but intermittently. It does the constant chirping on off thing. Plus, it takes some fidgeting with it to get it in the right spot to even start charging, which then leads to the on off charging.

    So, should i try to get a new touchstone? I never had this problem with my pre on this touchstone.
  4. a2k
    a2k is offline
    a2k's Avatar
    Posts
    103 Posts
    Global Posts
    111 Global Posts
    #4  
    Quote Originally Posted by GarrettQ View Post
    well, replaced the back cover, it works more often now, but intermittently. It does the constant chirping on off thing. Plus, it takes some fidgeting with it to get it in the right spot to even start charging, which then leads to the on off charging.

    So, should i try to get a new touchstone? I never had this problem with my pre on this touchstone.
    Sorry to hear you're still having problems. At this point I would exchange it for another. Hope you have better luck with the next.
  5. #5  
    Was the back cover damaged?
  6.    #6  
    Quote Originally Posted by csinsc View Post
    Was the back cover damaged?
    I had reason to believe that the first back cover was damaged, so i returned it for another one, which seemed to work more frequently, but not the way it should.

    I did notice that every time i put the Pixi on the touchstone, i could hear a pulsing noise when putting my ear next to the touchstone, so this led me to believe that the touchstone was the culprit.

    Went to sprint store today and spent 65 bucks on the damn charging kit because they dont sell touchstone by itself. (which is stupid)

    New touchstone seemed to have fixed the problem, its been on it for a few hours and seems to recognize the phone with no problem.

    Thank you all for your help, its much appreciated. I just wish i was able to get the touchstone by itself locally, since i was too inpatient to order online.
  7. #7  
    not sure how long this problem happened but I just came from sprint and they swaped my touchstone because it wasn't charging my pixi they said the warranty covered it. My question why did you have to pay for another one?. I bought mine in juneish lol
  8. #8  
    Get one from amazon for 35 + return

    Mine is finicky too...it will charge then not then charge then not...
  9. #9  
    did you get the cover from a Sprint store? none of mine have them and it's not like i live in the boonies or anything.
  10. #10  
    Are there anything wrong with the 2 prongs and plates with the Pre and back? Could see lint getting in the way of them...
    "Life is Hard... it's harder if your stupid"
    - John Wayne
  11. #11  
    Just picked up a cover and another stone. Doesn't work and it's not the stone because my Pre charges fine on both and the Pixi won't charge on either.

    EDIT: fixed it. there was a tiny piece of clear plastic covering one of the contacts on the cover. grabbed a pair of tweezers and peeled it off and it connected to the touchstone right away.

    did multiple tests afterwards both vertically and horizontally and it worked perfectly.
    Last edited by chud311; 11/29/2009 at 09:36 PM.
  12. #12  
    Does the screen always stay lit when the phone's on the touchstone? Anyway to get the screen to turn off?
  13. #13  
    I just bought the pixi touchstone cover and had the same issue. Pre worked fine on the touchstone but pixi would not. I opened up the cover and and noticed that one of the two contacts on the pixi itself was pushed down too far so it wasn't making contact with the back cover. I got a small nail and was able to push it up, then put the cover back on and it worked.
  14.    #14  
    Quote Originally Posted by vj1999 View Post
    not sure how long this problem happened but I just came from sprint and they swaped my touchstone because it wasn't charging my pixi they said the warranty covered it. My question why did you have to pay for another one?. I bought mine in juneish lol
    Whoops, been a while since i posted this, and i never checked it again after i found the solution for my situation. I didnt return my first touchstone because it worked fine with my pre, which i gave to a family member.

    I had looked into the contact issue under the back cover, but mine seemed raised enough to make contact. After buying the new touchstone, i havent had a single problem with it. I remember reading somewhere that the "coil" inside the touchstone was held in with glue and can loosen, so thats why i made the decision to just buy a new one. Although the old touchstone and pre are still working together perfectly for the family member i gave it to, so i dont know what really happened.

    Quote Originally Posted by webosuser View Post
    Does the screen always stay lit when the phone's on the touchstone? Anyway to get the screen to turn off?
    I dont think you can turn it off while on the touchstone, it goes into what palm calls "nightstand" mode. There may be a patch from preware that fixes that though.
    Last edited by GarrettQ; 12/17/2009 at 12:39 AM.

Posting Permissions