Results 1 to 20 of 20
  1.    #1  
    I am using Sprint and have no issue except every email I send from my treo comes with the following information in the From line whent he receipeint receives the email. I know that Sprint is relaying the message for me but is there some way to mask this information? It would look like the comment below:

    From: XXXXX@sprintpcs.com [mailto:XXXXX@sprintpcs.com] On Behalf Of XXX XXXX

    Thanks!
  2.    #2  
    Any ideas, anyone?
  3. #3  
    Using what email client? What server?
  4. #4  
    Mine does the same thing. It is because you are actually using Sprint's SMTP server to send the E-Mail. You have to authenticate on Sprint's server to send on behalf of your E-Mail account. There is no way to change this because Sprint is relaying the mail.
  5. #5  
    Could you just switch to gmail?

    Its free pop

    You could keep sprint as your delivery but still use gmails free smtp and still set it up as reply to XXXXX@pcs whatever....

    Know what I mean?
  6.    #6  
    Unfortunately this is my work email so going to google is not an option.

    On my desktop I am using Outlook and Versamail on my Treo. I have tried Agendus Mail and Chatter and both do the same thing (on behalf of). Additionally it is an IMAP server.

    It would just be great if there was some way to mask it so it looks more professional, oh well, my client still get a quicker response then if they had to wait till I connected my laptop. Thanks for the ideas and trying to help!!
  7. #7  
    But why is this an issue? How is it not professional that your emails are being sent with "on behalf of"? I use Snapper, it does the same thing, and I don't have a problem with it and neither does anyone who's receiving emails from me.

    Outlook does the same thing with its meeting requests if someone other than the meeting organizer invites you to a meeting. Microsoft doesn't seem to think that "on behalf of" is a problem.
    I'm back!
  8. #8  
    For 15 bucks you could set up fastmail as your smpt. I dont think it would matter if it is for work. You would still recieve your mail from sprint but you would send through fastmail. You can set it up to look as if it came from sprint.
  9.    #9  
    jmill72x - It is a preference not fact. No one has ever said anything to me about it and my email has always worked great but it is a personal hang up (as are most of my problems).

    Tem - Interstng idea but since sprint is already relaying my work email, it sounds like I would be be going from "on behalf of sprint" to "on behalf of fastmail"
  10. #10  
    you need to use your regular smtp server, not sprints...



  11. #11  
    Quote Originally Posted by horsmanp
    you need to use your regular smtp server, not sprints...
    Most ISPs don't let you relay outside email through their SMTP servers, hence, this is why everyone in this discussion is relaying through Sprint.
    I'm back!
  12. #12  
    My question is even if you use sprints IMAP why can't you just send using gmails free smtp.

    This is what I do.
  13. #13  
    Ow I just viewed the post above. Sometimes the site is hard to view on the treo.

    So would it say "on behalf of gmail" for sure?
  14. Biggles's Avatar
    Posts
    381 Posts
    Global Posts
    514 Global Posts
    #14  
    Unlocked GSM may work different from Sprint, but have you tried putting the same smtp server into Versasnail as you put into Outlook on your work PC?

    In GSM it takes it fine and sends it through my own server.
  15.    #15  
    Quote Originally Posted by Tem
    Ow I just viewed the post above. Sometimes the site is hard to view on the treo.

    So would it say "on behalf of gmail" for sure?
    It is worth a test. I have not setup gmail on my Treo yet but will give it a go and see what happens. My gut tells me that Sprint what will not relay it. I am assuming you mean smtp.gmail.com?

    Quote Originally Posted by Biggles
    Unlocked GSM may work different from Sprint, but have you tried putting the same smtp server into Versasnail as you put into Outlook on your work PC?

    In GSM it takes it fine and sends it through my own server.
    On CDMA with Sprint, it fails. My buddy is on Cingular and does not have the issue so it is tied to Sprint not wanting to Relay the message
  16. #16  
    My main mailbox in chatter has fastmail info on delivery and gmail info on the smtp settings.

    Ya, smtp.gmail.com
  17. fraslin's Avatar
    Posts
    11 Posts
    Global Posts
    19 Global Posts
    #17  
    I had the same problem with Sprint adding "on Behalf of" to my emails. Didn't like it as my boss could tell when I was in or out of the office. It is nice to knock off a little early and still send emails from the train.

    Anyway, I opened a $15 fastmail account as my SMTP and the problem was solved.
  18. #18  
    It is the sprint SMTP Server.

    I use fastmail .. Well woth the $$s
  19. #19  
    It is nice to GET your email IMAP but there is no point in paying $15.00 to use fastmails SMTP.

    There is no difference between sending email from the Treo with POP or IMAP.

    Gmail is more reliable than fastmail and gmails SMTP is free.

    You can set up a mailbox using 1 server for delivery and another for out going.

    When I send my email via pop it arrives instantly to my wifes treo via IMAP and shows my IMAP address in which to reply to.
  20. #20  
    While using Gmail's SMTP will in fact work, you will still get the "on behalf of" message. So if you are trying to send mail from a work account it will still say xyz@gmail.com on behalf of xyz@company.com.

    For some reason this only happens in outlook, not outlook express or chatter or others. Bottom line is it doesn't happen when relaying through fastmail.

    Quote Originally Posted by Tem
    It is nice to GET your email IMAP but there is no point in paying $15.00 to use fastmails SMTP.

    There is no difference between sending email from the Treo with POP or IMAP.

    Gmail is more reliable than fastmail and gmails SMTP is free.

    You can set up a mailbox using 1 server for delivery and another for out going.

    When I send my email via pop it arrives instantly to my wifes treo via IMAP and shows my IMAP address in which to reply to.

Posting Permissions