Results 1 to 4 of 4
  1.    #1  
    So, I've had my 600 from VZW for about one year now. Recently I've had problems that I just can't take anymore. One day I had it in my hand it just reset on it's own. Not just a reboot but a complete hard reset like that day I took it out of the box. I'm not kidding.

    It also freezes on incoming/outgoing calls at least 3 times a day. The phone keeps ringing but the device is otherwise frozen. After about 30 seconds it flashes "No Service", unfreezes, and then shows a signal again. This seems to be a common problem.

    So, I went into my friendly Verizon store today and spoke to technical support who said, "yup I don't even need to look at it, I know they suck". He had me talk to someone in sales who said he would do me a favor and allow me to upgrade to the Treo 650 for only $299 which is the normal 2-year contract price.

    I just paid $300 for the 600 one year ago. I don't feel that I should have to pay to get a working phone. I'm happy to keep using the 600, I just want it to work. I know if I call and file an insurance claim they're just gonna give me some refurb 600 that will end up having the same problems if not more.

    I'm not trying to get a freebie but why should I pay $299 to upgrade to a phone that I normally would not buy just to get a phone that works? He said if I try 3 or 4 times and it still doesn't work then they will probably upgrade me. Three or four times?? I have to waste my time b/c of a shabby product? He said to call 611 and see if they will upgrade me but that was all he could suggest.

    My question is, is this "No Service" thing an issue with many 600's? Am I just wasting my time if I have them send me another one? And, should I just wait for the 700w and upgrade to that (even if I have to pay) instead of trying to get them to give me a 650 and then having to pay through the nose to upgrade to a 700w early next year? Are they still saying Q1 06?

    Thanks for the advice but this phone is useless as it stands now.
  2.    #2  
    anyone? suggestions? am i going to have the same problems with another 600? should i insist on a 650?
  3. lazaruz's Avatar
    Posts
    136 Posts
    Global Posts
    161 Global Posts
    #3  
    i had the exact same issue on my 1yo vzw treo 600 2 wks ago

    what tech support had me do (after 1/2 of hold time) was to update the prl
    and i haven't had an issue again (by the way I had just updated the prl about 14 days before my problem)

    go figure
  4.    #4  
    Quote Originally Posted by lazaruz
    i had the exact same issue on my 1yo vzw treo 600 2 wks ago

    what tech support had me do (after 1/2 of hold time) was to update the prl
    and i haven't had an issue again (by the way I had just updated the prl about 14 days before my problem)

    go figure
    really? is that the *228 thing? i called today and talked to a very nice person in the data area. he said since i was JUST over my one year warranty they would send me a new one no charge. i don't have to go through insurance. i'm not sure if it's refurbished or not. i'll try it out but if this one does the same thing i'll demand an upgrade.

    thanks.

Posting Permissions