Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 47
  1. #21  
    1st & only 650 since Nov. '04. Still hanging on to my one & only 600 (Oct '03) as a backup (which I haven't ever needed to use). I guess I oughta sell the 600...
  2. #22  
    One and only 650 since late Nov. '04.

    Gone through the original Shadowmite ROMs, my own ROMs, dropped it a few times, never had any problems with my P...don't see why it won't last a few more months until my 18 mo. upgrade kicks in...then it'll probably be back to a WM device.
    MaxiMunK.com The Forum That Asks, "Are You Not Entertained?"

    Remember: "Anyone that thinks the Treo should just work right out of the box, shouldn't own a Treo..."
  3. #23  
    Purchased mine in Feb 2005. I switched from AT&T Treo 600 to Cingular Treo 650 and I'm still on the original unit, Minimal resets, does what I need it to do. Phone / Email and PDA.

    MM
    Cingular Treo 650 (Unlocked?!?)
    Firmware 01.51 Software Treo650-1.17-CNG H/W A
    Treo Wireless Headset - Apple Ti15 OSX 10.3.9
    Palm VII -> Motorola StarTAC -> Treo 600
  4. #24  
    I pre-ordered my 650, and received it during the first shipment. No problems with it, contrary to my 600, 300 and 270, which had many unhappy returns!

    Cheers!
    LZ
    That's me in the photo - you can check out my kung fu school at http://www.kungfuschool.org
  5. mgauss's Avatar
    Posts
    743 Posts
    Global Posts
    745 Global Posts
    #25  
    I must say every time I drop the darn thing something brakes. Now I've been unlucky and dropped it at least 5 feet onto marble every time. I'm on my third Treo.
  6. #26  
    im on my 2nd, both had the Orange UK freeze problem - flashed the 2nd and it cured the problem. I could have flashed the 1st but I didnt feel brave enough at the time. Bonus: Wiped off the horrid branding in the process
  7. #27  
    This would have made a good poll.

    I'm on my first one, I got min in Nov.04 dropped it on the driveway once updated to each new ROM then made my own. Have not had any problems everything works perfect but I do a lot of preventative maintenance making sure the RAM is clean and being physically careful with it.
  8. #28  
    Bought December 2004. Should still be on my first one, but they replaced my original for a 3rd party software glitch problem that (found out afterward) could have been fixed on the original. (Had to then fix it on the replacement.)

    Works great, no problems.

    Cheers, Perry.
    Last edited by gtwo; 11/07/2005 at 07:56 AM.
  9. #29  
    First and only unit here: AT&T / Cingular Treo 650,
    FW: 1.28 SW: 1.13 ROW, unlocked,
    running on Sunrise Swiss about 7 months.

    No resets, but the known freeze about three times a week.

    I'm also waiting for the update !
  10. #30  
    I'm still on my first from January 05.
    Remember, the "P" in PDA stands for personal.
    If it works for you, it is "P"erfect.
  11. morrie's Avatar
    Posts
    259 Posts
    Global Posts
    265 Global Posts
    #31  
    i have my cingular since 2/05. it is a little more buggy then my t600 but it is still acceptable.
    morris stalk
  12. #32  
    I ordered mine from Sprint telesales on the very first day it became available. It arrived the next day and I have been using the same phone ever since. I love it.
  13. #33  
    I'm on my first
    Factory unlocked/unbranded GSM 650 - Tmobile; FW: 1.71; SW: 1.20-ENA; Carrier DB: 255; HW: A

    If I'm repeating what someone has already said look at how long the thread is and ask yourself if you really expect me to read the whole thing.
  14. cardio's Avatar
    Posts
    779 Posts
    Global Posts
    787 Global Posts
    #34  
    Got mine as soon as cingular made it available, still on original. Dropped it more than once, bounced around in back of truck bed (sat it down in bed and drove back to highway from off road campsite), and accidently kicked across room on tile floor and watched in agony as it careened into the wall. Still works fine.
  15. #35  
    Still on the original Sprint Nov '04 shipment.
    I'm back!
  16. #36  
    Got mine in Feb 05 shortly after Cingular offered them. Still working fine. No problems.
  17. #37  
    I bought my Verizon 650 the day it came out back in May from Palm. I would have had it working fine today except for trying to close the door of my truck on it. My door sprung back at me while crushing my Treo. My replacement is working fine.
    Browse over to my new forum. http://www.palmfanatic.com

    "The wireless telegraph is not difficult to understand. The ordinary telegraph is like a very long cat. You pull the tail in New York, and it meows in Los Angeles. The wireless is the same, only without the cat. " - Albert Einstein

    Palm IIIxe - Kyocera 7135 - Treo 600 - Treo 650 -> Palm Vx - Tungsten T3 - Treo 700p
  18. #38  
    Sprint Nov. '04, still the first. I've just made a few custom ROM changes, but, same hardware.
  19. #39  
    Got mine in Dec 04. No -unusual- problems. About to jump to the ppc-6700 though.
    My Windoze toolz http://www.securitysoftware.cc
  20. #40  
    Me, with Sprint, got it in November of 04 and have made it through all updates
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions