Results 1 to 5 of 5
  1.    #1  
    Has any one find this useful. I have Shure E3C series and current adapter from Radio Shack - either plays with one earplug or you have to jiggle to get stereo. Wondering if this is an impedance issue
  2. #2  
    Quote Originally Posted by Tom Stack
    Has any one find this useful. I have Shure E3C series and current adapter from Radio Shack - either plays with one earplug or you have to jiggle to get stereo. Wondering if this is an impedance issue

    Hi Tom,

    Are you talking about using the audio out coupler with an INNO.Dock, or a different configuration?
  3. #3  
    Quote Originally Posted by Tom Stack
    Has any one find this useful. I have Shure E3C series and current adapter from Radio Shack - either plays with one earplug or you have to jiggle to get stereo. Wondering if this is an impedance issue
    it sounds more like the radiochack adapter just isnt fitting right and its slipping out. This can be solved with the regular sedico adapter. This isnt an impedence issue.
  4.    #4  
    Thanks
  5. #5  
    if you lookm closely with the Radioshack adapter in you can see that it doesnt sit flush with the treo. theis is because of the treos curved bottom. This causes it to come lose very easily. But yea... Order the sedico adapter and you will be fine. I use the sedico adapter with the e4's and it works and sounds great!! Now if only I could fix the problem with ptunes crashing my treo when playing music in the backgroud!

Posting Permissions