So the Palm Desktop that came with the 600 is now almost 2 years old, can I use 4.2 (which came with the 650) or 4.14 from the Palm website?
Thanks