Results 1 to 6 of 6
  1.    #1  
    Has any one noticed an X mark on their battery, even with 50% charge on? I noticed a RED X mark on the battery, and there was over 50% charge left in the battery. When I perform a soft reset, the X mark disappeared, but the battery was also drained. This is the second time it happened, and the last time, it was 15 days ago. Is this a software issue or a Battery issue? Usually, when my battery goes low, I just get a low charge indication, and when it is really low, the battery shows a red line at the bottom of the battery icon.
  2. Widdy's Avatar
    Posts
    75 Posts
    Global Posts
    78 Global Posts
    #2  
    Be prepared to get it exchanged. This is symptomatic of the defective battery connector that causes the dreaded "Network Search" malady. As it progresses; you will occasionally not be able to answer a call when the phone rings or you may not be able to place a call.
    Be sure to mention the red "X" when you talk to your carrier. If the phone is less than a year old they should replace it.
  3. #3  
    I also had this happen and ordered a battery. But before it got there I decided to open the treo and disconnected the battery and then reconnected it. It now seems to work great and haven't had any problems with it yet.
    Nate
  4.    #4  
    OK, I guess I need to speak to the vendor here. This phone was bought separately without any Phone plan in Singapore, and I am using this in India.
  5.    #5  
    Hi Nate,
    Does'nt the manufacturer warranty go VOID if I opened the handset myself to re-connect the battery?
  6. #6  
    Quote Originally Posted by ajayacharya_250
    Does'nt the manufacturer warranty go VOID if I opened the handset myself to re-connect the battery?
    Sadly but yes. And it's very common on almost all electronics.

Posting Permissions