im sure most know more than me but i thought id share what fixed mine.

i did all the settings like the other threads said to, used the APN string, and still didnt work.

what fixed it was at the dial up box i clicked the properties tab and in the "connect using" box not only was the standard modem over BT checked, my laptops built in modem was checked and placed above it.

i unchecked the built in modem and moved it down the list and BAM, connected instantly.

86 down and 35 up.

hope this helps someone as it was the problem with mine.