It finally worked! I had all the same problems discussed, port in use, unable to bluetooth sync. Here's what I did:

1) Made sure the Com Ports match. Right click on sync icon in tray
check the port number for local in setup. Match that number with
the port on your computer (mine was 3). <Start>
<rt. click My Computer> <Properties> <Hardware> <Device Manager>
<expand ports> <rt. click on Bluetooth> <properties> <port settings>
<advanced> <pull down to correct Com Port Number>

2) Unless you need it which I don't (got wireless) Disable your Modem
also can be done in Device Manager. <expand Modem>
<rt. click Disable>

3) Soft Reset Treo 650

4) Restart Computer

Hope this helps. I'm also still able to cable sync (usb). I run a Dell Inspiron 9200 Windows XP SP2 Professional. Internal Truemobile Bluetooth 350. Bluetooth Manager version 1. Treo 650, VZW.