Results 1 to 20 of 20
  1.    #1  
    ok, so this is my second week with my treo, and it's been working PERFECTLY. no problems whatsoever. until...
    i was riding the subway today, and i pulled out my 650 and the keyboard and function buttons are not doing anything for the phone. here's the weird thing:
    pressing the on/off/hangup button turns on the screen, but once i'm there no buttons work to get me out of there. i try a soft reset to get out of keyguard, but the buttons don't work at all. also, my touch screen works fine, so it's not an input issue.
    just my buttons and keyboard don't work.

    anyone have any ideas? i'd REALLY appreciate ANY help i can get!

    thanks
  2. #2  
    I don't understand...is the problem with the Keyguard or not? Launch Preferences and turn off the Keyguard. Is it still a problem? Are you using Butler? If so, are you using it's keyguard? You know that you have to press the center button to release control of the keyboard if Keyguard is on, don't you?
  3.    #3  
    hey bill,
    thanks for the interest and response. the issue isn't keyguard. the keyboard and all buttons are not responding.

    however, i can do a hard reset which is weird because pressing the off button has to register in order to do the reset, but once the reset finishes, none of the buttons work.

    pretty much the issue is this: the buttons don't respond at all for functional purposes, but they can give input to turn the screen on and perform different kinds of resets. why? i need my buttons and keyboard!
  4. #4  
    Quote Originally Posted by mattkopko
    hey bill,
    thanks for the interest and response. the issue isn't keyguard. the keyboard and all buttons are not responding.

    however, i can do a hard reset which is weird because pressing the off button has to register in order to do the reset, but once the reset finishes, none of the buttons work.

    pretty much the issue is this: the buttons don't respond at all for functional purposes, but they can give input to turn the screen on and perform different kinds of resets. why? i need my buttons and keyboard!
    So you're saying that after performing a hard reset and choosing to erase all data, that before you perform a restore hotsync, your keyboard still doesn't work? If it doesn't work after all data has been removed, then you've got a hardware problem.
  5.    #5  
    yeah it still doesn't work. i was afraid it was a hardware problem. i just figured i'd test the waters here because a) going for a replacement is a pain in the *** (not to mention the days i will be going phoneless) and b) it seemed weird that, for example, the power button responds enough to tell the phone to do a hard reset (another example: after doing the hard reset, it asks to press the up botton to confirm data erase, and that worked!)...

    isn't that weird?
  6. #6  
    Yeah. You'll need to return it for a replacement.
  7.    #7  
    ugh.

    thanks for the help, though!
  8.    #8  
    OK

    so my new treo replacement wasn't supposed to come until today. then, last night, i brought the "broken" treo out to show someone how "broken" it is, and the keys started working fine. the phone is 100% functional, though the hard reset has made me have to set up the phone once more.

    i swear this isn't some stupid "i didn't know keyguard was on" thing. i am totally dumbfounded. after 2 days of not working, the keys and buttons are now totally operational.

    anyone have any idea why? is there some actual hardware "hold" switch that turned off the buttons and now magically turned them back on? i'm so glad my treo now works, but this whole no-reason-for-the-fix thing has me spooked / concerned it might relapse...

    any thoughts?
  9. #9  
    Ugh. I'm right with you. The exact same thing just happened to me. Overnight, too, like in a matter of hours.

    I took it into Sprint to get it fixed, but when the sales dweeb said the tech said I'd have to hard reset it as the first step to even diagnosing the thing, I said I'd take it back for now and try to figure out a way to back everything up to the card without being able to use the keypad. Lo and behold, when I took it back from him, everything worked except one of the hard buttons (which worked maybe 75% of the time). I had to go to work by then and wasn't able to back everything up to the card, and now the problem is back again. It's wonderful that all I can do with my phone now is 1) turn it on and 2) take the battery out to turn it off.
  10. #10  
    Well, this seems to be the thread I'm looking for. I've been away from TC for a while, but a co-worker, who bought a 650 a few months ago on my recommendation (the least he could have done was buy me one, too. I still have a 600) is having the same problem as you all, and I am where he comes when he has Treo trouble. I told him I would try to research it, but he would probably have to take it in for an exchange. I did find a way to turn it on, but it is not ideal... Instead of pressing a button, change the SD card state. That is, if the card is in, remove it; if it is out, put it in. I found that that turns on the screen, and enables the center button to disable the keyguard, but one has to do it every time one wants to use the Treo. Also, his menu button still doesn't work. Could someone else who is having this problem let me know if SD trick works for them, and if the menu key is working or not? Thanks.

    Forgot to mention... I only found out about the issue this morning. He said it started the other day, but then, for a brief period, it was fine, and now it is having the problem again, which seems to be consistent with the reports from the rest of you.
  11. mabmarc's Avatar
    Posts
    146 Posts
    Global Posts
    149 Global Posts
    #11  
    This could be the stuck key issue that the Treos used to have. Check all the keys to make sure they click when you press the buttons. Especially the "P" key. If a key is stuck down none of the other keys will work except maybe power. If the key becomes unstuck all functions would return to normal. I had 3 Treo 650's with the stuck "P" key and they all had symptoms like you mentioned.

    Marc
  12. #12  
    Thanks for the info. My coworker took his 650 to Sprint this afternoon, and they were able to replace the keypad, so he didn't need to completely replace the Treo. It seems to be working fine now.
  13. #13  
    I'll weigh in as another person having the keyboard problems described above:
    1) power button works _only_ to turn on device
    2) keyboard sporadically works
    3) menu button _never_ works
    4) All this and I can't seem to get the "Remove Bush from White House" function on my Treo 650 to work...

    Crossing fingers that the new keypad or the "stuck P key" solutions help. Thanks to all who have offered ideas.
  14. BenJoeM's Avatar
    Posts
    786 Posts
    Global Posts
    787 Global Posts
    #14  
    This is happening to me now...it is crazy just out of the blue the phone stopped working all of the keyboard and button functions except the volume buttons. I am on the phone now with sprint and they are saying to take it into the store. I will keep you all posted
  15. nuke's Avatar
    Posts
    7 Posts
    #15  
    I had the same problem with my T600. I cracked it open, adjusted the ribbon cable inside and it worked perfectly after....it goes without saying, that I voided my warranty.
    -------------
    NUKE
    T650 - FW 1.31, SW 1.15G
  16. BenJoeM's Avatar
    Posts
    786 Posts
    Global Posts
    787 Global Posts
    #16  
    Update:

    I finally got it to Hard Reset and it still was happening, so I took out my SD Card and BANG! It was fixed. I put it back in and I had no problem. But Sprint has already flagged my account to receive a new one and my P button is going out so I am going to replace it anyways, I am now attempting to resync my data to see if it was a software problem.

    BenJoe
  17. BenJoeM's Avatar
    Posts
    786 Posts
    Global Posts
    787 Global Posts
    #17  
    Final Update,

    Sprint Said it was a freak thing and that I would need to have a new phone ordered. I mentioned I heard others were having the problem and they said they are aware of it and are having all those phones replaced when it is brough to there attention.

    Finally they wanted to order a new phone in and wanted me to wait until Friday, I said DO YOU KNOW HOW MUCH I PAID FOR THIS PHONE, I DON'T THINK SO! Well, they got me a new phone that minute (I kept my stylus so now I have two).

    Good Luck Ciao
  18. #18  
    I have this same problem, the SD card trick works, and whenever I hit the power key, the keyguard locks all the buttons again, so I can't press the power button to turn off the screen.... I believe one of my buttons is indeed stuck, and it's probably the alt key, which when pushed in conjunction with the power button activates keyguard manually, and you can't use the buttons, even the center key to release keyguard... So I wait for the screen to turn off (set at 30 seconds!) then hit the SD card from a black screen, and all my buttons work perfectly...until I hit the power button again (I have to learn NOT to hit that button for awhile)

    PITA.

    Anyway, I am interested in the 'replace keyboard' option, rather than using my insurance to replace the entire phone.... I took it into Sprint, and since they could tell it had been dropped (a looooong time ago, but functioned fine for months) they would not service it at all... Is that bogus too?

    Also, my computer is in the shop, and I won't have it back for about a week, so if I get a replacement Treo, can I backup a brand new phone from my SD card?

    Any help is appreciated.

    Thanks!
  19. #19  
    Same problem here, but on an unlocked GSM 650. UGH so frustrated...

    The other bizarre thing is that it is telling me that the phone is charging when clearly it is not...
  20. Mr Bok's Avatar
    Posts
    56 Posts
    Global Posts
    70 Global Posts
    #20  
    Quote Originally Posted by jeffhas
    I have this same problem, the SD card trick works, and whenever I hit the power key, the keyguard locks all the buttons again, so I can't press the power button to turn off the screen.... I believe one of my buttons is indeed stuck, and it's probably the alt key, which when pushed in conjunction with the power button activates keyguard manually, and you can't use the buttons, even the center key to release keyguard... So I wait for the screen to turn off (set at 30 seconds!) then hit the SD card from a black screen, and all my buttons work perfectly...until I hit the power button again (I have to learn NOT to hit that button for awhile)

    PITA.

    Anyway, I am interested in the 'replace keyboard' option, rather than using my insurance to replace the entire phone.... I took it into Sprint, and since they could tell it had been dropped (a looooong time ago, but functioned fine for months) they would not service it at all... Is that bogus too?

    Also, my computer is in the shop, and I won't have it back for about a week, so if I get a replacement Treo, can I backup a brand new phone from my SD card?

    Any help is appreciated.

    Thanks!

    They're full of BS!!! I was having the same exact issue you're having, and this is my 3rd replacement of the phone, all for keyboard issues (twice was a total keyboard failure, once for just the "p key of doom"). Anyways, my rep looked some stuff up, seeing that it was my 3rd replacement, and I definitely knew what I was talking about, and he pulled up an entry on the 650 that said pretty much verbatim reiterated the problem that you, and many others including myself, were having. Even let me know how to ID bad phones (apparently, new batches have been fixed, so I don't know how I got an old one just 2 weeks ago). Told me that I can refuse the replacement I'm getting in a few days, if it's in the bad batch. I'll let folks know how to tell, but because I don't want to be blatant about using this info that the helpful sprint representative (paradox? oxymoron?) gave me that he/she shouldn't have, I'll probably do it in another post, possibly under another user name. Quite frankly, I was surprised I could not find the identifying info on this board or on sprintusers.com.........
    Bok

Posting Permissions