Results 1 to 9 of 9
  1.    #1  
    Is there a utility that will turn Bluetooth on when the phone is turned on, and likewise turn BT off when the phone is turned off? I've spent a good deal of time looking for something like this and don't see it, either as a stand-alone product or as part of other utilities like launchers or profile managers.

    This is a battery saving issue as much as a convenience issue. Otherwise, every time I turn the phone on or off, I also have to go through several other steps - turn BT on/off too, as well as the headset. Saving at least one step would be nice.
  2. #2  
    try profilecare from www.gotreosoftware.com
    Treoing & Loving it
  3.    #3  
    I looked at ProfileCare, but unless I'm missing something, I'm not sure it does what I want. This isn't a time-of-day thing. When the phone is on, BT is on. When the phone is off, BT is off.

    Perhaps the manual profiles in ProfileCare would do it, but I don't see how you easily turn manual profiles on & off. It might be easier to just to manipulate BT directly. Am I missing something?

    Thanks....
    Last edited by RadicalDad; 07/04/2005 at 01:02 AM. Reason: typo
  4. #4  
    Give Blue Fang a try. It may be what your looking for:

    http://www.freewarepalm.com/utilities/bluefang.shtml
    -->BtDUN pre- and post- SprintPCS update 1.12 paired to PC and PPC.
    Darth_Maul -- a dark attacker, trained in the Jedi arts.
  5.    #5  
    Thanks for the tip. I installed Blue Fang, but it can only tell if the phone app is running, not whether the phone radio is on or off. If I were talking on the phone using BT, and went to the calender to schedule an appointment with my caller, Blue Fang would turn BT off when I went to the calendar. Almost, but not quite. Sigh.
  6. jacobh's Avatar
    Posts
    158 Posts
    Global Posts
    166 Global Posts
    #6  
    It will not turn off bluetooth if you are on a call and using a bluetooth headset. I have it set to turn on Bluetooth only when i enter the phone app, and then turn off as soon as I exit the phone app. With these settings it still works fine to check check your calendar, etc., even while you are on a phone call with your blue tooth headset. It won't turn off BT if you're in a call and using your headset.

    I find BlueFang works great for making my treo more responsive in general, because having bluetooth on slows it down just a bit when you are turning the screen on or off. So I set it to only turn BT on when I am in the phone app, and it seems to make the phone appear more responsive.

    Only one word of caution though, if you do a hard reset and clear your phones data, just the first hot synch may not re-install it properly. You may have to delete it and then re-install it, otherwise it may missbehave. At least this is what I have found. Another option though, would be to to use your backup program to restore your apps from your card, and in this case it seems to be re-installed properly.

    Cheers,
    Jacob H.
  7. #7  
    Quote Originally Posted by jacobh
    It will not turn off bluetooth if you are on a call and using a bluetooth headset. I have it set to turn on Bluetooth only when i enter the phone app, and then turn off as soon as I exit the phone app. With these settings it still works fine to check check your calendar, etc., even while you are on a phone call with your blue tooth headset. It won't turn off BT if you're in a call and using your headset.

    I find BlueFang works great for making my treo more responsive in general, because having bluetooth on slows it down just a bit when you are turning the screen on or off. So I set it to only turn BT on when I am in the phone app, and it seems to make the phone appear more responsive.

    Only one word of caution though, if you do a hard reset and clear your phones data, just the first hot synch may not re-install it properly. You may have to delete it and then re-install it, otherwise it may missbehave. At least this is what I have found. Another option though, would be to to use your backup program to restore your apps from your card, and in this case it seems to be re-installed properly.

    Cheers,
    Jacob H.
    Jacob, how does your T650 recognize incoming calls while utilizing BlueFang? When I've tried it, it silently acknowledges a call (noticed only because I was looking while testing it) with a dialog box asking whether to turn BT on or not. If I hadn't been looking at it, I would not have noticed and missed my call.

    RadicalDad, I've been looking for the exact thing that you are but haven't found anything. BTToggle Pro 2.5 has the same problem with handling incoming calls. Both developers (BTToggle and BlueFang) say there is no way around this problem from their standpoint.
  8. jacobh's Avatar
    Posts
    158 Posts
    Global Posts
    166 Global Posts
    #8  
    Quote Originally Posted by acousticbiker
    Jacob, how does your T650 recognize incoming calls while utilizing BlueFang? When I've tried it, it silently acknowledges a call (noticed only because I was looking while testing it) with a dialog box asking whether to turn BT on or not. If I hadn't been looking at it, I would not have noticed and missed my call.
    That's precisely what I was talking about where was talking of the circumstances when BlueFang "missbehaves". After I had been using BlueFang for a while it developed the problem you describe (i think it was from a file getting corrupt or a setting getting erased). After I deleted BlueFang, hot synched, then did a second hotsync reinstalling it with Quick Install, that fixed the problem for me. It currently just rings and does not prompt me about turning BT on for an incomming call, but it also doesn't automatically turn it on for an incoming call. For me this is fine because I don't usually have my BT head set ready at this point anyways. It automatically turns it on for my outgoing calls though (when I enter the phone app), which works fine for my purposes.
  9. #9  
    Radical One; is this your problem? if so, I have it too: I can turn off bluetooth; but when I next turn on the screen, BT insists on being turned on; If I respond no, the machine goes into a beserk loop. /The only way I've found to "fix" it is to take the batttery out and start over. So every time I turn the thing back on, if I am not using BT, I have to answer yes to the screen query, then manually turn BT back off again. If this is a feature, not a bug, it must be Windoze. I would love to have a fix for this as it really drains the battery if I don't catch it. thanks
    tony

Posting Permissions