Ok, I've figured out how to hotsync my treo 650 on OS 9.2.2 using hotsync manager 3.2 and the old desktop software with the new conduits that came with the treo.

However, I'm very concerned with installing the treo update 1.12 in this way. The update says that it requires OS X 10 point something and hotsync manager 3.2.1.

What's the worst that could happen if I try to install the update using hotsync manager 3.2 instead of 3.2.1? I know that the update changes the treo's ROM, so there must be a potential for some serious damage, right?

-joe