Page 8 of 12 FirstFirst ... 3456789101112 LastLast
Results 141 to 160 of 230
  1. #141  
    I've seen this type of thing once or twice, but I've never been able to reproduce it.
  2. #142  
    OK, perhaps it's a software conflict somewhere. Thanks.
  3. #143  
    Quote Originally Posted by doomsey
    I've seen this type of thing once or twice, but I've never been able to reproduce it.
    FWIW, I tried the application on a freshly-hard-reset Treo 600 and it still had the same problem, although it appeared to be less frequent than before (with a lot of other software loaded). My guess is that there's something in the KeyCaps600 code that's based on a timer, and that the code thinks the events are happening so close together that they're the result of a held key instead of a two keypresses.

    FYI this problem doesn't happen in the TreoKeyHack by Igor Nesterov. His software doesn't have the "repeat delay" feature that yours does, though, which I really like.... and they don't play nicely together for some reason (you can't use his keycaps feature and your delay feature -- the delay doesn't work if you do that)... so I really hope yours can be fixed at some point!

    Thanks, Jesse
  4. #144  
    I dont know when it started, but th updated keycaps no longer gets backedup when i hotsync. why is that
    Wisdom sheds light on the knowledge you have accumulated

    Palm Pre (Sprint)
  5. #145  
    Quote Originally Posted by jberman
    Every now and then, when I type the same letter quickly twice in a row, I get the option character for the second character instead of the letter I'm trying to type. For example, hello comes through as hel'o; occasion becomes oc8asion.
    Doomsey, I just wanted to thank you publicly for your work on this problem. It's been driving me nuts since I first started using KeyCaps600 a year ago, and you've been able to fix it in 0.9b7. Thank you so much!!!

    Jesse
  6. #146  
    Thanks for the fix doomsey!
  7. #147  
    I put a new version of keycaps, 0.9b9, up on my website. I left the old version for now because I changed a lot of things, but I've been using the new version for a week and it seems to work ok.

    It has three important changes:
    * Significant speedups in processing of the nav keys (may allow use of faster repeat rates without problems)
    * Adjustable notification priority (set to 'Last' for better compatibility with Butler, or 'First' to allow compatibility with textplus; unfortunately these are mutually exclusive)
    * A fix for bad interactions between autocompletion and keycaps

    controls for the latter two changes are on a new 'advanced options' page accessed via Menu-O.

    please let me know if you have any comments about this new version.
  8. #148  
    Activating any of the advance options causes my treo 650 to reset upon re entry to keycaps. Also keycaps doesn't function upon exit. After a reset and launching keycaps again, time preferences show gibberish characters as a sign of preferencw corruption. Not using advanced options gives me normal behavior. Btw, what is autocomplete?
  9. #149  
    Using keycaps even without the advanced options work well with Butler and textplus. I just don't get to disable it in phone app and I can't use the other advance options.

    Installation of keycaps via handzipper causes a reset too.
  10. #150  
    Problems like this can probably be worked around by deleting the old version before installing the new one.

    But that shouldn't be necessary. I'll try to figure out what's going on.

    edit: I uploaded 0.9b10 which fixes a possible way invalid prefs will crash on entering the 'advanced options' page.
    Last edited by doomsey; 09/04/2005 at 11:42 AM.
  11. #151  
    I believe it has nothing to do with preferences. I deleted my saved and unsaved and reset. At that point, its like having hard reset the treo. Enabling the advance options still caused a reset upon re-launching of the app. I had to re-launch as keycaps wasn't enabled. I deleted the app via uninstall manager and reinstalled via handzipper. This method causes the treo to crash. Install to ram option of resco explorer works though.

    Ignoring the advance options and just enabling keycaps (reset enabled and adjustment of second) have no problems.
  12. #152  
    Huh. I don't know... might be a conflict with some other software you use? Could be TextPlus; I'll have to try it.

    What happens if you don't check "Detect Autocomplete?"
  13. #153  
    Quote Originally Posted by doomsey
    Huh. I don't know... might be a conflict with some other software you use? Could be TextPlus; I'll have to try it.

    What happens if you don't check "Detect Autocomplete?"

    If I dont check any of the advanced options, there is no reset problem. It couldnt be other programs since I deleted all of my saved and unsaved preferences already but it still caused a reset. (Only with advanced options enabled)

    Have you recieved the email with my preferences?
    Last edited by MFB; 09/04/2005 at 11:10 PM.
  14. #154  
    Hi Doomsey!

    I am very happy using KeyCaps but this just seems to conflict with ShortCuts (s<alt><alt><alt><alt>hl) instead of displaying "hello" it will display "hlo'". I already mentioned this in one of the topics but I just do not know how to paste it here. The solution I did as a tip from Bill was to have "." after the shortcut name and it did show the correct word. Perhaps you can have a look since this might have something to do with the autocomplete function as well.
    Btw, ShortCuts will work if the KeyCaps is disabled.
    Regards.
    Last edited by GuWa7; 09/04/2005 at 11:03 PM.
  15. #155  
    Any update?
  16. #156  
    I can't reproduce either of these problems.

    GuWa7 - what do you use to set up the shortcuts?
  17. #157  
    Quote Originally Posted by GuWa7
    Hi Doomsey!

    I am very happy using KeyCaps but this just seems to conflict with ShortCuts (s<alt><alt><alt><alt>hl) instead of displaying "hello" it will display "hlo'". I already mentioned this in one of the topics but I just do not know how to paste it here. The solution I did as a tip from Bill was to have "." after the shortcut name and it did show the correct word. Perhaps you can have a look since this might have something to do with the autocomplete function as well.
    Btw, ShortCuts will work if the KeyCaps is disabled.
    Regards.
    try to adjust the repeat rate slower, if this doesnt fix it enable hold (e>1>E) and set click to lower e. one of these should work.
    Wisdom sheds light on the knowledge you have accumulated

    Palm Pre (Sprint)
  18. #158  
    doomsey,

    I hard reset my treo and restored my saved unsaved preferences ,keycaps, butler and netselect. I get the keycaps problem when I enable any of the advance features. Removing Butler and netselect, restoring saved preferences and a soft reset made the keycaps advance options work without any reset,disable problem or keycaps db corruption. I'm certain its one of my applications that is causing the keycaps reset. The mere presence of this application in ram affects it.
  19. #159  
    I use Butler and have no compatibilty problems. I know you use TextPlus; I don't, but I suppose I can do testing with it. I don't know what NetSelect is.

    If you can find a single program or a small set of programs that are causing the problem, let me know. I should be able to fix it if I can reproduce it, but since I don't have any idea whatsoever what is going on it's really hard to work on it right now.
  20. rigo's Avatar
    Posts
    143 Posts
    Global Posts
    196 Global Posts
    #160  
    It's been a while since I updated. I have v0.7 and there doesn't seem to be any problems with it. Do you think I would benefit from upgrading? Thanks.

    Rigo
Page 8 of 12 FirstFirst ... 3456789101112 LastLast

Posting Permissions