with the Sprint 1.08 upgrade. I just purchased a Motorola cr kit that does not work with my Treo 650 with the 1.08 upgrade. I tried a friends phone today and it worked. His phone is a treo 650 but it has the 1.03 software. Could the 1.08 upgrade be the problem?

Thanks,
Steve
skind@nyc.rr.com