I had a problem sending emails from my TREO600. Tried everything. Took it to
the carrier also. No help!
Now I have discovered that in the Advanced Tab of the email settings on TREO, it automatically assigns the "POP3" password for "OUTGOING MAIL SERVER". As soon as I "unassigned" the same, it started sending the emails.