Results 1 to 15 of 15
  1.    #1  
    Hi, I have bought a new Treo 600 unlocked gsm phone a month ago. The phone has shut off and will not turn back on. I have tried all resets including the battery reset. I have also opened it up to check the battery connection and it is good. I unplugged the battery and left it for a day to hopefully reset it this way. No luck! I also noticed that when I was charging it with the back off the battery was cold. If Im not mistaken, I think the battery is supposed to get warm if it is charging. Also, when certain buttons are pressed at the same time on the keyboard, the led at the top of the phone will light up red and stop when the buttons are released. Palmone support sucks really bad so I thought I could get help from the ones that really know what their doing. You Guys!!! So please, any help or suggestions on this problem would greatly be appreciated. Thanks from: No longer a Palm User in KY
  2. #2  
    Maybe These guys can help
  3. #3  
    Quote Originally Posted by 2dupont4
    Hi, I have bought a new Treo 600 unlocked gsm phone a month ago. The phone has shut off and will not turn back on. I have tried all resets including the battery reset. I have also opened it up to check the battery connection and it is good. I unplugged the battery and left it for a day to hopefully reset it this way. No luck! I also noticed that when I was charging it with the back off the battery was cold. If Im not mistaken, I think the battery is supposed to get warm if it is charging. Also, when certain buttons are pressed at the same time on the keyboard, the led at the top of the phone will light up red and stop when the buttons are released. Palmone support sucks really bad so I thought I could get help from the ones that really know what their doing. You Guys!!! So please, any help or suggestions on this problem would greatly be appreciated. Thanks from: No longer a Palm User in KY
    You posted this in the 600 forum and you state that it is 600. So, how were you charging it with the back off?

    If it is a 650 (and based on sxtg's post...it must be) then if you bought it new, why don't you take it back? If thats not an option, buy the palm oem battery. Good luck.
  4. #4  
    Quote Originally Posted by t2gungho
    You posted this in the 600 forum and you state that it is 600. So, how were you charging it with the back off?

    If it is a 650 (and based on sxtg's post...it must be) then if you bought it new, why don't you take it back? If thats not an option, buy the palm oem battery. Good luck.
    Actually he states that he opened it up. Also I gave hime the link because the 600 batt can be replaced it just requires opening the unit up.
  5. #5  
    I got confused by the link you gave him "Extended Capacity Battery For TREO 650 " and the fact that he was charging the unit with the back off ("I also noticed that when I was charging it with the back off the battery was cold")?
  6. #6  
    Quote Originally Posted by t2gungho
    I got confused by the link you gave him "Extended Capacity Battery For TREO 650 " and the fact that he was charging the unit with the back off ("I also noticed that when I was charging it with the back off the battery was cold")?
    I meant to link him to the actual battery site. My mistake.
  7. #7  
    A problem developed w my T600: I just changed the "Theme" for my Zlauncher set up using a common one that's been around. It worked for about 6 seconds then the screen turned white and the unit was frozen??? A soft reset brought it to my password entry page, but as soon as I hit a key it went white again. Warm reset fixed the problem and the response time is faster (changing apps). Thing is this happened twice before in different applications.....ideas?
  8. #8  
    happened again.........this time only a Hard reset brought everything back to life.
  9.    #9  
    Quote Originally Posted by t2gungho
    You posted this in the 600 forum and you state that it is 600. So, how were you charging it with the back off?

    If it is a 650 (and based on sxtg's post...it must be) then if you bought it new, why don't you take it back? If thats not an option, buy the palm oem battery. Good luck.
    Yeah, it is a 600. I had to open the back by taking the four screws out. Not to hard to do but a pain. Im guessing and hoping it is the battery. Am I right when I say it should at least get warm when charging? This phone won't even turn on period! Dead!! All I use it for now is a paperweight. Oh and yes, I thought about sending it back but it looks like a big hassle and I think I voided my warrenty by taking the back off. Thanks for the help so far guys but no luck. Any more suggestions? Thanks!!! and GO MARINES!!! Most of my family are marines!!
  10. #10  
    Quote Originally Posted by 2dupont4
    Any more suggestions? Thanks!!! and GO MARINES!!! Most of my family are marines!!
    Cool

    I just bought a new battery and torx screwdriver off of ebay for $24 bucks. I have the 'no service' problem and cant make any calls. Hopefully it will be here by tomorrow.
  11.    #11  
    Bought a new battery and tried to see if this would work. No such luck! Please any help on a one month old dead treo 600 would be helpful.Thanks!
  12.    #12  
    Also, when the A button is pressed and the 5 button is pressed on the keypad together, the led willm stay lite red and then goes away when you let go of those buttons. Any Suggestions?
  13. #13  
    Sir, your treo is dead. Since you've already opened the back, that voids your warranty. You even tried to change the battery but no luck. I suggest sending it back to P1 and have them repair it. It maybe a good idea NOT to mention that you opened it. Since it's now a paperweight, you really don't lose anything by sending it back. Good luck!
  14.    #14  
    Im thinking the same thing! Thanks for the help. Anyone interested in a one month old palm treo when I get it fixed from Palmone?! Will sell cheap with tons of accessories! Makes a great paperweight and conversation piece.
  15. #15  
    This probably doesn't apply to 2dupont4, but just as a general FYI - if your Treo dies make sure you check that your charger is still good. My Treo 600 recently lost all power and wouldn't recharge. (I didn't notice that the red light wasn't coming on when I plugged it in to the charger.) I was all set to buy a new battery on ebay when I decided to try another charger. I plugged it in to another charger, it worked and it is back to normal.

Posting Permissions