Page 2 of 2 FirstFirst 12
Results 21 to 36 of 36
  1. #21  
    Quote Originally Posted by alexburke
    Have him change the number he stored for your cell in his speed-dial -- insert *31# before the number, and his CID will be sent for that call only, overriding the block he has in place.

    #31# is the same as *67 on a landline -- blocks CID for that call only.

    Insert

    *31#

    or

    #31#

    Which?
  2. #22  
    Read my post again -- *31# at the beginning of the phone number to call ALLOWS CID for that call only, overriding the permanent block you may have in place with the "Block caller-ID on outgoing calls" checkbox.

    #31# BLOCKS CID for that call only.
    Alexander Burke
    Hardware hacker and all-around technogeek
  3. #23  
    And to think reading comprehension was one of my stronger traits in school!

    Apology is due and given!!

    Thanks for the info and measured response.

    Cheers, Perry.
  4. #24  
    Around these parts *67 before the phone # (at least with Cingular Blue & Orange) blocks CID on a per call basis (same as the PSTN line).
    Quote Originally Posted by alexburke
    #31# is the same as *67 on a landline -- blocks CID for that call only.
  5. #25  
    Quote Originally Posted by MisterEd
    Around these parts *67 before the phone # (at least with Cingular Blue & Orange) blocks CID on a per call basis (same as the PSTN line).
    That's because your telco has dumbed it down. 31 is the feature code for calling-number restriction; * enables, # disables. Follow it up with #, then the number you're calling, then SEND.

    This applies to GSM only.

    Look for "Number presentation":
    http://www.techgsm.com/page/network-...tor_codes.html

    Here's another one:
    http://www.gsm-security.net/faq/gsm-...lip-clir.shtml

    There is a lot of power and control available to those who know and use those codes properly. There's some really, really cool sh*t (damned censors) you can't do on TDMA or CDMA networks that you can do on GSM.

    Oh, one more little-known code: If you need to reach emergency services (911 in North America, 999 in the UK, etc), and you're using a GSM phone but you're in a country where you don't know the number, just call 112. This works everywhere, on every GSM network in the world, as far as I know.

    Can you tell I'm a GSM bigot?
    Last edited by alexburke; 06/13/2005 at 11:06 PM.
    Alexander Burke
    Hardware hacker and all-around technogeek
  6. #26  
    Actually they both work through my GSM (Cingular) service .... *67 and #31#.
    Quote Originally Posted by alexburke
    That's because your telco has dumbed it down. 31 is the feature code for calling-number presentation; * enables, # disables. Follow it up with #, then the number you're calling, then SEND.

    This applies to GSM only.

  7. #27  
    Quote Originally Posted by MisterEd
    Actually they both work through my GSM (Cingular) service .... *67 and #31#.
    *67 may work just fine on your carrier, but it's not guaranteed to work across GSM carriers. Why not just use the one that you know will work everywhere, including when you're roaming on another carrier's network? That's the point of standardization...
    Alexander Burke
    Hardware hacker and all-around technogeek
  8. Biggles's Avatar
    Posts
    381 Posts
    Global Posts
    514 Global Posts
    #28  
    The answer, for me, seems to be to leave the phone on while charging overnight, instead of turning it off.

    Then, in the morning, caller ID is still blocked.

    I assume there's no problem with doing this - best battery management advice seems to be to charge it every day, or every other day - does it matter that's the phone's 'on'; no-one can ring in the middle of the night while the charger's on anyway?
  9. #29  
    Quote Originally Posted by Biggles
    does it matter that's the phone's 'on'; no-one can ring in the middle of the night while the charger's on anyway?
    It makes no difference - it will just take slightly longer to charge if the phone is on, because some of the incoming power from the charger is used to power the phone radio. But your last statement is incorrect - the phone can receive calls any time the radio is on, regardless of whether it's being charged or not.
    Palm Pilot Personal -> Palm III -> Palm IIIx -> Visor Prism -> Clie TJ37 -> Treo 650 -> GSM Centro
  10. Biggles's Avatar
    Posts
    381 Posts
    Global Posts
    514 Global Posts
    #30  
    the phone can receive calls any time the radio is on, regardless of whether it's being charged or not
    How true. I was sure I had read somewhere that the phone didn't function when the Treo was charging.

    So it's just a choice: leave the phone on all night or remember to reactivate blocking of caller ID each time you switch on?
  11. #31  
    Quote Originally Posted by Biggles
    How true. I was sure I had read somewhere that the phone didn't function when the Treo was charging.
    What the hell kind of phone can't send or receive calls when it's plugged into a charger?

    Quote Originally Posted by Biggles
    So it's just a choice: leave the phone on all night or remember to reactivate blocking of caller ID each time you switch on?
    Neither. In the Phone application, press the Menu button, then go to Options, then Call Preferences. Tap the "Get Status" button. Check the box marked "Block outgoing caller ID", and tap OK.

    Once that's done, for extra oomph dial #31# and hit the talk button. The acknowledgement is instant, indicating it's setting something in the phone and not in the network.

    This setting should theoretically stay in place forever. On my carrier (Rogers Wireless, who can't properly run a GSM network to save their lives [although their recent acquisition of Microcell should get them some competent GSM network engineers]), I find I need to reset it around once every six months.

    So, for those phone numbers where you always want them to see your Caller ID, merely include *31# before the number (and before the +, before the 1, and before the area code as well, if the number includes any of those).

    Correct examples, for those that need it dumbed down to this degree:

    *31#+14165551212
    *31#16135551212
    *31#9055551212
    *31#5551212

    Problem solved. Quit b*tching and just try it already. It works.

    If this is the thanks I get for sharing my 10+ years of experience with both well- and poorly-run GSM networks (yes, I was a Microcell customer before going to Rogers [not by choice, I moved out of Microcell's coverage area]), then I'll keep my trap firmly shut from now on, and let you work yourselves into a lather, keeping my mouth shut, and enjoy my feeling of schadenfreude.

    (Bonus point if you can tell I've been up working all night and am overtired.)
    Alexander Burke
    Hardware hacker and all-around technogeek
  12. Biggles's Avatar
    Posts
    381 Posts
    Global Posts
    514 Global Posts
    #32  
    Neither. In the Phone application, press the Menu button, then go to Options, then Call Preferences. Tap the "Get Status" button. Check the box marked "Block outgoing caller ID", and tap OK.

    Once that's done, for extra oomph dial #31# and hit the talk button. The acknowledgement is instant, indicating it's setting something in the phone and not in the network.

    This setting should theoretically stay in place forever.
    I claim the bonus point. You're not paying attention, but that's understandable if you're overtired.

    It doesn't stay in place beyond the next time you switch off (or reset) your Treo. Whether or not you key in #31#.

    Er, that is, actually, the whole point of this thread :-)
  13. #33  
    OK, I was looking for things that have changed with the 1.13 software update, and I think this may be one of them. I note that now, if I select "Block outgoing caller ID", that option is still selected after a soft reset, though if I do a "Get Status" it goes off again. Unfortunately I don't have another phone with a caller ID display here to check whether it is actually still in effect.

    Perhaps someone else can verify whether the functionality, as well as the indication, survives a reset with this new version.
    Palm Pilot Personal -> Palm III -> Palm IIIx -> Visor Prism -> Clie TJ37 -> Treo 650 -> GSM Centro
  14. #34  
    the checkbox is still checked, but in reality the function is not still active
  15. #35  
    i just have the carrier permanently set mine up as blocked.
    works great for me, on sprint & vzw.
    iBug
    mac osx user new beetle pilot powerbook operator smartphone communicator

    ----------
    vzw.kyo6035 > vzw.kyo7135 > vzw.treo600 > sprint.treo650
  16. #36  
    Mine has always remained checked (despite resets) but it has never actually worked. i'm on Cingular
Page 2 of 2 FirstFirst 12

Posting Permissions