Page 2 of 2 FirstFirst 12
Results 21 to 37 of 37
  1. #21  
    Quote Originally Posted by silverado
    I just uploaded version 1.2b3. It has two minor modifications:

    - Added a warning when running from the SD card (program must be in RAM).
    - Corrected the program's version string to properly reflect its version (this is the version seen in the default launcher).

    It's awfully quiet in here, should I take this to mean that there are zero bugs in this program?
    1.XXX causes a corrupted saved preference when the following is configured:

    restore after reset
    Auto mode on
    Dbl-click Side Unused
    Shift+side Unused
    Option+alt Auto Mode

    After a reset, option+alt shows the alt key popup, instead of toggling Auto Mode.

    The only way to correct this is to delete the saved preference for KBlights and reconfigure.

    Doesn't seem to happen in any other configuration, though I haven't tried them all.
  2.    #22  
    Elysian9,

    Good find!! I will look into this and post a fix.
  3. #23  
    Quote Originally Posted by silverado
    Elysian9, Good find!! I will look into this and post a fix.
  4.    #24  
    Version 1.2b4 has been uploaded. It fixes the problem found by elysian9.

    (BTW, if anyone is interested, this wasn't caused by corrupted preferences, but rather by the application not responding to the options properly with these settings. You could get out of this state without deleting the preferences if you set one of the keystrokes that use the side button to turn the light on, then disable/enable the program)
    Last edited by silverado; 04/25/2005 at 03:02 AM.
  5. #25  
    Not sure I want to update, I found the current version I am using so darn could if it ain't broke .

    Thanks for making a great app, makes feeding my little one a bottle while ereading possible!

    Thanks again for a great product!
    I wish I had a dime for every dime I have
  6.    #26  
    Just uploaded version 1.2b5. It does the following:

    - fixes a reset bug that showed up when toggling auto mode in the Messaging application.
    - adds an icon for the default launcher's list view (also for McPhling and others).
  7. aldamon's Avatar
    Posts
    650 Posts
    Global Posts
    684 Global Posts
    #27  
    silverado, "Restore after reset" suddenly stopped working for me with the latest stable version from March. Then I upgraded to your beta version and it's still not working. Very strange. I think it might have something to do with the installation of TCPMP which also controls keyboard lights. I also tried out ScheduleCare briefly. Either could have screwed something up.
  8.    #28  
    Quote Originally Posted by aldamon
    silverado, "Restore after reset" suddenly stopped working for me with the latest stable version from March. Then I upgraded to your beta version and it's still not working. Very strange. I think it might have something to do with the installation of TCPMP which also controls keyboard lights. I also tried out ScheduleCare briefly. Either could have screwed something up.
    Hi aldamon,

    Do the keystrokes stop working after a reset? If you have Auto Mode on, is it on after a reset? Or is it only that the state of the lights isn't the same after a reset?
  9. aldamon's Avatar
    Posts
    650 Posts
    Global Posts
    684 Global Posts
    #29  
    The state of the lights is not correct after a reset. The keystrokes work fine so I turn them off after the reset. I don't use Auto Mode.

    It's really no big deal. It's probably just me. I guess having the keyboards lights on by default after a reset makes the most sense anyway.
  10.    #30  
    I would say it probably has something to do with the other programs you mentioned. The lights should be restored to their pre-reset state after a reset.
  11.    #31  
    I just uploaded version 1.2b6 which includes a new set of cleaned up icons (thanks to Frenzytom!). I've also made the backgrounds of the icons transparent, which will make them look much better with colored backgrounds.
  12. aldamon's Avatar
    Posts
    650 Posts
    Global Posts
    684 Global Posts
    #32  
    Hey Silverado. Good news! Before installing the new version, I disabled the program and soft reset the Treo. Then I installed the new beta, reset, and then activated it. The state of the lights after a reset is correct now. I think the reset cleared up the bug I created with the other software.
  13. #33  
    Downloaded the latest version. Looks very nice.

    One suggestion - I have it set to turn on auto on application key. It's kinda goofy when it turns on the lights when you go to turn the phone off. I'm not sure it's feasible to recognize not to turn the keyboard on when you're putting it to sleep, but it would be less "odd". Just a suggestion. Thx.
  14.    #34  
    Quote Originally Posted by aldamon
    Hey Silverado. Good news! Before installing the new version, I disabled the program and soft reset the Treo. Then I installed the new beta, reset, and then activated it. The state of the lights after a reset is correct now. I think the reset cleared up the bug I created with the other software.
    Glad to hear it!
  15.    #35  
    Quote Originally Posted by airjoe
    Downloaded the latest version. Looks very nice.

    One suggestion - I have it set to turn on auto on application key. It's kinda goofy when it turns on the lights when you go to turn the phone off. I'm not sure it's feasible to recognize not to turn the keyboard on when you're putting it to sleep, but it would be less "odd". Just a suggestion. Thx.
    I know what you mean and I think it's kind of goofy too. One little complication is that some applications take over that key so it's not used to turn off the device. This means that I would have to make it turn the lights on unless the device is going to go to sleep after the press, which could be quite tricky to do.
  16. #36  
    Hi Silerado

    Great program, especially at night using Tom Tom, but I'm having problems with it when Voice Dial is allocated to the side button. It won't turn on or off the lights by double clicking the side button.
  17.    #37  
    Quote Originally Posted by MikeProcter
    Hi Silerado

    Great program, especially at night using Tom Tom, but I'm having problems with it when Voice Dial is allocated to the side button. It won't turn on or off the lights by double clicking the side button.
    If it's assigned to the standard press-and-hold side button function (in Preferences -> Buttons), then it should work. If it's somehow assigned to work with a single click of the side button, then it won't work, nor would any other use of the side button.

    Which of the two cases is it?
Page 2 of 2 FirstFirst 12

Posting Permissions