Results 1 to 8 of 8
  1. heckj's Avatar
    Posts
    153 Posts
    Global Posts
    251 Global Posts
       #1  
    This is getting ridiculous, I ordered and payed for launcher x five days ago and have not received a reg code. I have sent 3 emails and have not gotten one response. Does anyone know how to get intouch with these guys? If I don't hear soon, I will report them to the proper authorities. This is no way to run a business.
  2. #2  
    Its been 9 days for me..
    Last edited by yodelinpug; 04/04/2005 at 02:05 PM.
  3. heckj's Avatar
    Posts
    153 Posts
    Global Posts
    251 Global Posts
       #3  
    I'm ready to go to the proper authorities. This is ridiculous. I have a feeling we are not the only ones.
  4. #4  
    Been 4 or 5 days for me as well.....(of course I was charged within a few hrs ;-) ). Maybe I am too accustom to the great response time from all the other developers around here...spoiled I guess. But from all the posts I've seen here and on launcherx's own forum, must just be poor customer service. They haven't responded to my email to their support either.
  5. #5  
    I finally got my code after one of my emails to them. They said the automated process must have failed...
  6. heckj's Avatar
    Posts
    153 Posts
    Global Posts
    251 Global Posts
       #6  
    I just got my reg code after a few more emails. I told them about you guys. They said to send new emails and check your spam filter. They said they have been shorthanded and and pretty backed up.
  7. #7  
    They also don't have anyone updating it's code currently, check the forums over there
    1 | 2
  8. #8  
    They are very slow, but it does arrive...at least from my experience...

Posting Permissions