Results 1 to 8 of 8
  1.    #1  
    Hi,

    I have a problem using my treo 600. Since i travel a lot, all my contacts are listed with the country code before their numbers. When i get a local call, only the area code and the phone number are shown, and thus the name is not displayed. Is there anyway that I can make my treo show the names without removing country code from all my local contacts? or maybe impose a local country code on incoming calls so the name would display?

    Thanks.
  2. #2  
    I am not 100% sure if this will work, but have you tried putting a '+' before their phone number? I think it worked for me. Good luck.
  3.    #3  
    Yes, I have done that. My country code is +961. Area code is 3. So i have all numbers saved as +9613xxxxxx. But when I get a call, it appears as 03xxxxxx and the name is not displayed.

    HELP!
  4. #4  
    This is strange. I am using the Treo650, and the Caller ID works perfectly.

    The contacts in my phonebook have +xx prefix. And for both local and international calls, the name of the callers show up fine.

    Could it be the telecom operator from your country?
  5.    #5  
    Nop. If i plug my SIM into any other phone it works just fine, so I'm ruling out the operator. Do you have North American Dialing one with your country code prefix?
  6. #6  
    I'm assuming your in North America and receiving international calls. Also, not sure if Dialing preferences would affect incoming calls, but I do have North Amerian Dialing without 'Always dial one...' checked off.

    Maybe it's firmware or software related? I have this:
    Firmware: 03.05
    Software: Treo600-1.12-INT
    Hardware: B

    Menu + I from main phone screen.
  7.    #7  
    Actually, I'm in the middle east. I have the same settings except that my software is: Treo600-1.12-ROW.

    The country code is +961.
    Area code is 3.

    So I have all numbers listed as +9613xxxxxx. If I get a call, number shows as 03xxxxxx and name does not display. I managed to do something. I added an area code of 961 in the North American Dialing preferences and saved the numbers as +3xxxxxx. It worked, but it's a very weird setting. I'm trying to update the treo software to the International version. Will let you know if it works. Any other suggestions?
  8.    #8  
    couldnt update. it said that the version on my phone is higher than that downloaded. I guess I'll just go with the North American Dialing thingy.

Posting Permissions