Results 1 to 7 of 7
  1.    #1  
    I just got off with Cingular CS. I told her that I was going overseas and my company wanted me to use a prepaid sim so they could reimburse me for calls. Since I was calling from my Treo she had my imei number and gave me the 8 digit code. A few minutes later, it's unlocked.

    I tried a friend's Suncom sim, and it said that this sim will not work with this phone. So did I get the right unlock number? Do i need to enter the number while his sim is in my phone? Will Suncom just not work on cingular's service? I'm trying to find someone that has t-mobile, as I know that they work on a gsm network. Any ideas? I followed the powerpoint show on how to unlock it, and it said that it worked. Where am I going wrong? My card did work in his phone, so it must be compatible. Grrr.
    Thanks
    Last edited by wktaylor; 03/29/2005 at 02:47 PM.
  2. SteveDu's Avatar
    Posts
    86 Posts
    Global Posts
    88 Global Posts
    #2  
    Your best bet is keep your Cingular's SIM in while entering the 8-digit unlock code and get a T-Mobile SIM and try it. Note that you can put in ANY 8-digit code in the #*#*xxxxxxx# format the phone will say the SIM lock has removed but the thing is you'll have to get an unique unlock code from the CS by telling their your IMEI code and make sure they got the right one too.

    If not, soft reset and try it again. Good luck too.
  3. #3  
    They say you need to wait 90 days before they can unlock your phone, has anyone experienced where they got it under 90 days?
  4. SteveDu's Avatar
    Posts
    86 Posts
    Global Posts
    88 Global Posts
    #4  
    Quote Originally Posted by rchung
    They say you need to wait 90 days before they can unlock your phone, has anyone experienced where they got it under 90 days?
    I did, less then 2 weeks
  5. #5  
    wktaylor - I had the same problem when I first tried to unlock my Cingular 650. I obtained the unlock code from a Cingular Techy and entered the code while my Cingular SIM was inserted. I got the sim code removed message and then tried to use a T-Mobile SIM in the phone. When I put the T-Mo SIM in and turned on the radio, I was promted to enter a code again. Of course as luck would have it, I didn't have the code handy at the time. I posted a message on this board and a number of people told me that the code should be input when another carrier's SIM in in the phone. The reasoning behind this I don't know. Long story short, I borrowed a T-Mo SIM again the next day and put it in the phone intent on entering the code again. Strange thing was, this time it worked fine with ever prompting me to enter the code again. Worked fine ever since. I don't know why it didn't work the first time, but maybe you'll find if you try it again the thing will work.
  6.    #6  
    I think the problem was that they had my wrong imei number. They had the one on file that I sent back to P1, so they gave me the wrong code. I was transfered to their tech support and they said that it would be emailed to me in a few days. Hopefully this will take care of it, when ever it comes.
    Thanks for the help, I'll let you know what happens.
  7. #7  
    Just to clarify the way to enter the unlock code is incorrect above.
    It should be *#*#xxxxxxx# <dial>
    The * and # were switched.

Posting Permissions