Page 2 of 6 FirstFirst 123456 LastLast
Results 21 to 40 of 104
  1. #21  
    Setting up PalmVNC is not the easiest thing to do. Adding security to your connection with a VPN client such as Mergic or Movian is another added complexity. In addition, if you use a software firewall (ie Norton Internet Security, Zonealarm) on your PC you'll have to configure your software firewall as well.

    One note that may be of help if your using SprintPCS as your Treo ISP:

    Although Sprint provides each Treo with a static IP, they use a subnet mask which changes the IP that your home PC will see. The Treo IP that your home PC sees is the broadcast IP as determined by the subnet mask. Thus, the Treo may appear to have a different IP address if you connect at different times. To get around this, I had to setup Norton Internet Security to allow the possible range of broadcast IPs that could be assigned to my Treo's static IP. Sprint tech support refused to give me this range. They instructed me to go to Treocentral.com and look for the "hacked DUN". Shadowmite would have liked that one!

    I got the range by going to http://www.showmyip.com/ and entering my Treo's IP in the IP address lookup form in the middle of the page. For anyone using Sprint and Norton Internet Security, their IP ranges are:

    68.24.0.0-68.31.255.255
    and 68.240.0.0-68.247.255.255

    Setup Norton Internet Security to allow connections to and from this range of IPs and you'll get through your software firewall.
    -->BtDUN pre- and post- SprintPCS update 1.12 paired to PC and PPC.
    Darth_Maul -- a dark attacker, trained in the Jedi arts.
  2. #22  
    Hi Blademonkey, sorry for delay, had to go out for awhile... Came in saw your response.

    Quote Originally Posted by Blademonkey
    Jeffhas,

    Please reference the attached Diagram. Took me a while to make because im not the best at Visio. .
    Got the diagram, can't say I get everything, but fairly self explanatory, except I'm assuming my 2Wire device is the router, I have no other device (modem) attached... DSL Modem must be SBC?


    Quote Originally Posted by Blademonkey
    Please take note of the four different Subnets. In each subnet, every device will have an unique IP address. In the case of your Modem and router, they will have two IP Addresses each (Since the DSL Modem is part of Subnet B and C, and the Router is part of Subnet C and D).
    Also note the Teal and Burgundy double arrows, we shall refer to the Teal as the Blue arrow and the Burgundy as the Red arrow. The blue arrow represents the data path of all requests going to your external IP address (Or your NO-IP.com address). The Red arrow shows the data path of that request once it gets forwarded to your internal IP.


    The VNC software package is two folds: A VNC Client application is installed on the Device (PC or Palm) that will do the controlling, and a VNC Server application is installed on a Device (PC or Server) that will be controlled. The VNC applications communicate with each other using a network protocol called TCP/IP (you can read up on the specifics of the this protocol on wikipedia.com). The TCP/IP protocol is setup is such a way that is segments itself is many different ports so that similar types of applications could use the same ports (For Example, <a style='text-decoration: none; border-bottom: 3px double;' href="http://www.serverlogic3.com/lm/rtl3.asp?si=22&k=web%20servers" onmouseover="window.status='<a style='text-decoration: none; border-bottom: 3px double;' href="http://www.serverlogic3.com/lm/rtl3.asp?si=22&k=web%20servers" onmouseover="window.status='<a style='text-decoration: none; border-bottom: 3px double;' href="http://www.serverlogic3.com/lm/rtl3.asp?si=22&k=web%20servers" onmouseover="window.status='web servers'; return true;" onmouseout="window.status=''; return true;">web servers</a>'; return true;" onmouseout="window.status=''; return true;">web servers</a>'; return true;" onmouseout="window.status=''; return true;">web servers</a> use port 80 and FTP server use port 21 by default).

    This is all configurable but as way to standardize things they are usually left alone. When you go to a webpage, like google you are actually going to a server that has a webpage configured on port 80, it just so happens that web browsers AUTOMATICALLY look at the port 80. VNC uses the following range of ports 5800-5999. That range is what we could consider "reserved" for the VNC application, just like port 80 is "reserved" for web pages.

    The main reason why we HAVE to forward ports is that the actual device that your Treo tries to contact is the one holding the external IP. In your case it is your 2wire Router. Since the VNC server is NOT installed on the router, then the router will not respond to the VNC client. What we want to do is redirect or forward all the requests coming from the range of ports that are "reserved" (5800-5999) for the VNC application to the Device that has the VNC server installed and configured. In this case, the VNC server is your PC..
    OK... I get some of this, but not all (as before). VNC is installed on my Treo and my PC.

    Quote Originally Posted by Blademonkey
    The internal IP I was refering to is the IP address of your PC on Subnet D. This IP is the one we have to forward the requests to.
    The External IP I was referring to is the IP address of the Router, or the ip address or name of your no-ip.com account.
    Internal IP is the one from IPCONFIG...right?... other must be the one from No-Ip...right?

    Quote Originally Posted by Blademonkey
    I hope that clears out the conceptual issues. now I think I'll need some screenshots of your router's firewall config to see what's going. Let me know.
    ... Oh yeah, everything's just CRYSTAL CLEAR now (who are you kiddin'?)... bu I'm tryin', as it gets configured, I'll catch on to some/most of it.

    My Questions are:

    1) Am I adding a Host/Redirect with No-Ip?... See Screenshot, I want to make sure I fill this our correctly.

    2) The 2Wire Firewall Settings has an option for an allowable application called VNC, which looks like what we need... I just want to make sure this is correct, or do I/we need to configure an entirley new custom application with our own original info?

    3) Which IP do I use in my Treo to communicate with the VNC server?

    I know I keep saying this, but I REALLY do thank you for your help here.

    I'm not sure what to do next, so I'll wait for direction from you?

    Had to Zip the Screenshots... don't know why, but couldn't get them attached any other way... kept getting an error.
    Last edited by jeffhas; 03/29/2005 at 06:54 PM.
  3. #23  
    Correct, the internal IP is the ipconfig IP. it's internal because it sits behind the firewall, away from prying eyes.

    1) Select DNS Host (A). Where it says hostname, type in a name (like jeffscomp, or deathstar). this will make your no-ip address into jeffscomp.no-ip.com or deathstar.no-ip.com. Then go to the bottom of the page and click create host.

    2) firewall settings look fine. Make sure you have changed the default password on the VNC server (see VNCServer.jpg). Once you connect, vnc will ask you for this password.

    3) The Ip you would use is the No-ip.com ip (jeffscomp.no-ip.com or deathstar.no-ip.com if those were the names you chose). or your external IP. which in your screenshot is xx.xx.xx.xx. Remember to select a hostname to add.

    It is essential that you understand that no-ip is only necessary in this situation because your External IP will change. If you had a Static IP using no-ip.com or any other redirecting service would not be necessary. No-ip.com gives a DNS service to dynamic IPs (which is what we're assuming you have). This means that currently (based on your screenshot) your EXTERNAL IP address is 69.108.71.92. This is what your Router has as an IP. One way to check your current External IP would be to go to http://www.whatismyip.com .

    So a good test to do would be to try to connect to your external IP from the VNC client(http://www.whatismyip.com). then if all works well, use jeffscomp.no-ip.com in the vnc console instead of the IP(if jeffscomp is the hostname you choose). Domain names (like google.com) are an easy way to get to an IP address. you could very well go to http://216.239.39.99 (which is google's IP) instead of http://www.google.com. they are the same address, one is just easier to remember.
    Attached Images Attached Images
    Last edited by Blademonkey; 03/31/2005 at 08:04 AM.
  4. #24  
    Quote Originally Posted by Blademonkey
    Correct, the internal IP is the ipconfig IP. it's internal because it sits behind the firewall, away from prying eyes.

    1) Select DNS Host (A). Where it says hostname, type in a name (like jeffscomp, or deathstar). this will make your no-ip address into jeffscomp.no-ip.com or deathstar.no-ip.com. Then go to the bottom of the page and click create host.
    This is done.



    Quote Originally Posted by Blademonkey
    2) firewall settings look fine. Make sure you have changed the default password on the VNC server (see VNCServer.jpg). Once you connect, vnc will ask you for this password.
    Every Time I change the Password, and close properties, when I go back in , the default password is present... Any way to 'lock' in the password?... This is my firewall password, etc.



    Quote Originally Posted by Blademonkey
    3) The Ip you would use is the No-ip.com ip (jeffscomp.no-ip.com or deathstar.no-ip.com if those were the names you chose). or your external IP. which in your screenshot is **.***.**.**. Remember to select a hostname to add.
    I assume by 'remember to select a hostname' you mean on the no-ip host add-on screen?... If so, this is done. jeffhas.no-ip.info



    Quote Originally Posted by Blademonkey
    It is essential that you understand that no-ip is only necessary in this situation because your External IP will change. If you had a Static IP using no-ip.com or any other redirecting service would not be necessary. No-ip.com gives a DNS service to dynamic IPs (which is what we're assuming you have). This means that currently (based on your screenshot) your EXTERNAL IP address is **.***.**.**. This is what your Router has as an IP. One way to check your current External IP would be to go to http://www.whatismyip.com .
    I completely get this now. Went to whatismyip.com, it is the same as was in my screenshot yesterday.



    Quote Originally Posted by Blademonkey
    So a good test to do would be to try to connect to your external IP from the VNC client(http://www.whatismyip.com). then if all works well, use jeffscomp.no-ip.com in the vnc console instead of the IP(if jeffscomp is the hostname you choose). Domain names (like google.com) are an easy way to get to an IP address. you could very well go to http://216.239.39.99 (which is google's IP) instead of http://www.google.com. they are the same address, one is just easier to remember.
    I tried, display shows: Connecting to **.***.**.**:5800
    Network Connected
    read nothing
    ERROR: cannot initialize
    **.***.**.**:5800
    connection closed


    I'm not sure if I set VNC up correctly on my PC, or if it is simply the password thing. When I tried to connect, I had opened VNC Server Properties, changed the password, hit apply, and reduced the window to keep the password in... but this can't be good.

    On my VNC Icon in the taskbar, there is an option to 'add client', in reading the manual, I am not clear whether this is for my Treo or not... Can you answer this for me?... hostname? ID Code?
    Last edited by jeffhas; 03/29/2005 at 06:44 PM.
  5. #25  
    Well im assuming you're running the VNC server on your PC. I'm not sure about an add client. I use the combination of PalmVNC on my treo and UltraVNC on my servers.

    If you have another PC on the same subnet as your PC (subnet D) then you should try connecting to your PC (via internal IP). If not, forget about it.

    the problem can be of two things.
    1) the VNC Server is not setup/configured. Once your set your password and save. VNC will mask it with stars or asterisks. this is done to prevent people from figuring out that your password is either 4 characters or 6 characters long. It will default to a set of characters.

    2) The firewall settings are not set properly. Check them again. In the PalmVNC setup, make sure you enter the VNC password under "Server Password".
  6. #26  
    You usually connect to a vnc server over port 5900, 5800 is more used by ultravnc for their web interface.
    "The danger from computers is not that they will eventually get as smart as men, but that we will agree to meet them halfway." -Bernard Avishai
    "Computers are a lot like air conditioners - they both work great until you open windows." -Anonymous

  7. #27  
    Tek To Da Rescue.

    how am i doing, tek?
  8. #28  
    Quote Originally Posted by Blademonkey
    Tek To Da Rescue.

    how am i doing, tek?
    I don't know about Tekara, but I think this is great. We're all learning here.
    -->BtDUN pre- and post- SprintPCS update 1.12 paired to PC and PPC.
    Darth_Maul -- a dark attacker, trained in the Jedi arts.
  9. #29  
    OK...

    I actually have PalmVNC on my Treo, and UltraVNC on my PC... but, I also have winVNC on my PC as well, it just wasn't active because I was trying to use UltraVNC. Since I was geting the errors with Ultra, and above post suggested the ports might be wrong or something, I removed Ultra from service, I installed winVNC into service, now I get a new error

    Connecting to **.***.**.**:5800
    Network connected
    read failure (Err=0X1212)
    ERROR: cannot initialize
    **.***.**.**:5800
    Connection closed

    Still no VNC at this point.

    Yes, I made sure password was set up on Ultra VNC server and WinVNC Server, and also on Treo VNCserver (same password all the way around now).


    Just a note about the Firewall settings. The access through my firewall is allowed by way of an 'Allowed Application' the one added to my list off allowable applications is VNC which has a public IP of 69.108.71.92 my external IP... Is this correct?

    Is there anything else you guys can think of?...

    My PC also has the built in Windows Firewall, that is set up right now to allow access through winVNC (or UltraVNC if I make that program active again - looks like I can switch). Do I need to allow certain ports in this field... or does the program suffice?

    Should I delete (uninstall) winVNC or UltraVNC?

    The reason I have both is I couldn't get Ultra to work, so I downloaded standard, it appears they both utilize the same application on the Treo (correct?)

    Are there any other settings that might need to be adjusted/corrected that you can think of on my Treo?

    Connection Name:
    VNC

    Server name or IP address:
    **.***.**.**

    Display number: 0

    Server Password: ASSIGNED

    Let me know how/if I've screwed this up?

    Thanks All!
    Last edited by jeffhas; 03/29/2005 at 06:42 PM.
  10. #30  
    You should only need to run one VNC Server app at a time. You can have both installed but make sure only one is running.

    Try disabling your windows XP firewall, that's pretty useless when you have your Router as a firewall.

    So things to do are

    1) make sure you're running 1 set of VNC Server software at one time.

    2) Disable or turn off Microsoft windows firewall altogether. Then try again.

    (note: ultra VNC is a modification of Winvnc that is geared towards the palm devices. One benefit to ultra VNC is that it does server side scaling, but we'll get into that later. All you need to know is that WinVNC and UltraVNC server are pratically Identical. I would stick with one to avoid confusion.).
  11. #31  
    I still think your using the wrong port, you should try connecting to 5900 instead of 5800

    Anyway, also try this, open up the viewer on the desktop with the server and have it connect to 127.0.0.1 (loopback) if it connects then we know the problem is either with the firewall or router but not the server
    "The danger from computers is not that they will eventually get as smart as men, but that we will agree to meet them halfway." -Bernard Avishai
    "Computers are a lot like air conditioners - they both work great until you open windows." -Anonymous

  12. #32  
    yea, he's right. I connect using 5900 as well.
  13. #33  
    Quote Originally Posted by Blademonkey
    yea, he's right. I connect using 5900 as well.
    I also use port 5900 with PalmVNC.

    I connect through port 1723, which is the Point to Point Tunneling Protocol (PPTP) port because I use MergicVPN to make my connection secure. But after I have a secure connection using MergicVPN, I use port 5900 with PalmVNC.
    -->BtDUN pre- and post- SprintPCS update 1.12 paired to PC and PPC.
    Darth_Maul -- a dark attacker, trained in the Jedi arts.
  14. #34  
    Do you run Citrix too? {= D
  15. #35  
    Quote Originally Posted by Blademonkey
    Do you run Citrix too? {= D
    No. Citrix uses IPSec to make their connection secure so you'll have to use MovianVPN, which is an IPSec client for PalmOS. I'm happy with the PPTP protocol that MergicVPN uses.
    -->BtDUN pre- and post- SprintPCS update 1.12 paired to PC and PPC.
    Darth_Maul -- a dark attacker, trained in the Jedi arts.
  16. #36  
    Just a quick heads up to newbies. You might want to be a little careful of posting your IP and open ports in an open forum. You never know...
    Click for Free iPod Nano or better. - really works!
  17. #37  
    Quote Originally Posted by Blademonkey
    You should only need to run one VNC Server app at a time. You can have both installed but make sure only one is running.

    Try disabling your windows XP firewall, that's pretty useless when you have your Router as a firewall.

    So things to do are

    1) make sure you're running 1 set of VNC Server software at one time.

    2) Disable or turn off Microsoft windows firewall altogether. Then try again.

    (note: ultra VNC is a modification of Winvnc that is geared towards the palm devices. One benefit to ultra VNC is that it does server side scaling, but we'll get into that later. All you need to know is that WinVNC and UltraVNC server are pratically Identical. I would stick with one to avoid confusion.).
    1) XP only lets you run one VNC server at a time.... I'll stick with Ultra.

    2) Turned off the Windows Firewall.


    Quote Originally Posted by Blademonkey
    yea, he's right. I connect using 5900 as well.
    Went in to PalmVNC on Treo, Edit, then Advanced. Changed base port to 5900.




    .....oh yeah... did I mention... IT'S WORKING!

    Thank you so much first and foremost Blademonkey, just for bothering to take me on as a project!... and of course MANY THANKS to everyone else contributing to this thread and throwing your 2 cents in where necessary so that I could be running with VNC.

    Just fiddling for a couple of minutes, it clearly is a bit slower that Win-Hand, and the 'scrolling' is pretty different... but I'll get use to it, it sure appears, even in just my limited experimenting, that VNC seems to run more smoothly and seems more stable... time will tell.

    So much for paying Win-Hand $15/mo to use this app.

    If you have tips regarding operation, let me know!

    APPRECIATE EVERYTHING!!!

    -Jeff
  18. #38  
    Quote Originally Posted by Magohn
    Just a quick heads up to newbies. You might want to be a little careful of posting your IP and open ports in an open forum. You never know...
    Yeah I thought about that, but it'll change soon, and it is the extrenal IP... still wanted the help, trust me, there's no great secrets on my PC, and even if you could get my personal info... you really wouldn't want it!... no one wants to be me!

    THANKS ALL!
  19. #39  
    Just a note, because everyone that I steer to UltraVNC overlooks this. Make sure you install the video driver for UltraVNC. It makes things much much faster...

    You can tell if it is installed by looking in Device Manager on your UltraVNC server machine. In display adapters section you should see an item called "Winvnc video hook driver".

    Also.. you can always test your UltraVNC server by using UltraVNC client on a PC first. If you can't connect using a PC, then your Treo isn't going to connect.
  20. #40  
    Quote Originally Posted by jeffhas
    .....oh yeah... did I mention... IT'S WORKING!

    -Jeff
    Congrats!!!

    Now you'll need to setup MergicVPN to secure your connection.

    And, edit your previous post by erasing your IP address.
    -->BtDUN pre- and post- SprintPCS update 1.12 paired to PC and PPC.
    Darth_Maul -- a dark attacker, trained in the Jedi arts.
Page 2 of 6 FirstFirst 123456 LastLast

Posting Permissions