Results 1 to 11 of 11
  1.    #1  
    does anyone know how to get the linux program 'KPilot' syncing with the Treo 600 ? Its saying it cant detect my device ?

    When booting off Windows it syncs perfectly with Agendus and also syncs perfectly at work on Lotus notes with Intellsync ...


    HELP!!!!!!!!
    blue jean baby, LA lady
  2. mmmm_beer's Avatar
    Posts
    44 Posts
    Global Posts
    46 Global Posts
    #2  
    I have not tried syncing in Linux yet, but a couple of things to check would be the correct USB module being loaded in the kernel. When you attach the Treo and try to sync, it should have been recognized by the kernel, a quick 'dmesg' should show you that some device ( in this case the Treo ), was found on a USB port. Also, if you use the command 'dmesg|more' (without the quotes), you see a message about a USB chipset was detected, if not, you may need to insure that the correct USB module is compiled for your kernel (UHCI,OHCI) one of them, I can't remember has two different modules, try each. I will try it myself, to see if I can get it work.
  3. mmmm_beer's Avatar
    Posts
    44 Posts
    Global Posts
    46 Global Posts
    #3  
    I was able to finally get it to sync, a couple of things you need to do, is to make sure that /dev/ttyUSB0 and /dev/ttyUSB1 exist, they can be created via:
    mknod /dev/ttyUSB0 c 188 0
    mknos /dev/ttyUSB1 c 188 1
    the Treo will connect for hotsync on /dev/ttyUSB1 and for some other reason the /dev/ttyUSB0, I can't remember what it does with that one. Then I had to sync it as root, you might be able to get it to work as a user if you chmod 666 to both ttyUSB[0-1] devices. Once I did it a root it would sync. Of course it kept deleting the /dev/ttyUSBx devices, something I haven't really investigated yet, but I am sure there is some way around that. Good luck.
  4.    #4  
    thank you
    blue jean baby, LA lady
  5.    #5  
    hmmm....none of that worked for me
    blue jean baby, LA lady
  6. mmmm_beer's Avatar
    Posts
    44 Posts
    Global Posts
    46 Global Posts
    #6  
    Did you try it as root? The one time it did work for me, I was root and had the device set as /dev/ttyUSB1 in the preferences. I was assuming (hoping), that doing the chmod on both the /dev/ttyUSB[0-1] devices would work, but it may not.
  7.    #7  
    yep tried that via root
    blue jean baby, LA lady
  8. mmmm_beer's Avatar
    Posts
    44 Posts
    Global Posts
    46 Global Posts
    #8  
    Is it getting detected on the USB port? After hitting the hotsync button, do a dmesg and check that at the bottom it is being detected as a Handspring device. If I get a chance later, I will see what else might affect it. I am using SuSE 9.2 Professional, with all the latest patches, is that the version you are using?
  9. Entropy's Avatar
    Posts
    97 Posts
    Global Posts
    157 Global Posts
    #9  
    Unfortunately I'm not familiar with SuSE or kpilot - I'm a GNOME + Gentoo user myself.

    First order of business - Nearly all of the sync programs for Linux are built on top of pilot-link. Thus it's the best place to start for debugging things.

    Do '/sbin/lsmod' - You should be able to do this as a non-root user. Look for a module named "visor". If it doesn't show, hit the sync button on your palm once then cancel. If it STILL isn't showing, run "modprobe visor" as root.

    Depending on whether SuSE uses udev or not (nifty new device file management system for 2.6 kernels), you may find that the USB tty devices disappear when the Treo is not actively attempting to sync. BTW, on my Gentoo box, the main files are /dev/tts/USB0 and /dev/tts/USB1, which are symlinked to /dev/ttyUSB0 and /dev/ttyUSB1 (and I've configured it to also symlink to /dev/pilot).

    Now, if the visor module shows in lsmod and the device files exist when your Treo is trying to sync, the next step is to disable whatever sync functionality kpilot has (this is temporary).

    From a shell, run "pilot-xfer -p <device> -l" AFTER you have hit the sync button on your Treo and waited a second or two. <device> will most likely be /dev/ttyUSB1 or its equivalent. Default is /dev/pilot if you don't specify -p. (Note: in the beta versions of pilot link, there is no longer a default port. This is almost surely not an issue for you, but just a heads-up for the future.)

    If this works (you should get a list of everything on your Treo), then you know that the device files and kernel are set up properly.

    If not, let us know and we'll see what we can do.
  10.    #10  
    okay thanks, lemme try that...

    *looks around for a geeky guy IT guy to help translate that into english*
    blue jean baby, LA lady
  11.    #11  
    okay thanks, lemme try that...

    *looks around for a geeky guy IT guy to help translate that into english*
    blue jean baby, LA lady

Posting Permissions