Results 1 to 11 of 11
  1. rcgabriel's Avatar
    Posts
    91 Posts
    Global Posts
    96 Global Posts
       #1  
    After reading so many horror stories about the GemPlus SIMs with Cingular, I was just wondering if anybody has had any issues with T-Mobile SIMs in unlocked Treo 650s. I am unable to find any real info on T-Mobile SIMs in general, and don't even know how to tell if my SIM is a 32k, 64k or what (it's brand new, they just gave it to me a few weeks ago after I lost my Treo 600 which had my old SIM card in it).

    I am curious because I am experiencing some intermittent lockup issues, which are probably software related, but I'm just checking anyway to try to rule out other causes.
  2. #2  
    unlocked & tmobile, no problem here
    treo 650: on my hand nya nya nya!
  3. #3  
    No problem with my T650 on T-Mo either.
    "Once a new technology rolls over you, if you're not part of the steamroller, you're part of the road." - Stewart Brand
  4. #4  
    NO problem here either.
  5. #5  
    When I first activated my T-Mobile SIM in my unlocked 650, everything slowed to a crawl. No actual crashes, but the phone was unusable. I just got a replacement 650 and it works perfectly - well, I've only had it one day!

    Anyway, there obviously were a few 650 lemons that didn't like SIM cards - probably all SIM cards.
  6. #6  
    no problems for me. put it in and it has worked perfectly. no resets, no problems. and as i am in so cal, edge speeds!. thank you cingular network.
  7. #7  
    I got my Unlocked 650 two weeks ago, popped in my T-Mobile SIM and it has been working like a charm since...
  8. #8  
    For all the previous posters that have working Tmobile SIM on unlocked phone. Do any of you have a Gemplus SIM? Wonder if unlocked version will also have problems with Gemplus SIM like with Cingular verison. I have Tmobile SIM which is Gemplus and am waiting for Vienna Channel unlocked Palmone treo. Thanks
  9. raziel's Avatar
    Posts
    180 Posts
    Global Posts
    451 Global Posts
    #9  
    No MAJOR problems. Just that the phone resets itself once every few days, but I think it's verichat causing that. I'm also in SoCal enjoying the EDGE speeds for $4.99. However, once inawhile, when I'm on the 101 around Universal and Hollywood, I get a Network failure and I have to reset the phone to find the Network again.
    Palm III -> Sony Clie 73V + Sony Ericsson 610 -> Sony Ericcson P900 -> Nokia 6600 + IPAQ 4150 -> Treo 650 -> BenQ P50 -> Motorola Q -> Treo 755p -> HTC Titan (Sprint Mogul)
  10. rcgabriel's Avatar
    Posts
    91 Posts
    Global Posts
    96 Global Posts
       #10  
    How do u tell a Treo gemplus SIM? There are no letters on my SIM at all, just a bizarre bunch of number groupings and a strange logo/symbol in the corner that looks like the letters "GD" or "GED". Have no idea what that means and can't find any discussion on tmobile sim cards on the web.
  11. #11  
    Quote Originally Posted by soulreaver99
    No MAJOR problems. Just that the phone resets itself once every few days, but I think it's verichat causing that. I'm also in SoCal enjoying the EDGE speeds for $4.99. However, once inawhile, when I'm on the 101 around Universal and Hollywood, I get a Network failure and I have to reset the phone to find the Network again.
    I haven't had any issues until I installed Treo Alarm (0.95c). Shortly after that, I started getting soft reboots, randomly, as well as, network failures. Basically, I'd notice my phone wasn't connected to the GPRS network and when trying to reconnect (via Prefs --> Network), it would fail and give me an error code. Only resolution is to soft reset the phone...oh, and I just uninstalled Treo Alarm so hopefully these issues will go away.
    ----------------------------------------------------------
    Unlocked GSM Treo 650 | T-Mobile
    Received: 2/10/2005

Posting Permissions