Results 1 to 9 of 9
  1.    #1  
    I had the sprint 650 and whenever I pushed the 5 way button to dial it took 2 seconds to dial. My Cingular GSM 650 dials instantly when I push the 5 way button
  2. #2  
    Yeah, my PalmOne Treo on Cingular dials fast. I really see no lag switching apps, dialing, or anything. Furthermore, the touch tones dial faster than they did on the 600 (which dialed them SLOW)
    Treo 750 (AT&T)
    Treo600->Treo650->Cing8525->Blackberry 8700c->Treo750->AT&T Tilt->Treo750->iPhone 3G
  3. #3  
    Yup. When I scroll thru my contacts and pic one to dial, it dials right on the spot. No lag.
  4. #4  
    Really? That's great for you guys. This is the one and only feature, or problem I should say, regarding the Sprint 650. I can't stand it. It reminds me of the 7135.
  5. #5  
    Is this a problem specific to the CDMA Treo 650s? Are Verizonized Treo users also reporting this?

    Quote Originally Posted by GalenMD
    Really? That's great for you guys. This is the one and only feature, or problem I should say, regarding the Sprint 650. I can't stand it. It reminds me of the 7135.
  6. #6  
    I am using a Verizonfied 650. It seems that this a CDMA issue, either hardware or software related.
  7. #7  
    Yes, the unlocked GSM on T-Mobile has zero delay as opposed to the couple of seconds delay I normally saw on the Sprint version.
    Main Phone: Treo 270/600/650/700w/700p/750v/Motorola Q/iPhone
    Tried but sold: Motorola Q/Nokia E61/700wx/HTC TyTN/Treo 680
  8. #8  
    Quote Originally Posted by bcaslis
    Yes, the unlocked GSM on T-Mobile has zero delay as opposed to the couple of seconds delay I normally saw on the Sprint version.

    Same here .
    Unlocked GSM on Tmobile.
  9. #9  
    same here.
    I think that although there are some new issues:
    Voicemail dialing

    GSM users are not experiencing these issues Sprint users faced:
    Sound problem in earpiece and for the person called
    Bluetooth problem
    Button Lag problem
    Network Time issue

    Right? Are there other issues?

Posting Permissions