I have fixed the problem with getting all of your messages every time. First go into server setting and check it to leave mail on server and make sure the delete from server is not checked (obviously with gmail you dont want them deleted). Then go to delivery options andcheck "unread messages", you can check the "get" or "download" button to your preference but do not check the "mail from" button. Now back out and hit syc, it will download all of you messages this time. Once they are downloaded open the option screen on the top and "select all" then go back in and select "mark read" then delete them. From now on you will only get new, unread messages.