Results 1 to 9 of 9
  1.    #1  
    Well one of the main reasons I purchased the 650 from the 600 was to use a Bluetooth Headset. I'm sure that many of you upgraded for the same reason.

    I've tried several headsets and will post a quick review along with a question...

    Jabra 250 from Palm - Worthless headset - return immediately - heavy crackling sounds even from 1" away from Treo phone.

    Bluespoon AX - Clever design, some crackling sounds, a lot better range than 250. Very comfortable, but outgoing sound when driving a car is not the best.

    Sony HBH-660 - Caller ID has minimal usefullness due to the size of the screen and the number scrolls. Similiar or slighlly less crackling than the AX. Using a clear jabra eargel helps with low sound from the headset. However, there is a VERY annoying beep when answering/hanging up on a call. Moderate range if in line of sight of phone.

    Sony HBH-300 - Best outgoing sound quality of the group. However, for some reason the voice is not automatically transferred to the headset when dialing a call or receiving a call. Has anyone gotton this to work? It works on the 660. Also, has anyone tried to remove the ear hook and use an eargel?

    Thanks... Based upon reading other forums/posts it seems the Bluetooth radio on the headset is really weak on the 650. Bummer!!
  2. #2  
    I purchased both the Sony 660 and the Cardo 500.

    I've only tried the Sony 660 thus far with good results, EXCEPT the ear piece is UNACCEPTABLY UNCOMFORTABLE for me. The way the ear clip is positioned, the ear piece sits high on my ear, way above my canal. The volume is too soft and it hurts.

    Before I bail on the Sony 660, are you aware of anyway to adjust it so that it the ear piece sits low enough to fit over my canal?

    BY THE WAY, went through just about every convergence device and LOVE the Treo 650 after 2 weeks. Use it with Mailstreet and Goodlink to constantly sync with my office Microsoft Outlook exchange server.

    David
  3. #3  
    Gene,

    Did you use the Bluespoon AX with the T650 for any length of time? I have the AX, and agree that the soudn quality is not that great. In fact, I find incoming sound quality a bit "tinny".

    But my real problem with the AX - making it unusable to me - is that anytime I power cycle either phone or headset, I have to re-run the Handsfree setup in the Bluetooth Setup Devices screen (even though it exists as a Trusted Device Pair). Pain in the neck.
  4. #4  
    David-
    A few guys with the HBH-660 have outfitted theirs with eargels which apparently fit perfectly over the earpiece and dramatically increase volume. I haven't done it yet myself (still waiting for unlocked GSM) but this allows you to get rid of the over-the-ear piece and just headset attached directly to your ear. Supposedly gives great volume and much more comfort:

    http://www.slicsound.com/ss001.asp

    Hope this helps!
    Eddie
  5. #5  
    Thanks, Eddie, especially for the link.

    I'm using the Cardo 500 which is much more comfortable, but to this point, seems far inferior in overall quality to the Sony 660.

    David
  6.    #6  
    Quote Originally Posted by awesterink
    Gene,

    Did you use the Bluespoon AX with the T650 for any length of time? I have the AX, and agree that the soudn quality is not that great. In fact, I find incoming sound quality a bit "tinny".

    But my real problem with the AX - making it unusable to me - is that anytime I power cycle either phone or headset, I have to re-run the Handsfree setup in the Bluetooth Setup Devices screen (even though it exists as a Trusted Device Pair). Pain in the neck.
    I used the AX and tried it for about a week, and I was alright with the incoming sound quality minus the popping sounds. It paired fine with my phone and I didn't experience the issues that you did. You may want to try to hard reset your phone and remove any custom ROMS if any and then try pairing.

    I have found out that a custom ROM had caused the issues with the HBH-300. The 300 is now working great!
  7.    #7  
    Well, I have found out that the issue is not with the custom ROMs, but with some program that was installed on my phone. I hard resetted and installed a custom ROM, and everything with the HBH-300 is working great.

    By the way, after trying the 300 and many other headsets, the 300 is the best if you're concerned about getting the best incoming/outgoing sound with distance from the 650.
  8. #8  
    Gene...the AX pairing issue is solved, turned out the Handsfree setup with the AX does not "atick" if it already existed as a trusted device.

    BTW, how fast does your HBH-300 connect to the T650 when making or receiving a call?
  9.    #9  
    Quote Originally Posted by awesterink
    Gene...the AX pairing issue is solved, turned out the Handsfree setup with the AX does not "atick" if it already existed as a trusted device.

    BTW, how fast does your HBH-300 connect to the T650 when making or receiving a call?
    I never had an issue with paring the AX. The 300 connects really fast I would say it's instantaneous.

Posting Permissions