Results 1 to 12 of 12
  1.    #1  
    Hi All,
    I've tried numerous different encoding methods (Pocket DVD, VirtualDub, VirtualDubMod, DivX, XVid, Dr. DivX), and on 2 different PCs, but regardless, the audio won't sync properly for me in MMPlayer (even though the compressed videos are in sync when played in Windows). I'm using the trial version of MMPlayer 2.14.

    When I look at the MMPlayer statistics, they look fine as far as I can tell... Here's a sample:
    Dec/skipped frames: 584 / 0
    Thrown pkts vid/aud: 0 / 0
    Max pkts vid/aud: 0 / 0
    Max usage vid/aud: 52 / 4
    Aud buf underruns: 0
    Idle (ticks): 0
    Dynamic mem headroom: 4009

    The settings I usually use to encode (although they shouldn't matter) are 2 pass XVid, 320x240, 225 kbps, decimate by 2, 32 kbps MP3 audio, 22 khz, etc. They're cartoons btw. I've been working all week trying to get this to work to no avail! The video is on the memory card, the app is in RAM, etc. Any ideas? Changing the a/v sync setting isn't really acceptable b/c that would have to be done for each video!

    I have also tried MMPlayer's demo ZZTop video (hi res), and it's out of sync (although that's understandable - it's higher bitrate and skipping 14% of the frames). Is it possibly something with my Treo? After reading some posts here, I may try SmartMovie and/or Kinoma... Please help me figure this out! Thanks in advance,
    Kyle
  2.    #2  
    anybody?

    FYI, I've gotten my avi movies to convert to .mp4 with Kinoma producer, and they play just fine (and in sync), but the quality is much worse (blocky & pixelated) compared to the video created with VirtualDub, etc. That's even considering the mp4 videos are at 320 kbps... TIA,
    --Kyle
  3. #3  
    Kyle;

    After many frustrating hours of hundreds of tests of trial settings permutations to try and resolve a/v out of sync problems using PocketDVD and MMPlayer some one suggested using a VERY QUICK AND EASY utility to use and it works wonderfully well for me.

    It's called PocketDivXEncoder and it's free.

    Download and run it, and process your avi movie through the Correct Audio/Video Synchro button on the bottom left of the main screen and see the smile form on your face. It takes only a few seconds to correct the sync on my movies.

    I hope it works as tremendously well for you as it does for me!
  4. ResDog's Avatar
    Posts
    12 Posts
    Global Posts
    45 Global Posts
    #4  
    I'm simply supporting what Big OTR has stated:

    PocketDivXEncoder is WONDERFUL!! I would suggest selecting the b-frame setting, Xvid codec (if you have it installed) and de-selecting the VHQ setting. Leave it on one pass to see how you like it before defaulting to 2-pass.

    This program is WONDERFUL!

    Good luck!
  5. #5  
    I'm not sure what path/programs you'll land on to get your DVD to AVI format...

    ResDog has great success ripping the movie and then using PocketDivXEncoder to get a wondeful result.

    For ease of use (and since I already spent the money...) I use PocketDVDStudio to do the DVD ripping and processing to AVI format.

    I then take a few seconds and run that AVI through the PocketDivXEncoder Correct Audio/Video Synchro utility.

    It's a real pleasue to watch a TREO movie in sync after suffering for so long...
  6.    #6  
    Hmm... I've tried PocketDivXEncoder, but I didn't try the Correct Audio/Video Synchro setting you mentioned. I was under the impression that was just to be used *if* the a/v was out of sync when playing on the computer, and that it was to be done manually. I'll have to try that tonight. At any rate, thanks very much for the recommendation.

    ResDog & Big_OTR_Fan, could you post your settings that have worked well for you (as high as your Treo would play without problems - or as low w/o looking bad)? What did you use for these settings:
    Device (Tungsten?):
    Vid Quality:
    Aud Quality:
    Dimensions (320x I assume?):
    Which advanced settings were checked?
    -IVTC?
    -Framerate (I've been setting 15)?

    I don't mind the time, so I'd generally use 2-pass encoding and queue up a bunch of files overnight. However, I noticed when I select 2-pass, VHQ must be checked. I don't know what that and IVTC are.

    Again, thanks a bunch guys, I appreciate it! Take care,
    --Kyle
  7. ResDog's Avatar
    Posts
    12 Posts
    Global Posts
    45 Global Posts
    #7  
    Kyley,

    The correct Audio/Video Synchro selection works great, and should be done... even if you don't see an issue with the file. Also, it will generate a NEW file, adding the word "resynced" to the name, so be sure to copy the NEW file to your device.

    I am using a Treo 600, so my settings vary. I've found the following to be best for me:
    Device: Smart Phone (Since Treo 600 is low res)
    Vid Qual: 6
    Aud Qual: 4
    Dim: I use the auto scaler to show it, and since I'm on the Treo 600, I make sure that neither the width or the height are over 160 (Treo 600 limitation). Make sure you keep the MAINTAIN ASPECT RATIO checked if you are working with letterbox files.
    ADV Settings: I make sure BFRAMES, DEINTERLACE, and XVID are checked. Nothing else. (Be sure to have the Xvid codec installed if you select Xvid)
    Framrate: 15 is fine. I find that at around 22, the treo 600 starts to choke.

    VHQ and IVTC stand for: Video High Quality and International Video Time Code (Neither of which I use). If you do 2-pass, VHQ will be auto-checked.

    After file is encoded, I slap it through the CORRECT function (to be safe) and BAM! throw it to my SD card.

    At these settings, I get a 1-hour TV show into around 65Mbs.

    Hope that helps.
  8.    #8  
    Thanks again ResDog! Big_OTR_Fan, if you have any settings to add (particularly for the 650), let me know! Take care,
    --Kyle
  9.    #9  
    Thanks guys! This is working great so far (I haven't encoded much with it yet though). The settings I used were quality 10, FPS 15, audio 32 kbps/22 khz mono, 320xX, in advanced I checked 2-pass (and VHQ), De-interlace (although I'm not sure about this setting), B-Frames, XviD. I'm guessing that at 15 FPS, higher quality can be used, but at full FPS (29.997 in original), quality 10 caused too high bitrate messages in MMPlayer. I don't mind the extra processing time of 2 pass - just queue it up to run overnight!

    One setting that would probably be helpful to have in PocketDivxEncoder is decimate by 2 and decimate by 3 settings as an alternative to the set framerate (I've seen a lot of places recommend to do that instead of setting the framerate explicitly). Take care,
    --Kyle
  10.    #10  
    Hi All,
    I've encountered the following error message when encoding a couple of times now. I of course can't translate it, and I see no way of contacting the program's author... Any idea what the problem is or how to fix it (or is it just a bug)? TIA,
    --Kyle
    http://www.edscope.com/other/pdivx-error.gif
  11. ResDog's Avatar
    Posts
    12 Posts
    Global Posts
    45 Global Posts
    #11  
    I'm guessing it has to do with the filename being long and containing troublesome characters.

    Rename the original file to something VERY SIMPLE and try again.
  12. #12  
    Quote Originally Posted by kyley
    Hi All,
    I've tried numerous different encoding methods (Pocket DVD, VirtualDub, VirtualDubMod, DivX, XVid, Dr. DivX), and on 2 different PCs, but regardless, the audio won't sync properly for me in MMPlayer
    To sync audio "on the fly" in MMplayer:

    1. press the red phone button on your treo. You will see "AV" or "AV sync" I can't remember.

    2. Push up/down on the 4 way button until the audio matches with the video.

    3. enjoy

Posting Permissions