Results 1 to 10 of 10
  1.    #1  
    Here is a new one (I think?). No matter how hard I tried I could not get the screen to come on on my 650. I pressed every button on the thing - nothing. I brought it into the Sprint store and after a reset it came up. Their reason for this issue was that I did not have at least 5 megs of free space available on my device. Has anyone had a similar issue? Can it be that the phone's display cannot work on 3 megs of nvRam? This sounded a little hokey to me.
  2. #2  
    I have been having similar problems. My 650's screen will not come on if I press any buttons. The only way to get it to come is to take the battery out and put it back in(similiar to your soft/hard rest). I did a hard reset(erased all sofware I put in it) and it still did it. I took it back to sprint and they said they had to test it and upload software, which they did. But I'm still having the same problem. I think I got a LEMON so I'm gonna try to get them to replace the phone. So your not alone!
  3.    #3  
    Why won't they just swap out the hardware?
  4. #4  
    It doesn't happen when I take the battery out and put it back in and use the phone/pda. The phone will turn on/off with no problem. It happens when I stop using it for a couple hours. So when I took it to sprint and they did there testing and software upload, it was working fine. However, a couple hours later after I didn't touch it, the screen would not come on. I've tried different things like turning it off with the end call button and letting it turn itself off and it still will not come on after awhile of not using it. Why will they not replace the hardware? Well the answer is I haven't had a chance to go back to the sprint store. I have off tommorow so I'm gonna go and try to get them to replace it, but, I'm expecting to get some bull****. So I guesse I'll see. I'll let you know what happens
  5.    #5  
    So after moving like 8-10 megs to my SD card I still get tons of delay on the phone. I know that dialing from the contacts list caused a 3-5 sec delay but this is more like the phone freezes for like 15-20 seconds.
  6. #6  
    I have that problem periodically when my business connection notifies me or when I plug in my headset.
  7. #7  
    Quote Originally Posted by larry91403
    Here is a new one (I think?). No matter how hard I tried I could not get the screen to come on on my 650. I pressed every button on the thing - nothing. I brought it into the Sprint store and after a reset it came up. Their reason for this issue was that I did not have at least 5 megs of free space available on my device. Has anyone had a similar issue? Can it be that the phone's display cannot work on 3 megs of nvRam? This sounded a little hokey to me.
    Some people on this site would think it's your imagination. Try Silverado's PowerUser tips...
  8. mszatny's Avatar
    Posts
    427 Posts
    Global Posts
    494 Global Posts
    #8  
    I've also experience this "unresponsive buttons" problem maybe 2-3 times since I've had the Treo650. Only solution was removal of the battery. I don't think memory was the issue for me since I've alwasy had >12MB free.

    MS
    <img src="http://users.netropolis.net/mszatny/pics/bevo.gif" border=0>
    The Woodlands, TX

    Palm Pro > PalmIII > Visor Prism w/Omnisky>SPCS Treo300 > SPCS Treo600 >
    SPCS Treo650 > CNG Treo650 > Copper Treo680 > ATT Treo750 WM6 > iPhone 3G
  9.    #9  
    Quote Originally Posted by IamVincent
    Some people on this site would think it's your imagination. Try Silverado's PowerUser tips...
    Who? What? Where?
  10. #10  
    Sprint gave me a new phone today, the receptionist tried to give me crap about it being >14 days, however, I gave the technician the phone for a couple hours to let them see how messed up it was and when I came back they gave me a brand new phone, so far no problems.

Posting Permissions