My Treo 650 "suddenly started beeping when it goes in and out of roam. I went into the preferences and have this turned off but it persists.

Also, the screen lights when roaming. Is there a way to shut this off as well?