Results 1 to 5 of 5
  1.    #1  
    I am having a problem with DateBk5 (version 5.4a-p7) on the Treo 650. I have my alarms set up to repeat 3 times when they go off. I previously had a Treo 600 and DateBk5 alarms worked exactly the way I'd want them to on the 600. On the Treo 600, when an alarm that is set for more than one repeat rang, you could press the power button which would stop the first iteration of the alarm, start the second repetition of the alarm and display the keyguard message "Keyguard: Press Center button to unlock." Even if you didn't press the power button, you'd get the keyguard message after the first iteration of the alarm finished playing, at which point you could then press the center button twice, the first time to dismiss the keyguard and the second time to acknowledge the alarm.

    The Treo 650 seems to work differently. First, there is no power button, so there is no way to cancel the first iteration of the alarm. But, even more problematic is the fact that the keyguard message doesn't display after the first iteration of the alarm, but only after all iterations have sounded. Unlike the Treo 600, on the Treo 650, keyguard stays on until all iterations of the alarm have played. Thus if you have a long MIDI tune and a large number of repeats, it can take a very long time to be able to silence and acknowledge the alarm. The short-term workaround is to make alarms repeat only once.

    There is another alternative: according to the DateBk5 documentation, "Keyguard is now temporarily disabled for the Alarm dialog when it first appears but only if you check the box in the Sounds & Buttons dialog of the Alarms tab of the main DateBk5 Preference panel (Options | Preferences in any view), so you can silence alarm repetitions by just pressing Left/Right/Up/Down on the Rocker button (or by pressing down on the alarm screen -- at top right where no controls are present). Note that after the Treo shuts off, if you manually power on and the alarm dialog is displayed, keyguard is enabled (as it should be)."

    Checking the Enable Buttons In Alarm dialog box improves things somewhat, but it is still problematic. What happens is that if the box is checked, when the alarm goes off, the bottons still don't work, but the touchscreen goes live, so you can silence the first repeat of the alarm right away by tapping the screen. None of the rocker buttons work. The second repeat will then start playing. After you've canceled the first repeat of the alarm, again, contrary to what the documentation says you are Not able to use the Rocker buttons to cancel the remaining repeats no matter how you've set the Enable Buttons In Alarm dialog box. If the box is checked, the only way to acknowledge the alarm is through the touchscreen. This is OK, I suppose, but I keep my 650 in my pocket using a screen protector and the alarm often gets instantly dismissed even before I have had a chance to hear it. Even worse, if you (deliberately or accidently) press any other buttons (like the phone or mail buttons), the actions assigned to these buttons seem to get cued up and processed after all alarms have finished playing.

    I suspect that the problem is caused by the difference in operation of the center button between the Treo 600 and 650 (which has affected a number of programs where the center button works in the 600 but not in the 650). In any event, on the 650, the program doesn't function as described in the documentation because there is no way to get any buttons to work during an alarm. It is only possible to activate the touchscreen (which can be less than desirable).

    What I am hoping for is for DateBk5 to work on the 650 in a similar way to the way it worked on the 600 (other than having the ability to silence the first iteration of the alarm with the now non-existent power button). Thus it would work like this: if you have Enable Buttons In Alarm checked, it would work as described in the documentation, and if you have Enable Buttons In Alarm unchecked, the first iteration of the alarm would play all the way through and after the first iteration, the Treo 650 keyguard would kick in (i.e., you get a message on the screen saying "Keyguard: Press Center button to unlock" and you could press the center button once to unlock and a second time to acknowledge the alarm). All other keys and the touchscreen would remain inactive until Keyguard was turned off.

    I'm wondering though if my unit is somehow different than others (perhaps due to some other program I'm running). Can the other DateBk5 users here check how it works on their units and let me know if you get the same results. TIA.
    Regards,

    Robert
  2. #2  
    Are you using Datebk5 or the OE calendar app to handle the alarms?
    I was having issues with alarms not sounding off with version 5.4a-p7 if I used DateBK5 to handle the alrams, I have not fully tested p7 yet.
  3. dwman's Avatar
    Posts
    896 Posts
    Global Posts
    907 Global Posts
    #3  
    The version CESD has posted is a little misleading. Normally when he posts an update, he numbers it accordingly(p5,p6,p7, etc..)however according the Yahoo newsgroup he has posted a couple of updates to p7 without changing the number. His latest version IS p7, but dated 1/7/05. Try that one to see if it solves your problem.

    http://www.pimlicosoftware.com/datebk5-v54a-p7.zip
  4. #4  
    can I just install this right over the old p7? or is there a procedure.
  5. dwman's Avatar
    Posts
    896 Posts
    Global Posts
    907 Global Posts
    #5  
    Just install over your current one. Should work fine.

Posting Permissions