Page 1 of 2 12 LastLast
Results 1 to 20 of 28
  1.    #1  
    I posted a problem I had with the Seidio Charge and Sync Cable for the Treo 650. This is still going on, so I thought I'd post the info here. The cable that Treocentral is selling is also made by Seidio, so you may want to watch out for this cable on Treocentral as well.

    I ordered my first cable on 12/13/04. I received it on 12/17/04. Pretty quick.

    The cable was defective. I noticed this immediately and created an RMA on 12/17/04. On power side of the connector that goes into the Treo 650, the metal conductor would slide inside the connector when pushing the end into the Treo 650. (pictures later).

    An RMA replacement was sent on 12/23/04 from Seidio (according to their email). This is almost a week later. Pretty slow. I received it on 1/4/05. 12 days later. So it took 18 days from when I reported the RMA until I got a replacement.

    This second unit is defect in the EXACT same place as the first. Described above (pictures below). I only plugged the cable in 3 times in a matter of a couple of minutes to discover it was defective. I was very careful as well, because I wanted to make sure I wasn't jamming it into the Treo.

    It seems like they may have a problem with the way this cable end is designed.

    I did notice that the cable seemed to work for the few minutes I had it plugged in, before the conductor pushed inside.

    I called Seidio Tech Support and sent an RMA email to their RMA department and (seidioseidio) on 1/4/05 offering to email pictures. Still haven't received a response. I did call their customer service today (1/7/05) and was offered a refund, but I'd really like a working charge and Sync cable. Customer Service informed me that their Tech support is out for the day.

    I really want this to work. It's a great idea, but I'd advice people not to buy this thing.

    Anyone else have this cable? Good or bad?
    Attached Images Attached Images
  2. #2  
    Oh NO! I ordered one of these from TreoCentral Monday and have been patiently waiting for it to arrive so I can charge in my car and at my computer. This will be VERY bad if mine doesn't work! I'm already annoyed that it is taking so long to arrive.
    Well, it isn't perfect and it makes me crazy, but I still do love my Treo!
    Sprint Treo 650 CDMA
  3. #3  
    Mine works fine.
  4.    #4  
    Quote Originally Posted by LouisW
    Mine works fine.
    Have you noticed whether your metal connector is pushed in or not (look at my pics).
  5. #5  
    I just got mine from TreoCentral and it is charging fine (I think) right now. I don't know whether it is Seidio brand though, since the logo on it is just a generic yellow that says Retractable Sync N Charge and it doesnt say Seidio anywhere.
    Well, it isn't perfect and it makes me crazy, but I still do love my Treo!
    Sprint Treo 650 CDMA
  6.    #6  
    Yeah.. mine says the same thing. Mine is generic yellow.

    Has your metal contact pushed in at all on the side? <see my pics above>
  7. #7  
    No. Seems to be ok and not pushed in. By the way, I could have sworn that the sync and charge cable I had for the 600 extended longer than this one does. It seems quite short.
    Well, it isn't perfect and it makes me crazy, but I still do love my Treo!
    Sprint Treo 650 CDMA
  8. #8  
    I'm further annoyed with this by the fact that I had a car adaptor that I used with my prior sync and charge cable (I think it worked with both my Boxwave version and my Seidio version for my 600 but I know it worked at least with the Boxwave) and Seidio told me it would work with this new cable and it DOESN'T.
    Well, it isn't perfect and it makes me crazy, but I still do love my Treo!
    Sprint Treo 650 CDMA
  9.    #9  
    I just got my 3rd copy of this cable today. Plugged it in the first time, and the contact is messed up just like the original. I'm going to see if I can get a refund. It's been a few months and 3 different cables. I just don't think this thing works very well.

    The original Palm cable works fine.

    Has anyone else had this issue? The people at Seidio seem to think I may be the only one. At least thats what they tell me.
  10. #10  
    These cables had horrible reputations with 600 users. Contacts would wear out quickly causing hard rresets if attached.
  11. #11  
    I'm intersted in this because I just ordered one of these retracting sync/power cables earlier this week, but haven't received it yet.

    If the problem is that the metal contact is "floating" on the plastic housing and is getting pushed in, can you use a small tool and pull the metal back out again and just put a dab of superglue or something on it?

    I realize it's normal to expect something you buy to work -- but it seems like it may be less of a hassle to just fix it yourself than keep exchanging it for the same flawed design.

    Later,

    Greg
  12.    #12  
    I talked to Seidio today asking about a refund. They assured me they tested it and they sell 1000s of these without many issues.

    Now they have me thinking that maybe my Treo is the problem?

    The standard Palm connector works fine, though and nothing looks bad at the bottom of the Treo.

    I just ordered one of the non retractable cables from eBay to see if it is any better.

    I tried superglueing one of the cables a while ago. It worked for about a week, then a piece of plastic inside the connector broke, so the whole connector part of this end floats around.

    It seems like the metal connector on the power side of cable end is just pushed out too much. Too much friction or something.

    Let me know how your cable works..
  13. #13  
    I just got my Seidio retracting sync/charge cable today and it seems fine. The contact on the power connector is good, and I tried pushing on it a little to see if it'd slide in and it wouldn't budge. Did you look at yours before you plugged it in the first time?

    Overall I like the cable. It's small and syncs and charges -- just what I was expecting. One thing I would like though is a hotsync button on the connector like the stock sync cable that came with the T650. Maybe I can add a button.

    Greg
  14. jkoons's Avatar
    Posts
    215 Posts
    Global Posts
    217 Global Posts
    #14  
    I've been using this cable daily for a couple of weeks now and it's been great! The contacts are all where they are supposed to be. Sometimes the cable does not retract correctly and I have to pull it out and release it a few times, but that's the only issue I have with it.
    Sprint PCS Treo 600 & 650
    Verizon Treo 700w
    www.James-K.com
  15. #15  
    I used to build literally thousands of cables similar to this.

    From your picture, it looks like the connector comes apart. Since they seem disinterested in helping you any more, you can try carefully pulling the hood off of the connector and see if there's a way to get that contact where it needs to be.

    Tom
  16. aldamon's Avatar
    Posts
    650 Posts
    Global Posts
    684 Global Posts
    #16  
    Mine is doing the same thing. It's always been a tighter fit than the OEM cable and now the metal connector is pushed in. Still works though. I just have to push in a bit more than usual.
  17. #17  
    Hi,

    The problem discussed here is for the very early version. The problem has been addressed. It is fine for the current version.

    Sorry for the inconvenience. Seidio fullly stands behind our products. If you have problems with the sync and charge cable for Treo 650, please contact rma@seidio.com

    Seidio
  18.    #18  
    Seidioseidio,

    I just received the newest version yesterday. It does the same thing.

    I was going to send the cables back...it doesn't really seem worth it for $14... I guess I'll just crazy glue the new one until it breaks.
  19. aldamon's Avatar
    Posts
    650 Posts
    Global Posts
    684 Global Posts
    #19  
    Quote Originally Posted by seidioseidio
    Hi,

    The problem discussed here is for the very early version. The problem has been addressed. It is fine for the current version.
    Blanket statements like that are a little irresponsible. I ordered mine on January 19th directly from you and it has the problem.

    https://www.seidioonline.com/Product...de=CBUDPTR650B

    Quote Originally Posted by mogulman
    Seidioseidio,

    I just received the newest version yesterday. It does the same thing.

    I was going to send the cables back...it doesn't really seem worth it for $14... I guess I'll just crazy glue the new one until it breaks.
    That's how I feel. It's a $15 cable. Not worth the hassle, especially if replacement cables are doing the same thing.
  20.    #20  
    Quote Originally Posted by VetPsychWars
    I used to build literally thousands of cables similar to this.

    From your picture, it looks like the connector comes apart. Since they seem disinterested in helping you any more, you can try carefully pulling the hood off of the connector and see if there's a way to get that contact where it needs to be.

    Tom
    Actually, Seidio has been pretty helpful in sending me replacements. It has taken a while to get them but I have received 2 replacements. I originally ordered back on 12/15/04. I got my 3rd cable yesterday.

    The problem is that the replacements were no better then the original.

    I did order a headset cable at the same time and it has been great. I just think this product is flawed (or incompatible with my particular Treo 650, since they say that they've sold 1000s with no problems).

    Jeff
Page 1 of 2 12 LastLast

Posting Permissions