Page 1 of 2 12 LastLast
Results 1 to 20 of 27
  1. bobgott's Avatar
    Posts
    24 Posts
    Global Posts
    25 Global Posts
       #1  
    Don't know if its just me .. but my Treo 650 seems very slow when I select a phone number to dial from a favorite button. For that matter .. it even seems to pause on simple commands like hangup.

    I just gave up my Treo 300 which seems much faster in recognizing my dial and hangup commands.

    Is anyone else seeing this? .. Is there a fix??
    -Bob
    -Sprint Treo 650
  2. #2  
    I heard about the problem.

    But exactly how slow is it? How many seconds?
  3. #3  
    There are many threads on this...do a search and you will find lengthy discussions about this topic. Basically, the new memory structure has something to do with the delay, and P1's weak user interface design (e.g., not flashing a dialing screen or anything acknowledging you've clicked a button) exacerbates the perceived delay.
  4. #4  
    I have that same problem, and it is really annoying.

    Maybe Shadowmite can get on the case
  5. bobgott's Avatar
    Posts
    24 Posts
    Global Posts
    25 Global Posts
       #5  
    Quote Originally Posted by O1Coupe
    I heard about the problem.

    But exactly how slow is it? How many seconds?
    It seems like a lifetime .. but actually about 3 seconds (varies). 3 seconds is a long time to wait for the dialer to kick in .. I always tap again .. never knowing if it got your first tap.

    Althought others have complained .. I can't seem to find a patch.
    -Bob
    -Sprint Treo 650
  6. #6  
    It's annoying and should have been corrected Before release.
    "Everyday is a Gift, A Blessing, An Opportunity!" - GM

    Phone history: Treo 600, Treo 650, Treo Centro, Pixi, Centro again, 800w, Treo 755p, Palm Pre
  7. #7  
    When compared to my Samsung and Sanyo phones, my calls connect (meaning actully have a ringing phone) at the exact same time. Its more a user perceived than an actual issue.

    At least thats what my testing produced
  8. #8  
    Indeed, but it is that blank white screen that I find most annoying.
    "Everyday is a Gift, A Blessing, An Opportunity!" - GM

    Phone history: Treo 600, Treo 650, Treo Centro, Pixi, Centro again, 800w, Treo 755p, Palm Pre
  9. jpasint's Avatar
    Posts
    146 Posts
    Global Posts
    204 Global Posts
    #9  
    “Its more a user perceived than an actual issue.”
    Not.
    It is a genuine problem. Perception has nothing to do with it.

    Joe
  10. #10  
    Quote Originally Posted by jpasint
    “Its more a user perceived than an actual issue.”
    Not.
    It is a genuine problem. Perception has nothing to do with it.

    Joe
    Really?
    Which phones were you testing against.
    Maybe the phones I tested against also have the problem, NO.. wait they aren't palm based, hmmm then it must be they each have thier own specific set of problems. Imagine my luck getting three different phone models and all of them with a completely sepearate dialing problem.
  11. #11  
    I guess it's just something we'll have to get used to unless P1 addresses the issue in a patch.
  12. #12  
    i have it as many as 7 seconds, but i geuss i could ignore it as long as everything else holds up
  13. #13  
    yep, this has been mentioned by a lot of people in a lot of threads. We all have it. The Treo600 does not have it, and neither do most cheap phones. So, welcome to the club.

    What does need to be said is that as far as I know, Sprint has NOT acknowledged this as an issue. Please correct me if I'm wrong.
  14. bobgott's Avatar
    Posts
    24 Posts
    Global Posts
    25 Global Posts
       #14  
    Compared to my old Treo 300 this thing is slower than a dog!

    However, my non-phone apps to behave faster. For instrance, my Agendus 9.0 is at least twice faster on the 650 than the 300. It seems any system or phone related functions are slower.

    Help!
    -Bob
    -Sprint Treo 650
  15. #15  
    I have done side by side testing with a 600, and it is a very real delay not a perceived difference. It's the main reason I got rid of my 650. If they fix that issue and a few others, I'll buy another.
  16. #16  
    sprint doesn't acknowledge it - they don't understand squat about these phones as evidenced by my many experiences with their stores and telephone support

    Quote Originally Posted by NSiNSiNSi
    yep, this has been mentioned by a lot of people in a lot of threads. We all have it. The Treo600 does not have it, and neither do most cheap phones. So, welcome to the club.

    What does need to be said is that as far as I know, Sprint has NOT acknowledged this as an issue. Please correct me if I'm wrong.
  17. #17  
    Yes, there is a delay. I think some are arguing that the length of time it takes for the call to actually get dialed is similar to other Sprint phones (I am new to Sprint). For me, the delay is not a reason to drop the 650 all together as there are many other benefits. I guess if I spent my day making call after call this could get annoying, but as it is I make 10-20 calls a day and it doesn't bother me.
  18. #18  
    Quote Originally Posted by silverado
    For me, the delay is not a reason to drop the 650 all together as there are many other benefits.
    I can understand that, but that really is no excuse for a company like PalmOne to release such an obviously unpolished, sluggish program that is actually worse than its otherwise identical predecessor, which used to work better in an older, slower phone. So, not only did they not improve the phone app in any of the areas most users had been asking for improvements on, but they actually made it *worse*.
    And this is not some obscure area of the device that you would use occasionally, or something for power users only... this is the *phone* part of a *phone*.

    If this was a new product, a first generation, then it would be forgivable... but as a second generation of the same product?

    There is simply no excuse for this, regardless of how nice the 650 is in other areas.

    I am really hoping a forthcoming patch from PalmOne fixes at least this problem.
  19. #19  
    well my first treo 650 did not have this problem, , it kept resetting itself after hotsync, but my second one works better with hotsync, but now it has the sluggish dialing, i guess i still have time to return it but until software comes out that is past revision A i would appreciate it
  20. icewing's Avatar
    Posts
    77 Posts
    Global Posts
    78 Global Posts
    #20  
    On my previous Sprint phone, when I selected a number and pushed Talk, I got a brief recording that said, "Connecting...". This was followed, as best as I remember, by the same type of delays I experience when hitting one of my phone favorites buttons, anywhere from <1 second to about 5 seconds.

    I really wouldn't mind it at all if the dialing screen would pop up immediately after (within 1 second) pressing the favorite button....this would eliminate the guessing game that we all play now (did the button press take? should I hit it again?)

    I think this is probably the biggest annoyance for me about this device (aside from having to use a 3rd party file manager to get apps that were moved to the SD card to show up under the categories you want them to!) Other than that I really love this phone and am quite happy with it...

    Now I just have to save my pennies to replace VersaMail and RealPlayer with sofware that actually functions/is not a royal pain in the a** to use...
Page 1 of 2 12 LastLast

Posting Permissions