Page 7 of 14 FirstFirst ... 23456789101112 ... LastLast
Results 121 to 140 of 264
  1.    #121  
    I just posted a new version (v0.23b) that hopefully address the !scAx! volume problem. This is what was happening. The problem would only happen if you combined other sound flags with !scax!. The way SC works is it executes the global sound settings before any other sound settings. So in the case where you give the following commands:

    !scA0!
    !scV0!
    !scPs1!

    SC would see the A flag and save the current settings and then set all sounds to 0

    SC would then see the V flag and save the current settings (which are the A flag settings because it already executed) and then set the vibrate settings for all sounds

    SC would then repreat this process for the P flag.

    Then when the appointment is over the process reverses itself BUT I was restoring the 650 settings int he same order they were set!!! Well this left the 650 virtually unchanged. So now I am restoring the sound state in REVERSE order. Restore P flag then V flag and then A flag. That is the correct thing to do.

    Jeff
  2. #122  
    Woo-hoo, it worked, it WORKED!!! Yay, Jeff!

    tanster
    Treo 650 on Sprint, as of 11/18/04!
    • To transfer data from your current Palm device to the Treo 650, click here.
    • To see my Treo 650 pics, click here.
  3. #123  
    Multiple issues, using .23:

    After ScheduleCare catches an alert during a meeting, the entire Treo seems very sluggish from then on out. For example, your logo in SC will not be moving smoothly. As soon as I disable SC, the logo starts moving nice and smooth. If I then reenable SC, everything is fine until the next time SC does something

    !scA0! does not seem to work for Verichat. IM sounds still come through loud and clear. !scIS0! also doesn't work.

    !scV0! doesn't seem to be working either. I still get vibrate with a phone call.

    Any thoughts?
    -Brian
  4.    #124  
    Quote Originally Posted by tanster
    Woo-hoo, it worked, it WORKED!!! Yay, Jeff!

    That's music to my ears! 3rd time is a charm right??

    Thank you for finding this one!

    Jeff
  5.    #125  
    Quote Originally Posted by bkrodgers
    Multiple issues, using .23:

    After ScheduleCare catches an alert during a meeting, the entire Treo seems very sluggish from then on out. For example, your logo in SC will not be moving smoothly. As soon as I disable SC, the logo starts moving nice and smooth. If I then reenable SC, everything is fine until the next time SC does something

    !scA0! does not seem to work for Verichat. IM sounds still come through loud and clear. !scIS0! also doesn't work.

    !scV0! doesn't seem to be working either. I still get vibrate with a phone call.

    Any thoughts?
    -Brian
    First I have heard of this. I will check into it. What alert seems to make the Treo slow down? Verichat or any alert? It is strange because SC just sets sound levels and does not trap alarms. It is a pretty passive application. Any hints at pre-conditions and specific alarms would greatly help me track this one down.

    Now it is possible that Verichat is overriding the sound level that has been set for it. I suspect that this is what is happening. I will have to look into this condition and see what I can do to enforce the sound levels. (It is not nice for applicaitons to change the sound levels without you saying it is ok to do this.) Does Verichat have options for alerting and volume settings?
  6. #126  
    Quote Originally Posted by jeffgibson
    First I have heard of this. I will check into it. What alert seems to make the Treo slow down? Verichat or any alert? It is strange because SC just sets sound levels and does not trap alarms. It is a pretty passive application. Any hints at pre-conditions and specific alarms would greatly help me track this one down.

    Now it is possible that Verichat is overriding the sound level that has been set for it. I suspect that this is what is happening. I will have to look into this condition and see what I can do to enforce the sound levels. (It is not nice for applicaitons to change the sound levels without you saying it is ok to do this.) Does Verichat have options for alerting and volume settings?
    The slowdown appears to happen after a phone call. The calendar notes had !scA0! and !scV0!. Additionally, as mentioned, !scV0! didn't stop the vibrate on the phone ring, regardless of the "Zero volume gets vibrate" function on the first page.

    Verichat does have its own alert setting, but it doesn't have its own volume setting. I thought it ties itself to some other volume setting, but I'm not sure which. They've got a trial version, see what you can figure out. Let me know if you need more details on any of the issues. I'm using Agendus, in case that matters at all...I think it has its own codes that it puts into notes as well...does it matter where in the note the !sc! tags are?

    -Brian
  7.    #127  
    Quote Originally Posted by bkrodgers
    The slowdown appears to happen after a phone call. The calendar notes had !scA0! and !scV0!. Additionally, as mentioned, !scV0! didn't stop the vibrate on the phone ring, regardless of the "Zero volume gets vibrate" function on the first page.

    Verichat does have its own alert setting, but it doesn't have its own volume setting. I thought it ties itself to some other volume setting, but I'm not sure which. They've got a trial version, see what you can figure out. Let me know if you need more details on any of the issues. I'm using Agendus, in case that matters at all...I think it has its own codes that it puts into notes as well...does it matter where in the note the !sc! tags are?

    -Brian
    I'll check into the vibrate settings but I have put a build together that may fix the slow down. During a quick code review I found a spot that may have caused this to happen. Build 0.24b fixes that situation.

    Jeff
  8. #128  
    Quote Originally Posted by jeffgibson
    I'll check into the vibrate settings but I have put a build together that may fix the slow down. During a quick code review I found a spot that may have caused this to happen. Build 0.24b fixes that situation.

    Jeff
    Well, I was about to post that it hadn't fixed it, but I decided to try calling twice. On the first phone call after installing the update, it still slowed down. On the 2nd call (and 3rd), no slowdown. So it looks like it fixed it, although the fact that it still happened the first time threw me a bit. I'll let you know if it comes back.

    Thanks!
    -Brian
  9. #129  
    Hi Jeff,

    Still not able to get Category Manager to work.

    Here are my settings, using ScheduleCare build 24 and DateBk5:

    http://tanster.smugmug.com/photos/14398348-S.jpg http://tanster.smugmug.com/photos/14398350-S.jpg http://tanster.smugmug.com/photos/14398351-S.jpg http://tanster.smugmug.com/photos/14398352-S.jpg

    At 10:06, I expected the display to dim, but it didn't. I tried setting different categories in Category Manager, entering multiple SC commands, and using your hidden "clear data" button. Nothing worked.

    Please let me know if I'm doing something wrong.... thanks!

    tanster
    Treo 650 on Sprint, as of 11/18/04!
    • To transfer data from your current Palm device to the Treo 650, click here.
    • To see my Treo 650 pics, click here.
  10. #130  
    Quote Originally Posted by bkrodgers
    Multiple issues, using .23:

    !scA0! does not seem to work for Verichat. IM sounds still come through loud and clear. !scIS0! also doesn't work.

    !scV0! doesn't seem to be working either. I still get vibrate with a phone call.

    Any thoughts?
    -Brian
    I think I spoke too soon about my volumes settings problem getting fixed, because I can verify bkrodgers' problems -- !sca0! and !scv0! don't seem to work for me either. !scd0! works fine, though.

    tanster
    Treo 650 on Sprint, as of 11/18/04!
    • To transfer data from your current Palm device to the Treo 650, click here.
    • To see my Treo 650 pics, click here.
  11. #131  
    More details regarding my last post:

    Build 22 results:
    • Executed !SCA0! !SCV0! !SCD0! for a one-minute period
    • Did screen dim and turn itself back on at correct times? YES
    • When calling myself during execution period, were all sounds/vibrations silenced? YES
    • When sending myself a text message during execution period, were all sound/vibration notifications silenced? YES
    • Were all volume/tone prefs restored after execution period? NO

    Build 23 results:
    • Executed !SCA0! !SCV0! !SCD0! for a one-minute period
    • Did screen dim and turn itself back on at correct times? YES
    • When calling myself during execution period, were all sounds/vibrations silenced? NO
    • When sending myself a text message during execution period, were all sound/vibration notifications silenced? NO
    • Were all volume/tone prefs restored after execution period? YES (but it might be because they were never turned off?)

    tanster
    Treo 650 on Sprint, as of 11/18/04!
    • To transfer data from your current Palm device to the Treo 650, click here.
    • To see my Treo 650 pics, click here.
  12. #132  
    this girl deserves the free copy for sure.
    “There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order.”
    — Ed Howdershelt
    "A government big enough to give you everything you want, is big enough to take away everything you have."- Thomas Jefferson
  13. #133  
    Using both builds 22 and 24, I could not get either of the following commands to work:

    !SCPS7V0K[Chirp]U[Chirp]!
    !SCSS7V0T[Klavier]!


    In each case, I called or text messaged myself before the execution period to verify that my phone prefs (see previous screenshots) were working, then called and text messaged myself during the execution period to see if the SC commands would take hold, but they did not (original phone prefs were still in play).

    tanster
    Treo 650 on Sprint, as of 11/18/04!
    • To transfer data from your current Palm device to the Treo 650, click here.
    • To see my Treo 650 pics, click here.
  14.    #134  
    Quote Originally Posted by tanster
    Using both builds 22 and 24, I could not get either of the following commands to work:

    !SCPS7V0K[Chirp]U[Chirp]!
    !SCSS7V0T[Klavier]!


    In each case, I called or text messaged myself before the execution period to verify that my phone prefs (see previous screenshots) were working, then called and text messaged myself during the execution period to see if the SC commands would take hold, but they did not (original phone prefs were still in play).

    I belive that I have fixed many of the issues you are finding. I found some significant logic errors in the alarm section of the program. The tests I have performed appear to work well. Would you mind running some of your tests? You have been *very* good at finding errors!

    Thanks,

    Jeff

    REEDIT: I have posted version 0.25b
  15.    #135  
    Quote Originally Posted by tanster
    Using both builds 22 and 24, I could not get either of the following commands to work:

    !SCPS7V0K[Chirp]U[Chirp]!
    !SCSS7V0T[Klavier]!


    In each case, I called or text messaged myself before the execution period to verify that my phone prefs (see previous screenshots) were working, then called and text messaged myself during the execution period to see if the SC commands would take hold, but they did not (original phone prefs were still in play).

    My bad on this one! I changed the command characters from '[' to '(' because it was easier to type on the 650 keyboard. I just had not updated the documentation. MY FAULT!!! The command help screens have now been updated in v0.27b

    Jeff
  16.    #136  
    Quote Originally Posted by tanster
    Using both builds 22 and 24, I could not get either of the following commands to work:

    !SCPS7V0K[Chirp]U[Chirp]!
    !SCSS7V0T[Klavier]!


    In each case, I called or text messaged myself before the execution period to verify that my phone prefs (see previous screenshots) were working, then called and text messaged myself during the execution period to see if the SC commands would take hold, but they did not (original phone prefs were still in play).

    You also found another bug that I just found in the procvessing of the tone name. Fix is in v0.28b.

    Good job!!! Keep going!!!!

    Jeff
  17. #137  
    Build 28 notes

    Task 1: Executing universal A and V commands
    • Commands run: !SCA0! !SCV0! !SCD0!
    • Did screen dim and turn itself back on at correct times? YES
    • When calling myself during execution period, were all sounds/vibrations silenced? YES
    • When sending myself a text message during execution period, were all sound/vibration notifications silenced? YES
    • Were all original prefs restored after execution period? YES

    Task 2: Executing P and S commands, specifying tone names
    • Commands run: !SCPS7V0K(Chirp)U(Chirp)! !SCSS7V0T(Klavier)!
    • When calling myself during execution period, was P command run correctly? YES
    • When sending myself a text message during execution period, was S command run correctly? YES
    • Were all original prefs restored after execution period? YES

    Task 3: Using Category Manager
    • Set up as in post #129 in this thread
    • Did screen dim and turn itself back on at correct times? NO

    Other notes
    • Cannot use 5-way nav to move to the command list in Category Manager screen
    • Caps and Option key indicators do not appear in Category Manager screen
    • My main personal use of ScheduleCare will be turn all sounds, vibrates, and display off on my Treo when I go to sleep. This would be roughly 11:30pm every night until around 7am the next day. Can a single SC appointment span midnight? I've never been up late enough to test this, LOL!
    • I use Uninstall Manager, which gives me the option to install new apps to a "Sandbox"; when that screen comes up, there seem to be two SC files, one that is clearly labeled "ScheduleCare" (Screen 1), and the other, which appears in the Sandbox window with a blank name (Screen 2). I'm assuming the unnamed file is SC's own uninstaller (Screen 3)? No grave error here, but the SC Uninstaller should probably be named.


    Screen 1
    http://tanster.smugmug.com/photos/14440093-S.jpg


    Screen 2
    http://tanster.smugmug.com/photos/14440095-S.jpg


    Screen 3
    http://tanster.smugmug.com/photos/14419024-S.jpg

    tanster
    Treo 650 on Sprint, as of 11/18/04!
    • To transfer data from your current Palm device to the Treo 650, click here.
    • To see my Treo 650 pics, click here.
  18.    #138  
    Quote Originally Posted by tanster
    Build 28 notes

    Task 1: Executing universal A and V commands
    • Commands run: !SCA0! !SCV0! !SCD0!
    • Did screen dim and turn itself back on at correct times? YES
    • When calling myself during execution period, were all sounds/vibrations silenced? YES
    • When sending myself a text message during execution period, were all sound/vibration notifications silenced? YES
    • Were all original prefs restored after execution period? YES

    Task 2: Executing P and S commands, specifying tone names
    • Commands run: !SCPS7V0K(Chirp)U(Chirp)! !SCSS7V0T(Klavier)!
    • When calling myself during execution period, was P command run correctly? YES
    • When sending myself a text message during execution period, was S command run correctly? YES
    • Were all original prefs restored after execution period? YES

    Task 3: Using Category Manager
    • Set up as in post #129 in this thread
    • Did screen dim and turn itself back on at correct times? NO

    Other notes
    • Cannot use 5-way nav to move to the command list in Category Manager screen
    • Caps and Option key indicators do not appear in Category Manager screen
    • My main personal use of ScheduleCare will be turn all sounds, vibrates, and display off on my Treo when I go to sleep. This would be roughly 11:30pm every night until around 7am the next day. Can a single SC appointment span midnight? I've never been up late enough to test this, LOL!
    • I use Uninstall Manager, which gives me the option to install new apps to a "Sandbox"; when that screen comes up, there seem to be two SC files, one that is clearly labeled "ScheduleCare" (Screen 1), and the other, which appears in the Sandbox window with a blank name (Screen 2). I'm assuming the unnamed file is SC's own uninstaller (Screen 3)? No grave error here, but the SC Uninstaller should probably be named.


    Screen 1
    http://tanster.smugmug.com/photos/14440093-S.jpg


    Screen 2
    http://tanster.smugmug.com/photos/14440095-S.jpg


    Screen 3
    http://tanster.smugmug.com/photos/14419024-S.jpg

    Great post! As we talked about in our IM session, I will try to track down why Categories are not working for you. I have tested this many different ways and category support works for me. I am interested in the experience of other beta testers with category profiles. Are they working for you or are you also experiencing issues with Build 28?

    Thanks,

    Jeff
  19.    #139  
    New release - PROTOTYPE for GUI profiler - Feedback requested.

    All, I have put together the start of the GUI part of ScheduleCare. I would like feedback from as many people as possible before I launch into coding.

    Please review build 0.30b. There is now a PROFILE button that will bring up the main profile manager screen. There is also a button on the manager screen for an alert manager screen. There is NO logic behind the screens yet but there will be soon. Again, I am looking for feedback and suggestions on the GUI layout.

    Jeff
  20. #140  
    Quick report Jeff -- the vibrate appears to work when the tag is in the appointment, but not with the category manager. I can try to describe it in more detail later, but I wanted to give you a heads up.

    -Brian
Page 7 of 14 FirstFirst ... 23456789101112 ... LastLast

Posting Permissions