Page 2 of 12 FirstFirst 1234567 ... LastLast
Results 21 to 40 of 222
  1. #21  
    Okay Jeff...weird happenings:

    1. This morning after I read your post, I decided to try it again. The first OUTGOING call, I saw the highlight move, but any phone calls after that, the highlight did NOT move and I think it did the same thing yesterday, but I didn't say anything to you because I thought I was going crazy!!!

    2. Incoming calls seem to always work i.e. "volume gets increased" and I do NOT notice the highlight moving...does that sound like the same behavior for you?

    Keep up the great work...I know you will get it Jeff!!!

    Ron

    P.S. I will try a "wired headset" in a minute. Thanks!!!!!
  2. #22  
    Jeff:

    A wired headset had no effect on the mute issue...whether or not I had bluetooth on or not. The volume started out loud and did not get any louder when I pressed the mute button...and I did not see the highlight move at all. I am looking forward to your next build.

    Merry Christmas to you Jeff and all the great people on this forum!!!!


    Ron
  3.    #23  
    I have solved the problems (I think). Build v1.5 is now available.

    Detection of external hardware works on my end 100% of the time. I have added a new control to the form that will allow you to change the detection time for different BT headsets. This may have been the cause of "some" of the issues people were having since some headsets seem to take longer than others to be detected.

    I have confirmed that if you use the button on the BT headset, the mute fix will not work. Appears that you need to answer the call via a screen tap. I have put a change in the answering code that will send a screentap if it sees a headset button press to answer an incoming call.

    Jeff
    Last edited by jeffgibson; 12/25/2004 at 05:26 PM.
  4. #24  
    hey Jeff: Seems to be working fine for me...just so I understand correctly: If my headset is a little slow (like me), I would set "timer" to longer like say 5 seconds? It seems to be working fine the way I have set it....looking forward to your response...and next build...I may even throw $10 instead of 5...woot woot
  5.    #25  
    Quote Originally Posted by rjmoose
    hey Jeff: Seems to be working fine for me...just so I understand correctly: If my headset is a little slow (like me), I would set "timer" to longer like say 5 seconds? It seems to be working fine the way I have set it....looking forward to your response...and next build...I may even throw $10 instead of 5...woot woot
    Well I just threw in the new configuration in hope that it would help make BTmute works with as many headsets as possible. The way the API calls work that I am using is that they need to "detect" the headset. Well as I read the headset forums, I am hearing people say that their headset does not pick an incoming call for say 2 or 3 rings. That is telling me that parhaps their headset is not being recognized by the phone for that length of time. If that is true, then if I try to find a headset then my API call might fail. So I am giving everyone the option to vary the length of delay time before I try to detect a headset.

    So the net-net is if the program is workinng for you at the default setting of 5 seconds, then great! Otherwise try increasing the delay time until you get BTmute to work for your headset. I can easily increase the max time beyond 20 seconds, but I realy don't think that will be necessary.

    Can you confim that you can answer calls via the headset button and still have your volume increased?


    Thanks for your comments and suggestions!

    Happy Holidays.....

    Jeff
  6. hall316's Avatar
    Posts
    333 Posts
    Global Posts
    334 Global Posts
    #26  
    does this work when making outgoing calls? I have not installed it yet, but just trying the mute, unmute function myself, it did not seem to make a difference in the loudness when making an outgoing call only for incoming calls.
  7.    #27  
    Quote Originally Posted by hall316
    does this work when making outgoing calls? I have not installed it yet, but just trying the mute, unmute function myself, it did not seem to make a difference in the loudness when making an outgoing call only for incoming calls.
    On my HBH660 it makes a big difference on outgoing calls. I have had reports by others as well that his increases the volume on outbound calls.

    Jeff
  8. hall316's Avatar
    Posts
    333 Posts
    Global Posts
    334 Global Posts
    #28  
    I just installed it. No difference whatsoever with my 660 on outgoing, but it does as advertised on incoming calls.
  9.    #29  
    Quote Originally Posted by hall316
    I just installed it. No difference whatsoever with my 660 on outgoing, but it does as advertised on incoming calls.
    Just curious what BT headset are you using? When you make an outgoing call do you see the 5way navigation hightlight move from the hangup control over to the mute control and then back again after you dial the call? If you do not see this happen about 5 seconds after you make the call, then you proably need to adjust the detection time slider until you see this behavior.

    Jeff
  10. hall316's Avatar
    Posts
    333 Posts
    Global Posts
    334 Global Posts
    #30  
    hehe, I use the 660 (as in hbh-660) like in my post. No, I do not see anything happening when I dial out. I even try to do it manually (mute, unmute) and it doesn't change anything. I think I have it on 2 or 3 secs delay. I even wait and see if anything happens and nothing does.
  11.    #31  
    Quote Originally Posted by hall316
    hehe, I use the 660 (as in hbh-660) like in my post. No, I do not see anything happening when I dial out. I even try to do it manually (mute, unmute) and it doesn't change anything. I think I have it on 2 or 3 secs delay. I even wait and see if anything happens and nothing does.
    Well then you need to make the time delay bigger. Try 5 to 10 seconds. It definitely increases the sound level on my 660. (It also does not work for me to manually try it but it does work when BTmute does it.) The trick is getting the headset recognized before BTmute trys to discover the headset. If you have the time set too short then the detection happens before the BT headset gets configured.

    Make sense?

    Jeff

    REEDIT: You are always better off going for a longer time than a shorter one.
  12. hall316's Avatar
    Posts
    333 Posts
    Global Posts
    334 Global Posts
    #32  
    well that seemed to work. when does the timer start? When making a call, does is start when I hit dial? When recieving a call, does it start when I hit the center button? What's weird now is I'm not even seeing it when I recieve a call, yet it's louder. How much is this again, I'm digging it.
  13. hall316's Avatar
    Posts
    333 Posts
    Global Posts
    334 Global Posts
    #33  
    hmm, just noticed something. Normally the Bluetooth indicater is solid blue. So when it is and I recieve a call, the loudness is there even though I don't see anything moving across the screen. But when I place a call, the solid blue indicater gets white. Then the bluetooth headset connects really fast. I have the timer set on 11. Anything under that even though the headset has been connected for the call, your program will not increase the loudness even though I see it moving across the screen. As long as it's on 11 or higher it works. This is no big deal as normally, the call would still be ringing. I've just been calling voicemail as it's too late to call anyone else right now.
  14.    #34  
    Quote Originally Posted by hall316
    hmm, just noticed something. Normally the Bluetooth indicater is solid blue. So when it is and I recieve a call, the loudness is there even though I don't see anything moving across the screen. But when I place a call, the solid blue indicater gets white. Then the bluetooth headset connects really fast. I have the timer set on 11. Anything under that even though the headset has been connected for the call, your program will not increase the loudness even though I see it moving across the screen. As long as it's on 11 or higher it works. This is no big deal as normally, the call would still be ringing. I've just been calling voicemail as it's too late to call anyone else right now.
    You will not see the movement on an incoming call. Only on an outgoing call.

    As for the timing. For outgoing the clock starts on the send button.

    For incoming the timer starts when the call is answered.

    Jeff
  15. hall316's Avatar
    Posts
    333 Posts
    Global Posts
    334 Global Posts
    #35  
    Thanks Jeff. I just sent you payment. Very nice work.
  16.    #36  
    Quote Originally Posted by hall316
    Thanks Jeff. I just sent you payment. Very nice work.
    Your business is very much appreciated. Hope this little application makes your Treo a little easier to use!

    Jeff
  17. hall316's Avatar
    Posts
    333 Posts
    Global Posts
    334 Global Posts
    #37  
    Jeff, been messing with this, when making calls, it only seems to work about every other time now. I'm playing around trying to see if it really is every other time. I think I called my voicemail 50 times last night. Will do some more testing tonight after peak hours.
  18.    #38  
    Quote Originally Posted by hall316
    Jeff, been messing with this, when making calls, it only seems to work about every other time now. I'm playing around trying to see if it really is every other time. I think I called my voicemail 50 times last night. Will do some more testing tonight after peak hours.
    BY "working" do you mean the physical movement of the 5way nav or the increase in volume? Would be interested in your findings. I wonder if you need to exit and re-enter the phone app between calls?
  19. #39  
    Jeff,

    Finally my Motorola HS-850 works thanks to version 1.5. I still need to test incoming calls, but when that is verified, I am sending you $$$.

    Happy Holidays!!

    Jim
  20. hall316's Avatar
    Posts
    333 Posts
    Global Posts
    334 Global Posts
    #40  
    If been changing the timer settings to see if that changed anything. Since my headset connects so fast, it really didn't change much. When it did work, I ended the call and turned the screen off. Then I turned the screen back on and tried dialing again. I never got it to work two times in a row. But it did seem like it would work every other time. I tried to do the mute, unmute trick again after your program worked and then ended the call. I figured since it was working everyother time that might be the trick. Sadly, that was not it. There has to be an obvious trick that we are just not seeing. Like I said, I will try playing with it again later tonight when the unlimited calling starts. I did put the Jabra gels on it and it's loud enough without running this program, but I'd still like to figure out how to get this working for others as well if I would decide to stop using the Jabra gels.
Page 2 of 12 FirstFirst 1234567 ... LastLast

Posting Permissions